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Objectives
= Java Development Tool (JDT)
= Java Perspectives

= Some nice to know features
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Java Development Tool
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JDT is a complete
Development Environment
‘ to create, execute, debug '
and profile Java
Applications

WebSphere ElEl




ASXv5_JavaTools.PRZ Page 4
8/14/02

J_av_a P_e__rspecti\_/e_s an_d_ Default Views_

= Java = Java Type Hierarchy
» Package Explorer » Type Hierarchy can be in its own perspective
» Type Hierarchy or a view within another perspective
> Outline = Debug
> Search » Debug
> Console » Breakpoints
> Tasks > Expressions

= Java Browsing - similar to VAJ Java > Variables

tools > Display

> Projects > Outline
> Packages > Console
> Types
» Members

WebSphere ElEl




ASXv5_JavaTools.PRZ Page 5
8/14/02

Im_p_ortant_ Java_T_ooI Fe_ature_s

= \Views
» error ticks everywhere
» Packages view optionally shows members; working set filtering
» Type hierarchy scoped to packages and projects

= Editor

» parameterized templates
» bracket matching as user types
» structured selection support

= Code Assist - assist in generating code, options
»New: method argument hints; indicate deprecated methods, JavaDoc hints

= JUnit Integration

= Search Facilities - File Search, Java Search and Help Search
» Scope to a working set
» Search in hierarchy
» Read/Write access to fields
»find matches in binaries, inner classes
» Search References, Declarations, Implementors
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Refactoring

= Refactoring is behavior-preserving program transformation
» Make a system-wide code change without affecting the behavior of the system
— JDT automatically manages the changes
= Refactoring functions
» On Class, Interface
— Rename
- Move
» On Method
= Rename
= Pull-up
» On Field
= Rename
= Pull-up
— Self Encapsulation
= Can have Refactor with or without preview (set in Windows Preferences)

= ntegrated with drag & drop
= Extract local variable can replace all occurrences of an expression
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Java Launch Configurations

= | aunch configurations in Run or Debug mode

Create, manage, and run launch configurations

Launch Configurations: Marme: | Test

=23 Java Application

5 AlTests -
O Main |M= Argumments | Ml RE| 14 Classpath | B Source | %% Common
-4 Java Bean
E-du JUnit Project:
b gy AlTests (1) -
=@ Run-time Workbench I Lt =
@ Run-time Workbench
E—Jﬁt Server Main class:
Bk WASSORemote
-3k WebSphere v5.0 Test Er | Test =

----- Wl WebSphere v4 Application € ™ Jrelude external jars when searching for a main class
----- %8 WebSphere vS Applcation C
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Generating JavaDoc

= Right click the on class type or members and apply "Add JavaDoc Comment" action

= Can modify the template being used
—Edit template variable "typecomment” from Window > Preferences > Java > Templates

= Generating JavaDoc creates the shell of the JavaDoc - you fill the necessary information

¥ | = W E7 %Y || < 3P W8 [E 3 ™8] 4%

ERt &
My
B
Mlla 2 & |a o Open
] || =& HeloEBClient Open Type Hierarchy
® || - HeloEBean o
14| 8- IncrementEIBean - X
4| =@ Wit R
o E'E (default packag Paste #@author Administrator
- java Delete To change thi= generated comment edit the templat
;3: ot Refactor Window:Freferences:Java:Tenplates.
= i To enable and disable the creation of type commen
I : Window:FPreferencez:JavarCode Generation.
/0] i Company ;. IBHM
@ jsMod  Export... ublic class |
=8 junit.extension: Override Methods

-] ActiveTests

: Add Constructors from Superclass

#- [J] ExceptionT¢ g T e :

: Yl AV adoc |:_:|:::| TITIENT

m RepeatedT A Java men

m- [ TestDecora Add Bookmark -
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Publishing JavaDoc
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= Setup the JavaDoc command to use for export

— Window > Preferences > Java > JavaDoc

= Export > JavaDoc

— Select the project you want to create the JavaDoc and directory
— Options to generate use page, hierarchy tree, navigator bar, index, etc.
= Option to select your own Style sheet, and to add an overview HTML page

Javadoc Generation

Select types for Javadoc generation,

Select types for which Javados will be generated:

Javadoc Generation

Configure Javadoc arguments for standard doclet,

" Private

Destnaton:

Create Javados for members with visibili:

" Package " Protected

& | ze Standard Doclet

=-[F]@ Uit =
#-[#]8 (default package) ¥ Docurment tide: | This is a Title
F-[A]8#  junit.extensions Basic Options i
#-[]8  junit.framework
o M Generate use page WV @a
""E junit.samples W Generate hierarchy tree W i@ne
#-[7]8 junit.samples.money W Generate navigator bar v @ik
""E junit, tests W Generate index W ¢
F-[A] ot textu WM Separate index per letter

H-[ @ MaDaterPfleae App310 hd

& Public Select referenced classes to which Javadoc should create i

[} WS ADVEBetaheclipse\jretlibhyrt jar - Mot Configu

I coAbmphdoc

B
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Debugger features you might not know abou

< [Emply Vector - VectorT est i
< fFull Vector - VectorTest

@ fall] void - Assert

@ faillString message) void - Assert

& finalizefl woid - Object

] [c TR

'@Facto COdemﬂln _Ij—
| Display View

brbicn 2

I 3E v ariables : IE ﬁﬂml? =
=oa thige junitsamples VectoTost [id=32) —
=@ [Ermplps java chlVecka [id=34]
COEN I ol Vsl [id=43]
=om Mama="heClons’
e P toString support =
15 Eii 3 :
| Wariales Braskgoints | Display Exeessions - Wlelcome. I [J] YectorTest java X l J] TesiCase.jav.
return new .
_ _ value hovering
public void
int Sj_.z= Full =1zel ).

for - —-=0: 1 ¢ 100: i++
f ElEInEen tinew Int
azzertTrue(fFull =sizel() == 1[
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Editor and code assist features you might not know about

* Run= the bare test seguence.
* @egception

{3 Exception

{3 FuntimeException

JavaDoc code assist

~.

public void runBsre() throws Ezception.
==tUp();

-

public TestResult runi) {

TestEe=sult

vold zomeMethod() {
Funnable r= new Funnable

RuntimeException {

run(result ) ez TestResul
return res|iedfesnl - Testfeult

b

e X3
#* Run= the tes
*

public woid »

result  runi
¥

SR
# Runs the ban

variable name
suggestion

void somsMethod

83 Runnablel] dnonymous [nner Type

anonymous inner type code
completion (inserts method stubs)

public class Te=stSuite implements Test

private Vector {Teszts== new Vector(l0;
private String fHame:

< clone[] Object - Object
@ equalz(Object obj] boolean - Object
< finalizel] void - Object
@ hazhCode(] int - Obje

& TestSuite - junit frame d&l Hatl on
code assit (insarts

o

templates with variable name
guessing

inherited method
declaration)

int[] 1ia:
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For - iterate over amay a | {for fint i =00 < ialength; i++) { +
for - iterate ower array w temporary variable
for - iterate ower collection

Argument hints and _
proposed argument names

boolean enrected, boolean actual |
WE . actual);
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View features you might not know about

Higrarchy : junit framework: .
: ’.':'ff-‘ﬁ|@¢5"3.'x
1‘;’- org.eclipze.jdt launching i3 -
ERCT =158 orgeclpse jdt ui
b B TestCase E@ o .
o TestFaiure E A
g E— e
...... @ TestSuite . I E ..... compare
5 © Thowable e e e x| EeEs diglogs
=@ Eror o B juni framewark g f:lnd
o {3 AssertionFaledEn B“Z  import declarations -3 - jarpackager
ol { il = (3" TestCase S |avaed|tal.
------ m  fName: String B ackage:ewm -
L T Y I ookmarkAction.ja:
open type hierarchy : IESEEBSEP&, ; 3 ) BinaMgectEiter isva
P O (-~ estCaze(Shing ;
onapackage/project | | 0 . guntTestCases( " 3| package name
""" bl . 2. [3)| compression
------ @ name) L . |I|
------ o mwn) override T
------ @ .. mun[TestResult |nd| cator
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Q_t_h_er f_eatures you m_ig_h_t not know abo_ut |

= Debugger
» run code with errors
» automatic suspend in debugger when error is encountered

» method entry/exit breakpoints
» variable changed indication in Variables view

= [mport management — automatic import on...
» code assist type completion
» override methods, getter setter generation
> refactoring

= Compare

» structure compare for .java and .properties files
» option for ignore white space — in Java structure compare ignores formatting and comments
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Summary

= \WSSD provides a very powerful and flexible environment to create and debug
Java applications

= Integrated profiler assist developer to find performance bottlenecks at the class
and method level

= Only few of the many functions exposed here
= Help documents the detail of many of the features
= Hands-on labs and tutorials are best way to explore these powerful features

WebSphere ElEl



ASXv5_JavaTools.PRZ Page 15
8/14/02

Appendix
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J_ava B_uild Path |

= From Project > Properties panel
» Define compile dependencies

Select Class Path

order and what to
Select Dependent Select Dependent include when Export is
Select Source Folder Projects JARs selected on this

Project
- Irfo va Build Path /

- Beaninfo Path ) ’ R Ve -
~External Tools Builders & 50urce|  Projects | Ml Libraries i 11 Order and Export'
- Java Buid Path 18Rs and class folders on the build path:
“Javadoc Location [ pF | 1R - C:\WSADVSBeta\edipse\jrelibyrt jar Add JARs..| From within workbench
- Java JAR Dependencie = 1
- Project References Add External 1&Rs, | External to workbench
X T
Add Variable... | JAR based on a defined
variable
Advanced. .. 1l
Add other class folders
Edit. . to classpath
= |
Attach Source.
Remoe
4| | i3
Build output folder: .
: Class Output folder SRS
4 | ¥ |J|._Jr'||t Browse... £ ESETE
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Other useful funcﬂons

I & F M OE N OE E B N BB N RN EN E B N E N N N EF T BN EE & BN FE N E N R NEYEEE®EFE SN E N E SN RN RN ® RN ENENENNENEYN RN N

= Scrapbook Facilities

= Compare and/or Replace Functions
» From Local History or Team Repository
= Organize Imports
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= Allows evaluating and testing snippets of code

e e 2 BE Y §
i Xl mCE"EICreateaScrap:I:u:n:ukPage|

Create Java Scrapbook Page @ e
Create a new Java scrapbook page.
[

Enter or select the folder:

I Calculstoricals

B3 org
- e EJB11YAJ40 J
o EJEY 8040

£
£
Eﬂ---ﬁ JHTows
£

o JKToysEJBT ]

w8 T oedo

File name: I myScraphbook ﬂ Calculator java
String alpha = null;
alpha = IIaII + IIEII ;
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Local History of Code Changes

= Compare, replace, or add code from local repository
» Independent from team repository
» Customize size of local history through Workbench properties

- % Replace Java Element from Local History x|
Local History of 'Calculstor!
EHEP Aug 31, 2001
e (D F1S01 PM
{3 Java Source Compare ISt
iarkbench Local History CAug 31, 2001 3:19:01 PM)
private float ivEegister = 0; ;l
private String[] walidOp=s = {"+"., "="., "~ private float ivRegister = 0:
private String[] walidOp=s = {"+", "=".
W
#* Get= the ivRegister g )
# @return Feturns a float * Get= the ivRegister
*. * Mreturn Returns a {loat
public float getlvREegister() { *.7
return ivREegi=ster: publizc float getlIvREegister() {
1 return ivREegi=ster:
P = 3 *
* S=t= the ivRegister L =
#*# Mparam i1vHegister The ivRegister to =t * Set= the ivRegister
*®. * Mparam i1vRegi=ter The ivRegister to g
public wolid setlvRegister{float ivRegis=tex *.7
thi=. ivEegi=ter = ivHEegister: public void setlvRegister(float ivRegi=f
String alpha = null: thi=. ivEegister = ivREegister;
alpha= "a"+"b": *
r
T =
1| | | 1 | ia
Eeplace I Cancel | -
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Building Projects - Triggers

= BU||d triggerS - When (0] bU||d Preferences
» Automatic on file "Save" ¥ Preferences
— Default Global atiibute— [ Walnah workbench
> Manual E'L;Itl: o @erfnrm build autcrmatically on resource modificatios

+- Debug it : !
: [T Save all modified resources automatically prior to man

= Build per project
e Incremental or Full
— Build for all projects

¢ [ncremental or Full

W Link Navigator zelection to active editar

Navigator
View

Note H e R, BT | [J] Get:
i - lae AuctionFunEJB ;‘ imp
Incremental Build 1o T imp
available only if T A Mew b
"Automatic” build on file w-1# Dal  Golnta
. Lot
Save is turned OFF H e BE GoTo b
ﬁ EJE Open Perspective 3
-t R
1= Rs  Copy
e Ser Move
- ¥ Java - Application Developer . ﬁ Ao Renanme
File Edit Perspective | Project Debug ‘Window Help Elﬁ 208 Delete
T e : _ &
= - | B B | By | Gy Buid CtrHE Incremental Build  |q_ | % Open Projact
= Febuild Al I Close Project
N —— [® OpenType...  CteShift4T Full Build el \ Build
a7 -l AwctionRur : —a ———Rebuild All = ==
llmg e Tl import java e E5n




Building Projects with ANT

= ANT: Open source Java based equi
> ANT scripts written in XML

= ANT documentation
> hitp://jakarta.apache.org/ant/index.html
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valent of make

B} Packages = o i w X :@ tnake . xml 2 |

=-las Calculator 1<?zml wersion="1.0"7:
: , . 2
m‘ JRE_LIE - = 1Pragram FilesYE B project name="Calculator" default="compile" basedir="."
- calc
-} org.eclipse jot internal eval t3 5¢|—— ==t global properties for thi= build —:
------ X7 B<property name="src"' walus="."

w158 defaultClien e vy name="build" walus="_" -

#-la EJB11VAMM  GoTo B s s iy

- JKToysinter Open bate the time stamp —:3

[+-la MigratedFre  Open With &l

[+ Ta MyBankEJE >

Build Projeck
Rebuild Project
Refresh From Local

Rename

Copy

Mowve

Delete

add Bookmark

% Run o Server

- Team k
m Zompare Witk b
Replace With b

name="conpile" depend=s="Calculator":

lpile the java code from F{src} into {build} ——:
trcdlir="5%{=src}t" destdir="{build+" -

*

Lo




