• Re: New issue with BinkP

    From PSI-JACK@46:1/142 to ALL on Thu Jan 31 19:20:24 2019
    On 09/07/14, Psi-Jack said the following...

    My NC emailed me today saying that he can't connect as he's getting,
    from his Irex, "malformed command".. Now this issue literally started
    out of the blue, and now when I try to connect to him, all I get is a session timeout, and he says on his end it's reporting a malformed command.

    Anyone here ever experience that, and know what may be causing it, cause there's been no actual change on my side, and I have other BinkP sessions working just fine.

    So, what it seems like, is that the NC, when sending a Netmail to the Allfixlist@theirnodeaddress, his system simply sends a file back, no netmail, just a file, and Mystic's BinkP doesn't know how to handle that. I was able to setup and run BinkD enough to connect, retrieve just the 1 file that was pending, and all was well suddenly, no more issues.

    So, g00r00, this sounds like a specific bug on Mystic at the moment, not being able to handle that. If you can help me get DEBUG logs on fidopoll as needed, and what kind of information you need, I can get you all the logs for
    diagnosis and research. I can also get you the binkd debug logs so you can see what goes on with a successful transaction similarly, since that's the only
    way it was working.

    [Psi-Jack -//- Decker's Heaven]

    --- Mystic BBS v1.10 A51 (Linux)
    * Origin: Decker's Heaven * deckersheaven.com (46:1/142)
    Synchronet thePharcyde_ >> telnet://bbs.pharcyde.org (Wisconsin)
  • From SKUZ@46:1/102.9 to PSI-JACK on Thu Jan 31 19:20:24 2019
    On 09/07/14, Psi-Jack said the following...

    My NC emailed me today saying that he can't connect as he's getting,
    from his Irex, "malformed command".. Now this issue literally started

    Anyone here ever experience that, and know what may be causing it, cause there's been no actual change on my side, and I have other BinkP sessions working just fine.

    I've posted several threads with Logs on both sides, on the irex "Malformed command" and Mystic 'Timed out' issue in the past few months. Either nobody
    has reproduced it, or has any input ideas about what is causing it or how to fix it. Anyway, I see it all the time in my irex logs when connections are
    made with mystic. Pray tell us.. what is your theory Jack .. Inquiring minds, really want to know, .. trust me. ^^^^^^
    (:

    --- Mystic BBS v1.10 A51 (Linux)
    * Origin: fluph.darktech.org:2313 (46:1/102.9)
    Synchronet thePharcyde_ >> telnet://bbs.pharcyde.org (Wisconsin)
  • From G00R00@46:1/127 to PSI-JACK on Thu Jan 31 19:20:24 2019
    So, g00r00, this sounds like a specific bug on Mystic at the moment, not being able to handle that. If you can help me get DEBUG logs on fidopoll as needed, and what kind of information you need, I can get you all the logs for diagnosis and research. I can also get you the binkd debug logs so you can see what goes on with a successful transaction similarly,
    since that's the only way it was working.

    All of those might be helpful so feel free to e-mail whatever you have.

    Nothing anyone has sent me has been consistent so far, and I cannot reproduce it with the two versions of IREX I sed. Off the top of my head my guess its its IREX incorrectly using 1.1 binkp when it shouldn't be, since it seems to 100% specific to IREX (as most binkp problems are lol)

    --- Mystic BBS v1.10 A52 (Windows)
    * Origin: Sector 7 [Mystic BBS WHQ] (46:1/127)
    Synchronet thePharcyde_ >> telnet://bbs.pharcyde.org (Wisconsin)
  • From G00R00@46:1/127 to SKUZ on Thu Jan 31 19:20:24 2019
    I've posted several threads with Logs on both sides, on the irex "Malformed command" and Mystic 'Timed out' issue in the past few months.

    Can you point me to where you posted these logs recently?

    --- Mystic BBS v1.10 A52 (Windows)
    * Origin: Sector 7 [Mystic BBS WHQ] (46:1/127)
    Synchronet thePharcyde_ >> telnet://bbs.pharcyde.org (Wisconsin)
  • From SKUZ@46:1/102 to G00R00 on Thu Jan 31 19:20:24 2019
    On 09/10/14, g00r00 said the following...

    Can you point me to where you posted these logs recently?

    Sure, AGN_DEV subject: malformed command

    --- Mystic BBS v1.10 A51 (Windows)
    * Origin: fluph.darktech.org (46:1/102)
    Synchronet thePharcyde_ >> telnet://bbs.pharcyde.org (Wisconsin)
  • From G00R00@46:1/127 to SKUZ on Thu Jan 31 19:20:24 2019
    Can you point me to where you posted these logs recently?

    Sure, AGN_DEV subject: malformed command

    Thanks I took another look. Still makes me think its trying to run in BINKP 1.1 mode when the session isn't.

    I guess in A52 I can try to put a bunch of that debug logging in so we can
    try to see whats going on for sure, assuming you would be able to reproduce
    new logs of this issue?

    --- Mystic BBS v1.10 A52 (Windows)
    * Origin: Sector 7 [Mystic BBS WHQ] (46:1/127)
    Synchronet thePharcyde_ >> telnet://bbs.pharcyde.org (Wisconsin)