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Preface

Purpose

This guide provides all the information that you need to use the IBM DB2 OLAP
Server Spreadsheet Add-in for Lotus 1-2-3. It explains the features and options
and discusses the concepts, processes, procedures, formats, tasks, and examples
that you need to use the software.

IBM DB2 OLAP Server Version 8.1, known as Essbase 6.5 in this guide, is an
online analytical processing (OLAP) solution that satisfies the complex
calculation requirements of financial, accounting, and marketing professionals.
Essbase operates in a client-server computing environment on a local area network
(LAN). In this environment, multiple users can use their desktop computers to
retrieve and analyze centralized data.

You can create reports from the data residing on the Essbase server in several

ways:

e Generate database reports through a spreadsheet interface, called Essbase
Spreadsheet Add-in, as explained in this guide.

e Use Essbase Application Manager Report Writer to create a report script and
run a report. For more information, see the Essbase Database Administrator’s
Guide.

e Use Essbase Application Programming Interface (API) to create and run
database reports. For more information, see the Essbase API Reference in your
docs directory.

e Use reporting tools, such as Hyperion Reporting for Essbase.

Essbase Spreadsheet Add-in for 1-2-3 M vii



Preface

Audience

This guide is for Essbase end users who are responsible for some or all of the
following tasks:

Starting Essbase and connecting and disconnecting from Essbase databases
Retrieving data from a database into a worksheet

Drilling down, drilling up, and navigating through a worksheet to analyze and
arrange data from multiple viewpoints

Working with linked reporting objects and linked partitions
Updating data on the Essbase server

Using the worksheet to load and calculate data in the database
Creating multiple sheets from data

Working with currency conversions

Document Structure

The main sections of this guide are structured as tutorials that take you
step-by-step through basic and advanced tasks in Essbase Spreadsheet Add-in.
This document contains the following information:

viii Wl

“Introducing Release 6.5 on page xv provides information on migrating from
previous versions of Essbase to Release 6.5 and lists all new features and
enhancements.

Chapter 1, “Introducing Essbase,” introduces you to basic concepts of
retrieving and manipulating data through the spreadsheet interface.

Chapter 2, “A Basic Essbase Tutorial,” provides a step-by-step tutorial of
basic data navigation, ad hoc retrieval, and reporting techniques.

Chapter 3, “An Advanced Essbase Tutorial,” describes advanced reporting
and retrieval techniques for users that need special reports or formatted data
views.

Essbase Spreadsheet Add-in for 1-2-3
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e Chapter 4, “Using Drill-Through,” provides a brief overview of the Essbase
Integration Services drill-through product.

e The Index contains a list of terms and their page numbers. Select or look up
an index entry to view the page to which the entry refers.

Note: The Essbase Spreadsheet Add-in online help provides a comprehensive section
on Essbase Spreadsheet Toolkit. This section enables you to customize and automate
your use of Essbase by using Lotus 1-2-3 macros and Visual Basic for Applications
(VBA) functions. For more information on the Essbase Spreadsheet Add-in online help,
see “Accessing Online Help” on page 35.

The Essbase Spreadsheet Add-in User’s Guide for Lotus 1-2-3 is provided in the
\Hyperion\Essbase\docs\pdf directory in .pdf format for online viewing
and printing in Adobe® Acrobat Reader® (Release 3.0.1 or higher). The . pdf file
is named Ess123w.pdf. You can download Adobe Acrobat Reader from the
Essbase CD-ROM or from http: / /www.adobe . com. On the Essbase CD-ROM,
the Acrobat Reader executable file is located in the Adobe directory under the
appropriate platform and language-version subdirectories. To install Adobe
Acrobat Reader, launch the executable file, follow the prompts, and provide the
information requested.

Sample Databases and Files

This book provides tutorial steps that are based on sample databases and files that
are provided with the Essbase server software. You use the Sample Basic database
for most tasks in Chapter 2 and Chapter 3. You use a sample Essbase Currency
Conversion application for the section on currency conversion. See Chapter 3, “An
Advanced Essbase Tutorial.” For information on the Sample Basic database, see
Chapter 2, “A Basic Essbase Tutorial.”

In addition to these sample applications and databases, you also use several sample
Lotus 1-2-3 files in the advanced tutorial in Chapter 3. The individual at your
organization who installs the server is responsible for making these applications,
databases, and files available to you. Contact the Essbase system administrator for
more information.

Essbase Spreadsheet Add-in for 1-2-3 H ix
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Related Documentation

When you licensed Hyperion Essbase, you received the following printed
documentation:

x H

The Essbase Installation Guide, which shows you how to install and configure
the Essbase server, Essbase Spreadsheet Add-in, Essbase Application
Manager, Essbase SQL Interface, Essbase API, Runtime Client, and sample
applications.

The Essbase New Features booklet, which describes the new features that
have been added for this release of Hyperion Essbase.

In addition to the printed documentation and this Essbase Spreadsheet Add-in
User’s Guide for Lotus 1-2-3, you have access to the following online
documentation:

The Essbase Migration Guide booklet, which provides the steps necessary to
upgrade from earlier releases and migrate from one platform; for example,
such as Windows 2000 to Solaris.

The Essbase Documentation Roadmap, which lists all the Essbase
documentation and tells you how to access the online information.

The Essbase Quick Path Card, which provides an overview of the tasks
involved in creating, using, and maintaining Essbase databases.

The online Essbase Database Administrator’s Guide in the docs directory,

which explains the architecture of Essbase, how to design databases, how to

design calculations, how to set up Essbase security, how the database is stored,
and how to optimize Essbase.

The Essbase Application Manager Online Help file, which explains how to
use the Application Manager user interface.

The Technical Reference in the docs directory, which lists and describes
Essbase functions, calculation commands, report commands, ESSCMD
commands, and configuration file (. c£g file) settings.

The , which explains how to use Essbase Spreadsheet Add-in features with . This
guide is provided in the \Hyperion\Essbase\docs\pdf directory in . PDF
format for online viewing and printing in Adobe Acrobat Reader (Version 3.0.1 or
later). Adobe Acrobat Reader is provided on the Essbase CD-ROM, and can also
be downloaded from http: //www.adobe.com.
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The Essbase Spreadsheet Add-in online help files, which explain how to use
Essbase Spreadsheet Add-in, and provide all the spreadsheet macros and VBA
functions.

The API Reference in your docs directory, which lists and describes
programmatic functions available through the Essbase API, and provides
information to help you start programming with these functions.

The Essbase SQL Interface Guide, which contains information on how to
set up systems to load data by means of Essbase SQL Interface. This guide
is provided in the \Hyperion\Essbase\docs\pdf directory in . PDF
format for online viewing and printing in Adobe Acrobat Reader
(Version 3.0.1 or later). Adobe Acrobat Reader is provided on the Essbase
CD-ROM, and can also be downloaded from http: //www.adobe . com.

The Essbase Adminstration Services Online Help which you can access
by launching Essbase Administration Services and clicking Help in the
main menu.

Accessing Hyperion Documentation

All Essbase and Essbase Spreadsheet Add-in documentation is accessible from the
following locations:

You can access online Essbase documentation from the Information Map, an
HTML file. To open the Information Map, launch the essdocs . htm file located
in the ARBORPATH/docs directory.

Online help is accessible from the Spreadsheet Add-in. Start the product and
click the Help button or menu command.

The Hyperion Solutions Web site is located at ht tp: / /www. hyperion. com.
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» To access the documentation from the Hyperion Solutions Web site:
1. Logontohttp://www.hyperion.com.

2. Select Support from the menu bar.

Tip: Enter your username and password, and click Login. If you do not have a
username and password, click New User Registration on the left side of the login
page to request them.

Select Order/Download Documentation.
From the Product list box, select Hyperion Essbase OLAP Server.

From the Display list box, select Documentation, then click Submit.

Online Help

To access online help, click the Help button in any Essbase dialog box or select
Essbase Help from the Essbase menu.

To print an online help topic, display the topic and select File > Print, or right-click
and select Print from the pop-up menu.

To access HTML documentation, from the Start menu, select Programs >
Hyperion Solutions > Hyperion Essbase 6.5 > OLAP Server Documentation.

Note: You must have first installed HTML documentation to access it.

Online Guides

Online guides are electronic versions of printed documentation.

To display an online guide, start Adobe Acrobat Reader, and then open one of the
Essbase .pdf files located in your \Hyperion\Essbase\docs\pdf directory.

xii W Essbase Spreadsheet Add-in for 1-2-3
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The following table shows the conventions that are used in this document:

Table i: Conventions Used in This Document

Item

Meaning

»

Arrows indicate the beginning of a procedure, which
consists of one or more sequential steps.

Brackets [ ]

In examples, brackets indicates that the enclosed
elements are optional.

Bold Bold text indicates words or characters that you type
exactly as they display on the page. Bold in procedural
steps highlight major interface elements.

CAPITAL LETTERS Capital letters denote commands and various IDs.

(Example: CLEARBLOCK command)

Example text

Courier font indicates that the material shown is a code
or syntax example.

Ctrl + 0

Keystroke combinations shown with the plus symbol
(+) indicate that you should press the first key and
hold it while you press the next key. Do not type

the + symbol.

Courier italics

Courier italic text indicates a variable field in command
syntax. Substitute a value in place of the variable shown
in Courier italics.

Italics

Italics in a product-related term in the body of a book
indicates that the term is included in the glossary of
the book.

Ellipses (...)

Ellipsis points indicate that text has been omitted from
an example.

Mouse orientation

This document provides examples and procedures using
a right-handed mouse. If you are using a left-handed
mouse, adjust the procedures accordingly.

Essbase Spreadsheet Add-in for 1-2-3
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Table i: Conventions Used in This Document (Continued)

Item

Meaning

Menu options

Options in menus are shown in the following format:
Menu name > Menu command > Extended menu
command

For example: File > Desktop > Accounts

The variable n indicates that you must supply a generic
number; the variable x indicates that you must supply a
generic letter.

xiv Il
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Introducing Release 6.5

This chapter provides compatibility information for Essbase Release 6.5 and
previous releases of Essbase, including migration information and new feature
descriptions and enhancements. It contains the following sections:

e “Migrating to Release 6.5 on page xv

e “What’s New in Release 6.5” on page xvi

Migrating to Release 6.5

As you migrate (upgrade) from previous releases of Essbase to Release 6.5 (DB2
OLAP Server Version 8.1), keep in mind that Release 6.5 of Essbase Spreadsheet
Add-in is designed to work with Release 6.5 of the Essbase server. If the Essbase
system administrator upgrades the Essbase server to Release 6.5, Release 5.x of
Essbase Spreadsheet Add-in works on only a limited basis. Upgrade to Essbase
Spreadsheet Add-in for Release 6.5 as soon as possible.

Read the Essbase Installation Guide for detailed information about migrating from
previous releases of Essbase.

Essbase Spreadsheet Add-in for 1-2-3 H xv



Introducing Release 6.5

What’s New in Release 6.5

xvi

Hybrid Analysis

With Hybrid Analysis, Essbase supports retrieval of data from a external relational
data source. By enabling Hybrid Analysis in Essbase Integration Services, a
portion of database cell values are computable from an external relational source,
instead of being loaded into an OLAP Server database. Hybrid Analysis allows
access to lower level data that is too large to load into an OLAP Server database.

You need to license Essbase Integration Services to build Hybrid
Analysis-enabled metaoutlines.

Support for Negative Numbers in Filter Criteria in EQD

Essbase Query Designer (EQD) provides the ability to design queries with filtering
criteria. With Release 6.5, EQD supports the use of negative numbers in the
filtering criteria.

Enhanced Keyboard Accessibility in EQD

Keyboard accessibility for EQD is greatly enhanced in Release 6.5. When
launching EQD, focus is set to the first item in the tree in the navigation panel.
From there, users can access most EQD functionality using the keyboard. For
more information see the Spreadsheet Add-in online help on EQD keyboard
shortcuts.

Essbase Spreadsheet Add-in for 1-2-3



Introducing Essbase

Essbase is multidimensional database software that is optimized for planning,
analysis, and management reporting applications. Essbase uniquely blends an
innovative technical design with an open, client-server architecture. Essbase
enables you to extend your decision support systems beyond ad hoc queries and
reports on historical performance to dynamic, operational systems that combine
historical analysis and future planning. By consolidating and staging historical and
projected data for detailed analysis, you gain perspectives about your business that
enable you to take appropriate actions.

Essbase provides both power and flexibility. Thus, it can be used for a broad range
of online analytical processing (OLAP) applications including the following:

e Budgeting

e Forecasting and seasonal planning

e Financial consolidations and reporting

e Customer and product profitability analysis
e Price, volume, and mix analysis

e Executive information systems (EIS)

Essbase enables you and others in your organization to share, access, update, and
analyze enterprise data from any perspective and at any level of detail without
learning new tools, query languages, or programming skills.

Essbase Spreadsheet Add-in for 1-2-3 M 19
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Typical Users of Essbase

Essbase is designed for use in many different applications. Financial analysts have
found Hyperion Essbase to be invaluable in budget analysis, currency conversion,
and consolidation. Cost accountants apply the powerful capabilities of Essbase to
evaluate allocation and elimination scenarios. Product managers and analysts use
Essbase to plan and analyze multiple product lines and distribution channels.
Essbase can also be used as a repository database for spreadsheet data. Anyone
who uses a spreadsheet is a potential user of Essbase.

Because Essbase is applicable to such a broad variety of environments, individuals
using it at your organization may fill one or more roles in implementing and
running applications. This guide refers to specific roles by three titles. However,
in actuality, a role may be performed by one person or by several people working
collaboratively.

o Essbase system administrator. The Essbase system administrator typically has
experience in networking, installing software packages, and administering
system functions. In addition to installing the Essbase software, the Essbase
system administrator may also set up Essbase user accounts, set up the
security system, and maintain the Essbase server.

e Application designer. The application designer sets up the Essbase database,
creates the database outline, and develops calculation and report scripts.
The responsibilities of the Essbase system administrator and the application
designer may overlap in some areas. The application designer has probably
developed spreadsheet or database applications and understands the
operational problems and the tools being employed to solve them.

e User. The user interacts with Essbase databases through spreadsheets, using
Microsoft Excel for Windows or Lotus 1-2-3. Users are typically analysts and
managers who use spreadsheet programs as their primary tool for viewing and
analyzing data.

20 m Essbase Spreadsheet Add-in for 1-2-3



Introducing Essbase

Components of the Client-Server Environment

Client-server computing refers to the architecture in which individual PC
workstations are connected to a powerful server by means of a local area network
(LAN). The PC workstation acts as a client by requesting data from the server. The
server processes the request and returns the desired result to the client.

Essbase is built as a client-server system. System performance and multiuser
capabilities are greatly enhanced in the Essbase client-server environment.
Figure 1 illustrates the Essbase components and their relationships.

Figure 1: Essbase Components

The Server

Essbase server is a multidimensional database that supports analysis of an
unlimited number of data dimensions and an unlimited number of members within
these dimensions. Developed using a true client-server architecture, all data, the
database outline, the calculations, and the data security controls reside on the
Essbase server.
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Introducing Essbase

The Essbase server operates on Windows 98, Windows NT 4.0, Windows Me,
Windows 2000, and UNIX operating systems.

Essbase Spreadsheet Add-in

Essbase Spreadsheet Add-in is a software program that merges seamlessly with
Microsoft Excel and Lotus 1-2-3. After Essbase is installed, a special menu is
added to Lotus 1-2-3. The menu provides enhanced commands such as Connect,
Pivot, Drill-down, and Calculate. Users can access and analyze data on the Essbase
server by using simple mouse clicks and drag-and-drop operations. Essbase
Spreadsheet Add-in enables multiple users to access and update data on the
Essbase server simultaneously.

The Network

Essbase runs on PC-based LANS that support the Named Pipes or TCP/IP
protocol.

Note: Supported network environments and technical requirements are discussed in
detail in the Essbase Installation Guide, which is included with the Essbase server
package.

Essbase Application Products

22 |

Several optional products, designed to extend and enhance the scope of
OLAP applications, can be addressed using the Essbase server. The following
sections describe these products.

Essbase Spreadsheet Toolkit

Essbase Spreadsheet Toolkit includes over 20 macro and Visual Basic for
Applications (VBA) functions that enable you to build customized Microsoft
Excel and Lotus 1-2-3 applications. The applications incorporate Essbase
commands. Commands such as EssCascade, EssConnect, and EssDisconnect
provide all of the functionality of their corresponding Essbase menu commands.
For more information, see the Essbase Spreadsheet Add-in online help.

Essbase Spreadsheet Add-in for 1-2-3



Introducing Essbase

Essbase Partitioning Option

Essbase Partitioning option enables you to define areas of data that are shared

or linked between data models. Partitioning can affect the performance and
scalability of Essbase applications. Partitioning provides more effective response
to organizational demands, reduced calculation time, increased reliability and
availability, and incorporation of detail and dimensionality. For more information,
see “Accessing Linked Partitions” on page 190.

Essbase Structured Query Language Interface

Essbase SQL Interface enables access to PC and structured query language (SQL)
relational databases by making the Essbase server operate as an open database
connectivity client. Using Essbase SQL Interface, data can be moved easily from
these diverse corporate data sources into the Essbase server for user access and
analysis. For more information, see the Essbase SQL Interface Guide.

Essbase Application Programming Interface

Essbase Application Programming Interface (API) enables application developers
to create custom applications quickly by using standard tools while taking
advantage of the robust data storage, retrieval, and manipulation capabilities of
Essbase. Essbase API supports Visual Basic and C. For more information, see the
API Reference in your docs directory.

Essbase Currency Conversion

Essbase Currency Conversion translates, analyzes, and reports on foreign financial
data. Any exchange rate scenario can be modeled, and you can even perform ad
hoc currency conversions of data directly from the spreadsheet. The Currency
Conversion product is compliant with Financial Accounting Standards Board 52
(FASBS52). For more information, see “Working with Currency Conversions” on
page 203.

Essbase Integration Services

Essbase Integration Services works with Essbase, Microsoft Excel, and

Lotus 1-2-3. Essbase Integration Services is a suite of tools and data integration
services that serve as a bridge between relational data sources and the Essbase
server. Integration Server drill-through is one of the tools of Essbase Integration
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Services. Using Integration Server drill-through, you can view and customize
spreadsheet reports that display data retrieved from relational databases. For more
information, see Chapter 4, “Using Drill-Through.”

Hyperion Objects

Hyperion Objects are ActiveX controls that enable you to build application
programs quickly and easily to access and manipulate data residing in Essbase
servers. You can combine objects with other controls in a visual design
environment to construct new programs.

The Multidimensional Database

The Essbase multidimensional database stores and organizes data. It is optimized
to handle applications that have large amounts of numeric data and are
consolidation-intensive or computation-intensive. In addition, the database
organizes data in a way that reflects how the user wants to view the data.

Definition of Multidimensional

A dimension is a perspective or view of a specific dataset. A different view of
the same data is an alternate dimension. A system that supports simultaneous,
alternate views of datasets is multidimensional. Dimensions are typically
categories such as time, accounts, product lines, markets, budgets, and so on
(see Figure 3). Each dimension contains additional categories that have various
relationships one to another.

In contrast to the multidimensional view, worksheets stores data in two
dimensions, usually time and accounts, as follows:

Figure 2: Two-Dimensional Representations of Data in a Worksheet

A [ B [ € [ o [ E T F T 6 ]
1| Jan Feb Mar Apr May Jun
2 |Sales 1212 1421 1354 1178 1254 1465
'3 |[COGS 345 352 387 321 320 401
' 4 | Margin 857 1029 =t a57 934 1064
]
| 6 |Marketing 45 24 a5 1 56 ]
| 7 |Freight 21 71 a3 23 a5 21
| 8 |Discounts 2 24 52 14 53 jte]
| 9 | Total Expenses =iz 118 240 48 197 g5
10
|11 | Gross Profit 758 210 72T a09 737 979
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An Essbase application contains an unlimited number of dimensions, so you can
analyze large amounts of data from multiple viewpoints. The following illustration
shows four views of multidimensional data. You can retrieve and analyze the data
with the Essbase Spreadsheet Add-in software:

Figure 3: Multiple Views from a Five-Dimensional Database
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Database Outlines

Understanding the database outline is the key to understanding Essbase. To define
a multidimensional database, you design its database outline. The database outline
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contains the database organization (structure), the database members, and the
database rules, as shown in Figure 4:

Figure 4: Essbase Database Outline
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Note: The application designer or Essbase system administrator usually creates the
database outline. For more information on creating the database outline, see the
Essbase Database Administrator’s Guide.

The components of the database outline are the following:
e Dimensions

e Members

e Attributes

e Formulas
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e Aliases

e Consolidations

Refer to the following sections for descriptions of the outline components.

Dimensions

Dimensions are the most basic categorical definitions of data within the database
outline. You need at least two dimensions to make any meaningful reference to
data; for example, a time dimension and an accounts dimension. Other dimensions
may categorize products, markets, and scenarios. Using dimensional organization,
you can define any consolidation structure or any slice of data that is relevant to
the application. Essbase supports an unlimited number of dimensions.

Members

Members are the names of the elements within a dimension. A dimension
can contain an unlimited number of members. The calculation, reporting, and
dimension-building facilities in Essbase use the following terms to describe
members.

e Parents. A parent is a member with a consolidation branch below it. For
example, in the illustration below, Qtr1 is a parent member because there is a
branch containing monthly members below it.

Figure 5: Relationships Among Database Members
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e Children. A child is a member with a parent above it. For example, Jan, Feb,
and Mar are children of the parent Qtr1.

e Siblings. A sibling is a child member of the same parent and on the same
branch (same level). For example, Jan, Feb, and Mar are siblings. Apr is not a
sibling of Jan, Feb, or Mar, however, because it has a different parent, Qtr2.

o Descendants. A descendant is a member at any level below a parent. For
example, each member that falls in the Year branch is a descendant of Year.
The following members are all descendants of Year: Qtr1, Jan, Feb, Mar; Qtr2,
Apr, May, Jun; Qtr3, Jul, Aug, Sep; Qtr4, Oct, Nov, Dec.

e Ancestors. An ancestor is a member of a branch above a member. For
example, Qtr2 and Year are ancestors of Apr.

o Generations. The term generation describes the branch number of a member.
Generations count from the root of the tree (generation 1, which is the
dimension name) toward the leaf node.

e Levels. The term level describes the branch number of a member. Levels count
from the leaf node (level 0) toward the root (the dimension name).

Attributes

Attributes describe characteristics of data, such as the size and color of products.
Through attributes, you can group and analyze members of dimensions based
on their characteristics. Attribute dimensions must be associated with base
dimensions. For more information, see the Essbase Database Administrator’s
Guide.

Formulas

Each database member can have one or more formulas associated with it in the
database outline. For example, the Variance members of the Scenario dimension,
as shown in Figure 4, contain formulas. Formulas can be simple or complex. For
more information, see the Essbase Database Administrator’s Guide.
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Aliases

Essbase supports alternative names, or aliases, for database members. Aliases are
useful when various labels are used for the same member in various worksheets.
One worksheet, for example, may refer to Cost_of_Goods_Sold as COGS. Aliases
also can be used for reporting in alternative languages or for more formal output
name sets, such as account numbers.

Consolidations

Consolidations in Essbase applications are defined by member branches. The
database outline determines consolidation paths. The determination is based on the
location of members within a dimension. Indentation of one member below
another indicates a consolidation relationship. Indenting members is important for
the drill-down capabilities in Essbase Spreadsheet Add-in. As you navigate your
way through data, you can drill down through levels of consolidations. The
database outline is the roadmap that determines the levels of data navigation.
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When you add Essbase Spreadsheet Add-in to Lotus 1-2-3, most Lotus 1-2-3
operations remain unchanged; Essbase Spreadsheet Add-in simply adds a new
menu, a Essbase toolbar, and mouse shortcuts with which you can access the
Essbase server.

The tasks described in this tutorial are basic tasks. That is, these are tasks that you
probably use often when working with Essbase. Chapter 3 describes more
advanced tasks.

This tutorial chapter contains the following sections:

“Getting Acquainted with Essbase Spreadsheet Add-in” on page 32
“Preparing to Begin the Tutorial” on page 38

“Retrieving Data” on page 44

“Pivoting, Retaining, and Suppressing Data” on page 59
“Formatting the Worksheet” on page 73

“Creating Queries Using Essbase Query Designer” on page 88
“Deleting Queries” on page 101

“Viewing Messages and Confirmations” on page 101
“Accessing Help” on page 103

“Selecting Members” on page 106

“Saving and Disconnecting” on page 115

“Moving on to Advanced Tasks” on page 117

Note: Each tutorial task builds upon the previous task. Therefore, tasks must be
completed in succession.
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The examples used in this tutorial are based on the sample database (called Sample
Basic) that is included with the Essbase installation. Contact the Essbase system

administrator for information about accessing the Sample Basic database or about
accessing other databases on the Essbase server.

Getting Acquainted with Essbase
Spreadsheet Add-in

32 .

This section provides the following information to help you get acquainted with
Essbase Spreadsheet Add-in:

e “Adding Essbase Spreadsheet Add-in” on page 32
e “Starting Essbase Spreadsheet Add-in” on page 33
e ““Accessing Online Help” on page 35

e “Enabling Mouse Actions” on page 35

Adding Essbase Spreadsheet Add-in

If you manually update your environment settings or if you have removed Essbase
Spreadsheet Add-in from the Lotus 1-2-3 environment, you must use the

Lotus 1-2-3 facility to add Essbase Spreadsheet Add-in into Lotus 1-2-3. The
facility adds the Essbase menu to the Lotus 1-2-3 menu bar and points Lotus 1-2-3
to the Essbase Spreadsheet Add-in file in the \Essbase\bin directory. This file
is on the hard drive of your PC, if that is where you installed Essbase Spreadsheet
Add-in, or on the network drive if that is where you set up your PC operating
environment to run Essbase Spreadsheet Add-in.
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» To add Essbase Spreadsheet Add-in to Lotus 1-2-3:
1. InLotus 1-2-3, select File > Add-Ins > Manage Add-Ins.
Lotus 1-2-3 displays the Manage Add-ins dialog box.

2. Click Register and select the file ESS123.12A in the \Essbase\bin
directory where you installed Hyperion Essbase Spreadsheet Add-in on your
PC hard drive (if you installed the Add-in software there), or in the bin
directory where the Hyperion Essbase system administrator installed the
Hyperion Essbase Spreadsheet Add-in on a network drive (if you set up the
PC operating environment to run the Add-in software there).

3. Click Open and select the ESS123 . 12a add-in file. Make sure there is a check
mark next to the add-in file.

Figure 6: Manage Add-ins Dialog Box
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4. Click Done to close the Manage Add-ins dialog box and start the Hyperion
Essbase Spreadsheet Add-in.

The Essbase startup screen is displayed.

If you do not see the Essbase startup screen or if your system does not list the
Essbase Spreadsheet Add-in menu options, see the Essbase Installation Guide
for troubleshooting information.

Starting Essbase Spreadsheet Add-in

Because Essbase Spreadsheet Add-in software for Lotus 1-2-3 is implemented as
a Lotus 1-2-3 add-in, you must start Lotus 1-2-3 from Windows to use Essbase
Spreadsheet Add-in software.

You must open a worksheet before attempting to connect to the Hyperion Essbase
server. An attempt to connect to the Hyperion Essbase server without opening a
worksheet results in an error message.
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» To begin an Essbase session:

1. Start Lotus 1-2-3.

After the Lotus 1-2-3 startup screen disappears, the Essbase startup screen is

displayed.

The Hyperion Essbase menu should be displayed in the Lotus 1-2-3 menu bar.
If you do not see the Hyperion Essbase menu, you may need to use the
Lotus 1-2-3 add-in facility to add Essbase Spreadsheet Add-in into

Lotus 1-2-3. For more information, see “Adding Essbase Spreadsheet Add-in”

on page 32.

From the Lotus 1-2-3 menu bar, select Essbase to open the menu.

Figure 7: The Essbase Menu
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Note: If the Lotus 1-2-3 status bar is not displayed, you can display it by selecting

View > Show Status Bar.
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Accessing Online Help

Essbase Spreadsheet Add-in includes a context-sensitive online help system. You
access the Essbase Spreadsheet Add-in online help in one of three ways. Which
way you choose depends on the type of information that you need,

e Access the entire online help system for browsing or searching for
information. To access the entire help system, select Essbase > Essbase Help.
After you access online help, you can browse or search through the system to
view general information on Essbase Spreadsheet Add-in, Essbase command
descriptions, procedural information for completing tasks, Spreadsheet
Toolkit macros, and Visual Basic for Applications (VBA) function
descriptions.

® Access context-specific information from dialog boxes in Essbase Spreadsheet
Add-in. Each dialog box in Essbase Spreadsheet Add-in features a Help button
that accesses online help topics that are specific to the particular dialog box.
The buttons enable you to find the information you need without having to
search through the entire help system.

Note: The Essbase Spreadsheet Add-in online help also provides a
comprehensive section on Essbase Spreadsheet Toolkit, which enables you to
customize and automate your use of Essbase by using Lotus 1-2-3 macros.

® Access information on a specific Hyperion Essbase Query Designer function.
Access What’s This? Help in the Hyperion Essbase Query Designer dialog
box, and then click an item in the dialog box to access information on that
item.

Figure 8: EQD Help Button

Enabling Mouse Actions
The following terms are used throughout this guide to describe mouse operations:

e Primary mouse button and secondary mouse button describe the buttons on a
two- or three-button mouse. Usually, right-handed users configure the left
mouse button as the primary button and the right mouse button as the
secondary mouse button. The primary mouse button is the one that you use to
start Windows applications, such as Lotus 1-2-3; the secondary mouse button
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is used for auxiliary operations. The term click refers to use of the primary
mouse button. The term right-click refers to use of the secondary mouse
button.

e Select chooses the object that is under the cursor when you press and release
the primary mouse button. You can select a worksheet cell, for example, by
moving the cursor to the cell and pressing and releasing the primary mouse
button.

e Click (that is, both click and right-click) describes a quick press-and-release
action on a command object. You can click a button, for example, to execute
a command.

o Double-click describes two quick press-and-release actions that are executed
in rapid succession. You can double-click an application icon, for example, to
start a Windows application.

e Drag describes a press, hold, and move action. You place the cursor on an
object, press a mouse button, hold the mouse button and move the object, and
release the mouse button when you reach your goal. For example, you can
highlight arange of cells in Lotus 1-2-3 worksheet by dragging the cursor over
the cells.

Note: Hyperion Essbase uses a drag operation called a pivot. A pivot requires use
of the secondary mouse button. To execute a pivot, you must press and hold the
secondary, rather than the primary, mouse button while dragging the selection.

Essbase offers enhanced mouse actions in Lotus 1-2-3. You can use the mouse to
do any of the following:

Retrieve data

Drill down and drill up on database members

Pivot (move or transpose) data rows and columns

Access linked reporting objects

Access linked partitions

» To enable double-clicking to retrieve, drill down, and drill up on Essbase data:
1. Select Esshbase > Options.
2. In the Essbase Options dialog box, select the Global tab.
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3. Select the Enable Double-Clicking check box.

When the Enable Double-Clicking check box is selected, you can retrieve
and drill down to more detailed data (primary mouse button) and drill up to
less detailed data (secondary mouse button). When the double-clicking option
is enabled, the Lotus 1-2-3 in-cell editing feature is overridden.

Figure 9: Essbase Options Dialog Box—Global Tab
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4. Click OK to return to the worksheet.

For information about setting the primary mouse button to display the Linked
Objects Browser dialog box when you double-click a data cell, see the Essbase
Spreadsheet Add-in online help.
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Preparing to Begin the Tutorial

Before you begin the basic tutorial, read the following important sections:
e “Setting Essbase Options” on page 38
e “Following Guidelines During the Tutorial” on page 43

e “Reviewing the Sample Basic Database” on page 44

Setting Essbase Options

Before you begin the tutorial steps, make sure that the worksheet options are set to
the initial settings as illustrated in Figure 10 through Figure 13. If the option
settings are different, the illustrations presented in this chapter may not match the
worksheet view.

Note: For information about each option in the Essbase Options dialog box, see the
Essbase Spreadsheet Add-in online help.

1. Select Essbase > Options.

2. In the Essbase Options dialog box, select the Display tab.
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3. Select the appropriate check boxes and option buttons so that your display of
the Display tab matches the following illustration:

Figure 10: Initial Settings for Display Options

Essbase Options
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Select the Zoom tab.

Select the appropriate check boxes and option buttons so that your display of
the Zoom tab matches the following illustration:

Figure 11: Initial Settings for Zoom Options

Essbase Options
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Select the Mode tab.

Select the appropriate check boxes and option buttons so that your display of
the Mode tab matches the following illustration:

Figure 12: Initial Settings for Mode Options

Essbase Options

Note: If you are already connected to a Essbase database, the Essbase Options
dialog box also displays a Style tab. You can skip this tab for now.
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Select the Global tab.

Select the appropriate check boxes and option buttons so that your display of
the Global tab matches the following illustration:

Figure 13: Initial Settings for Global Options
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Note: You should have already selected the appropriate boxes for Mouse Actions,
as described in “Enabling Mouse Actions” on page 35.

10. Click OK to save the settings for this session and close the Essbase Options
dialog box.
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Following Guidelines During the Tutorial

Keep in mind the following guidelines during this tutorial:

Tasks that should not be performed as part of the tutorial are displayed in gray
boxes. These tasks are included only for your future reference. You can find
more information on these tasks in the Essbase Spreadsheet Add-in online
help.

You must be connected to the Sample Basic database during the tutorial. If you
are not connected to this database, the illustrations presented in this chapter
will not match the worksheet view.

You can access many Essbase commands in any one of these ways:
— By selecting the command from the Essbase menu
— By clicking the appropriate button on the Essbase toolbar

—  For the Zoom In and Zoom Out commands, by double-clicking either the
primary mouse or the secondary mouse button

You must set the options in the Essbase Options dialog box as described in
“Setting Essbase Options” on page 38. If the option settings are different, the
illustrations presented in this chapter may not match the worksheet view.

After you change a worksheet option in the Essbase Options dialog box, you
must perform a retrieval or a drill-down operation to have the new setting take
effect.

Be sure to follow each step in the tutorial. Each tutorial task builds upon the
previous task. Do not skip the final steps at the end of sections, because these
steps are often necessary to prepare you for the next tutorial task.

If you make a mistake during the tutorial, you can select Essbase > FlashBack
to return to the previous worksheet view.

The values in the Sample Basic database that represent ratios or percentages
are calculated to a very high level of precision (for example, 55.26162826). In
Lotus 1-2-3, you can apply a cell format to control the number of decimal
places that are displayed in data values. For more information, see the
Lotus1-2-3 documentation.
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e The numeric values that are shown in the illustrations used throughout this
tutorial may not match the values stored in your database. The values shown
in these illustrations reflect a freshly loaded database.

e Some worksheet columns have been adjusted for clarity in the illustrations.
You do not need to change the width of columns in the worksheet to follow the
tutorial steps. The Adjust Columns option in the Essbase Options dialog box
(Display Tab) adjusts columns for you.

Reviewing the Sample Basic Database

The Sample Basic database that you use for the tutorial is based on a hypothetical
company in the beverage industry. The major products of the company are various
kinds of sodas. These products are sold in U.S. markets, which are categorized by
state and region. Financial data for the company is collected monthly and is
summarized by quarter and by year. The company uses Essbase to calculate
financial and accounting data, such as sales, cost of goods sold, and payroll. The
company tracks both actual and budget data, as well as the variance and percent
variance between the two.

Retrieving Data

44 1

Now that you are more familiar with the Essbase environment, you can connect to
the Essbase server and start using Essbase and Essbase Spreadsheet Add-in. The
following section guides you through a typical Essbase session where you connect
to a database and retrieve data in various ways.

This section outlines the following basic retrieval tasks:
e “Connecting to a Database” on page 45

e “Changing a Password” on page 48

e “Retrieving Data from a Database” on page 48

e “Canceling a Data Retrieval Request” on page 50

e “Restoring the Previous Database View” on page 50
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e “Drilling Down to More Detail” on page 51
e “Drilling Up to Less Detail” on page 55
e “Customizing Drill-Down and Drill-Up Behavior” on page 56

Note: Make sure that you followed the steps in “Setting Essbase Options” on page 38.
If the settings in the Essbase Options dialog box are different from the settings
previously illustrated, the worksheet view will differ from the illustrations shown in this
chapter.

Remember that you can perform common data retrieval tasks by doing any of the
following:

e Selecting commands from the Essbase menu on the Lotus1-2-3 menu bar
e Clicking the appropriate buttons on the Essbase toolbar

e Double-clicking the primary or the secondary mouse button in the appropriate
cell (for Retrieve, Zoom In, and Zoom Out commands)

Connecting to a Database

To access Essbase data, you must first connect to a database on the server. This
tutorial assumes that you have the appropriate privileges to connect to a server, an
application, and a database.

1. Select Essbase > Connect

Essbase displays the Essbase System Login dialog box.
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Figure 14: Essbase System Login Dialog Box
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Note: To complete the steps that follow, you need to know the name of the
Essbase server, your username, and your password. If you do not have this
information, contact the Essbase system administrator.

From the Server list box, select the server that you want to access. (If the
server name that you want does not display in the list, you can type in the name
of the server you want to access.)

Press Tab to move to the Username text box; type your username in the
text box.

Press Tab to move to the Password text box; type your password in the text
box.

Note: You can change your password when you are connected to a server.
To change your password, see “Changing a Password” on page 48.
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5. To connect to the server, click OK.

Essbase displays a list of available application/database pairs in the
Application/Database list box. An Essbase server enables simultaneous
access to multiple applications. An application can contain multiple databases.
Only the databases to which you have security access are shown in the list.

For this tutorial, you use the Sample Basic database. If the Sample Basic
database was installed as part of the Essbase installation, it is shown in the list.
If Sample Basic is not shown in the Application/Database list box, ask the
Essbase system administrator to install it.

Figure 15: Available Application and Database Pairs

Essbase System Login E

Server. ILocthost j oK I
Usemame: W ﬂl
Password: lm Help |

LChange Password... |

Application/D atabase:

Demo Basic Update |

S ampeast East

S ample Intemtl Hote... |
S ample Hchgrate

S amppart Company

Sourcel Basic

Targetl Basic

6. In the Application/Database list box, double-click Sample Basic. You can
also select Sample Basic from the list box and click OK.

If the application is not already running, Essbase automatically starts it. There may
be a brief pause as the application loads. The time required to start an application
depends on the number of databases, the sizes of the databases, and the sizes of the
indexes of the databases contained within the application.
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Changing a Password

You can change your password only if you are connected to a server.

Note: Tasks that you should not perform as part of the tutorial are shown in
light-shaded boxes.

» To change your password:

1. In the Essbase System Login dialog box, select the Change Password
button.

2. Inthe Change Password dialog box in the New Password text box, type
your new password.

3. In the Confirm Password text box, type the password again.
The passwords must be identical.

4. Click OK to change your password.

5. Click OK again to close the Essbase System Login dialog box.

Retrieving Data from a Database

Each time you retrieve information from an Essbase server, the following
actions occur:

48 |

Essbase Spreadsheet Add-in requests data from the server.
The server processes the request and prepares the data.
The server transmits the data to Essbase Spreadsheet Add-in.

Lotus 1-2-3 receives the data from Essbase and organizes it in a worksheet.
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To help you monitor these operations, Essbase uses three custom cursors.

Table 1: Essbase Custom Cursor

This cursor: Is displayed when:

i Essbase requests information from the server.
i The server is processing the request.

i The server returns the data.

Note: Small retrieval actions display the cursors very quickly; you may not notice
changes in the direction of the arrow when retrieving small amounts of data.

» To retrieve data into an empty worksheet:

1. Open a new worksheet by selecting File > New or by clicking the g button.

Note: You should be connected to the Sample Basic database. If you are not
connected, follow the steps in “Connecting to a Database” on page 45.

2. Select Essbase > Retrieve.

Essbase retrieves data into the Lotus 1-2-3 worksheet.

Figure 16: Initial Data Retrieval from Sample Basic

A

B [ ¢ [ o | E | F |

Year

Measures Product | Market
105522

Scenatio

Because you selected the Enable Double-Clicking box in the Essbase
Options dialog box (Global tab), you can double-click in an empty cell to
retrieve data. You can also click the Retrieve button on the Essbase toolbar.
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When you retrieve data into an empty worksheet, Essbase returns data from the top
levels of each database dimension. The top level is used as a starting point to
navigate, or drill down, into levels of detailed data. In the Sample Basic database,
the following five dimensions are retrieved: Measures, Product, Market, Scenario,
and Year.

For the remainder of tasks in this tutorial, you can retrieve data by double-clicking
in a data cell, selecting Essbase > Retrieve, or by clicking the Retrieve button on
the Essbase toolbar.

Canceling a Data Retrieval Request

Occasionally, you may want to cancel a retrieval request. For instance, you may
want to stop a request if a retrieval is taking longer than expected or if you
mistakenly double-click.

Because Essbase returns data so quickly to the worksheet, you may not be able to
cancel a retrieval before the retrieval is complete. The cancel feature is most useful
when you need to stop a large retrieval request.

To cancel data retrievals, press the Esc key during a retrieval action.

Note: You can cancel a retrieval only while Essbase is processing in Essbase
Spreadsheet Add-in. You cannot cancel a retrieval when Essbase is processing from
the server.

Restoring the Previous Database View

The FlashBack command restores the previous database view. A database view is
simply what you see in the worksheet after a retrieval or navigation operation.
FlashBack is similar to the Lotus 1-2-3 Edit > Undo command, which reverses the
last action. The FlashBack command uses the memory of your machine to store the
current view before processing an Essbase retrieval request. You can use
FlashBack to undo only the most recent operation. FlashBack cannot undo
multiple operations.

Throughout this tutorial, you should follow all steps in the order that they are
presented. If you make a mistake or find yourself out of step with the tutorial, you
can use the FlashBack command from the Essbase menu or toolbar to undo the last
command and return to the previous database view. If you want to start the tutorial
over from the beginning, select the entire worksheet and select Edit > Clear > All.
Then press Enter or click OK to empty the worksheet and start again.
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You can disable FlashBack during normal operations to conserve memory on your
local machine. Do not disable FlashBack for this tutorial.

Note: Tasks that you should not perform as part of the tutorial are shown in
light-shaded boxes.

» To disable Flashback:

1. Select Essbase > Options and click the Global tab.
2. Clear the Enable FlashBack check box.

Drilling Down to More Detail

With Essbase, you can drill down to various levels of multidimensional data in the
worksheet. For example, if you want to view data for a specific quarter or month
rather than an aggregate data value for the whole year, you can drill down on the
Year dimension to see more detailed data.

You have three options for drilling down on a member:
e Select the member and select Essbase > Zoom In.
e Select the member and double-click the primary mouse button.

e Select the member and click the Zoom In button on the Essbase toolbar.

» To drill down to lower levels of the Year dimension:
1. On Year in cell A2, double-click the primary mouse button.

The drill-down action retrieves data for the level below (the children of) Year:
Qtrl, Qtr2, Qtr3, and Qtr4.

Figure 17: Result of Drilling Down on the Year Dimension

A | B [ ¢ [ o] E | F |
1 Measures Product Market Scenario
2 |0t I 24703
L3 [Gtr2 27107
L4 |Gtr3 27912
L5 |Gitrd 25500
L6 | ‘Year 105522

Note: For a discussion of the relationships among Essbase database members,
see “Database Outlines” on page 26.
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With Essbase, you can retrieve members into grouped, or nested, columns or
rows. Row groups containing more than one level of data are nested within
single-member row groups. For example, a row group containing Qtrl, Qtr2,
Qtr3, and Qtr4 may be nested within a single-member row for a specific
region, such as East (see the following illustration). Drilling down to lower
levels of database members is one way to retrieve data into nested groups.

In cell D1, double-click to drill down on Market and create nested groups of
rows down the worksheet.

Figure 18: Result of Drilling Down on the Market Dimension (Nested Rows)

A [ B [ ¢ [ b [ E T F ]
L1 Measures|Pr0duct!Scenari0
L2 |East Gitrl 5380
3 | Gitr2 5459
4 | Q3 6346
5 | Citrd 5936
L6 | ‘fear 24181
L7 |West Gitrl 7137
I8 | Gitr2 75148
9 | Q3 7939
10| Citrd 7270
L1 ‘fear 25861

Because worksheets can accommodate more rows than columns, Essbase is
preset to retrieve data into rows when you drill down on a member. You can
change this default behavior and display the results of a drill-down across
columns. Drilling across columns applies only to the top-level member of a
dimension (for example, Market or Scenario).

Follow these steps to drill down on Scenario and retrieve its respective members
into columns rather than rows:

Press and hold the Alt key.

2. Double-click Scenario (in cell E1).
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3. Release the Alt key.

Essbase displays the data in columns across the worksheet.

Figure 19: Result of Drilling-Down on the Scenario Dimension

(Nested Columns)

A [ B [ € [ b | E | F [ 6|
1] Measures | Product | 1
L2 | Actual Budget “ariance “ariance % Scenario
L3 |East Gitrl 5380 B&00)  -1120) -17.23076923 5380
4 | Gitr2 6459 7a80  -1081 -13.920529% 5459
5 | Q3 6346 7a50  -1204) -15.94701987 6346
6 | Citrd 5936 6790 854 -12.57731959 5936
L7 | Wear 24161 283300 4229 -14.89609017 24161
I8 |West Gitrl 7137 8960 -1823) -20.34595214 7137
9 | Gitr2 7818 82900 1775 -19.10B5662 75148
10| Q3 7939 5870 -1931 -19.56433637 7939
11| Citrd 7270 S0B0  -1790) -19.75717439 7270
12| Wear 29861 371800 7319 -19.68531463 29561

Drilling Down on Attribute Members

You can use the Essbase attribute feature to retrieve and analyze in terms of
characteristics, or attributes, of dimensions. For example, you can analyze product
profitability based on size or packaging. Attribute dimensions are associated with
base dimensions.

You can use an attribute dimension to drill down on the base dimension with which
it is associated. In the Sample Basic database, the Product base dimension is
associated with several attribute dimensions, such as Caffeinated, Ounces, and
Pkg_Type. Each attribute dimension consists of level O attribute members. Level
0 attribute members are the lowest level attributes that are associated with
members of a base dimension. The Pkg_Type attribute dimension, for instance,
has two level 0 members, Bottle and Can.

You can extract information on all products sold in a can by entering manually
the name Can in the worksheet. You can also use Essbase Query Designer or the
Essbase Member Selection dialog box to select the attribute and display it in the
worksheet.
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Open a worksheet, connect to the Sample Basic database, and select Essbase >
Retrieve. Select Product and replace it with Can by typing Can manually. Click
anywhere outside of cell C1 and select Essbase > Retrieve again. Figure 20
displays the results:

Figure 20: An Attribute Member in a Report

A [ B [ ¢ o [T E ]
1 Measures Can Market | Scenario
|2 |Vear 39578

Drill down to all products sold in a can by double-clicking Can in cell C1. Cola,
Diet Cola, and Diet Cream are the members of Product that have the Can attribute.
The result is displayed below:

Figure 21: Result of Drilling Down on an Attribute Member

AT B € T b T E T F |
1] | Weaswes Market | Scenario
| 2 |Year Can Cala 2577
3| Diet Cala 5708
L4 | Diet Cream 11093

Drilling Down on Level 0 Attribute Members

The following is a description of the general behavior of Essbase Spreadsheet
Add-in when you drill down on a level 0 attribute member:

If the level O attribute member is in a column, a drill-down pivots the attribute
to the innermost row of the worksheet.

e If the level O attribute member is in a row, a drill-down does not change the
position of the attribute in the worksheet.

e A drill-down on a level O attribute member displays the associated base
members to the right of the level O attribute.

e If there is more than one level O attribute member in a worksheet, a drill-down
on one attribute displays other attributes to the left of the level O attribute
member. Level 0 attribute members in columns pivot to rows, and level 0
attribute members already in rows remain in rows.

e A drill-down on non-level O attribute members is the same as the current drill-
down behavior for other types of members.
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The drill-down behavior for non-level O attribute members is the same as the
current drill-down behavior for other types of members. See the Essbase
Spreadsheet Add-in online help for examples of drilling down on level 0 attribute
members. For more information on attributes, refer to the Essbase Database
Administrator’s Guide.

Drilling Up to Less Detail

With Essbase, you can drill up to higher levels in the multidimensional database
outline by collapsing the current member tree. For example, if you previously
drilled down on a dimension, such as Scenario, to view data for Actual and Budget,
you may need to drill up to view aggregate data for the Scenario dimension.

You have three options for drilling up on a member:

Select the member and select Essbase > Zoom Out.
Select the member and double-click the secondary mouse button.

Select the member and click the Zoom Out button on the Essbase toolbar.

» To drill up on the Scenario dimension in the current worksheet:

1.

On any member of the Scenario dimension (that is, cell C2, D2, E2, F2, or
G2), double-click the secondary mouse button.

Essbase collapses the members of the Scenario dimension.

Figure 22: Result of Drilling Up On the Scenario Dimension

Essbase Spreadsheet Add-in for 1-2-3

A [ B c [ o [ E ] F ]

L1 Measures Product

L2 | Scenario 1

L3 |East Gitrl 5380

4 | Gitr2 5459

5 | Q3 6346

6 | Citrd 5936

L7 | ‘fear 24181
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2. Incell A3, double-click the secondary mouse button to drill up on East.

Essbase collapses East, West, South, and Central into the single Market
dimension and keeps the dimension in the A column.

Figure 23: Result of Drilling Up On East

A [ B [ € [ o | E [ F ]
L1 Measures Product
2 Scenario
3 [Market  l0tr1 24703
L4 | Qtr2 07
L5 | Qtr3 2Nz
L6 | Qtrd 25800
L7 | Year 105522

Customizing Drill-Down and Drill-Up Behavior

You can customize the behavior of the Zoom In and Zoom Out commands in the
Essbase Options dialog box. The following steps illustrate some drill-down and
drill-up techniques.

» To retrieve all members of a dimension with a single drill-down operation:
1. Select Esshbase > Options and select the Zoom tab.

Essbase displays the Zoom Tab.
Figure 24: Zoom In and Member Retention Option Settings

—Zo

Al Levels

" Bottom Level
' Sibling Level
' Same Level

" Same Generation
' Fomulas

— Member Retention

¥ Include Selection

™ ‘within Selected Group

™ Remove Unselected Groups

The Zoom In option group contains items that enable you to customize
drilling behavior. You can specify which members are returned to the
worksheet during a drill-down operation. For example, if you select Bottom

56 W Essbase Spreadsheet Add-in for 1-2-3



A Basic Essbase Tutorial

Level, Essbase retrieves data for the lowest level of members in a dimension.
With this option, a drill-down on Year retrieves Jan, Feb, Mar, Apr, May, Jun,
Jul, Aug, Sep, Oct, Nov, and Dec.

The Member Retention option group contains items that enable you to
customize drilling retention characteristics. The default selection, Include
Selection, retains the selected member along with the other members retrieved
as a result of a drill down. For example, if you drill down on Qtr1, Essbase
retrieves data for Jan, Feb, and Mar, as well as for Qtrl. When this option is
disabled, Essbase retrieves data only for Jan, Feb, and Mar; Qtr1 is eliminated.

Note: For more information on the Zoom In and Member Retention option groups,
see the Essbase Spreadsheet Add-in online help.

In the Zoom In option group, select the All Levels option and click OK to
save the setting.

In cell A3, drill down (double-click) on Market.

In cell C2, drill down (double-click) on Scenario.

Essbase retrieves all members of Market and Scenario. For the Market
dimension, Essbase drilled down two levels to get to the bottom-most
members, which are individual states. The Scenario dimension has only one
member level, so the members of Scenario would also be retrieved if you
selected Next Level in the Zoom In option group.

Figure 25: Result of Drilling Down to All Member Levels

I A B8 | e | o | E | F & |
1 1 | Measuras Produst
2 Actual  Budget Variance Variance % Scenario
3 Mew York Gt 1656 2000 -344 -17.2 1656
4 Gitr2 2363 2610 -247 -9.46360153 2363
5 Gitra 1943 2290 -347 -16.1528384 1943
6 Gitrd 2240 2320 -80 -3.448275846 2240
7 Year g202 9220 1018 -11.0412148 g202
8 |Massachusetts  (Gtrl 1632 1690 -168 -9.34911243 1632
9 Gitr2 1750 1900 -180 -7.89473684 1750
10 Gitra 1936 2100 -164 -7.80952381 1936
11 Gitrd 1494 1610 -116 -7.20496894 1494
12 Year 6712 F300 588 -8.05479452 6712

5. Select Essbase > Options and select the Zoom tab.

6. Return the Zoom In option setting to Next Level.
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If you want to drill up on only one quarter of the year, select Within Selected
Group in the Member Retention option group.
» To drill up only on Qtrl:

1. In the Member Retention option group on the Zoom Tab, click the Within
Selected Group check box and click OK.

Make sure that Include Selection is also still checked.
2. To drill up on Qtr 1 (in cell B3), double-click the secondary mouse button.

Notice that drilling up to the Year dimension affects only New York. All other
states show data for all four quarters.

Figure 26: Result of Drilling Up Within a Selected Group

I n 8 [ ¢ [ o [ E | F e [ ]

1 1 | Measuras Produst

2 Actual  Budget Variance Variance % Scenario
3 Mew York Year g202 9220 1018 -11.04121478 g202
4 M husetts Gt 1632 1690 -168 -9.349112426 1632
5 Gitr2 1750 1900 -180 -7.894736842 1750
6 Gitra 1936 2100 -164 -7.80952381 1936
7 Gitrd 1494 1610 -116 -7. 204968944 1494
8 Year 6712 F300 588 -8.054794524 6712
9  |Florida Gt 1070 1300 -230 -17.69230769 1070
10 Gitr2 1339 1670 -2 -14.7133758 1339
11 Gitra 1495 1730 -235 -13.58381503 1495
12 Gitrd 1125 1300 175 -13.46163846 1125

3. Before moving on with the tutorial, disable the Within Selected Group
option:

a. Select Essbase > Options and select the Zoom tab.

b. In the Member Retention option group, clear the Within Selected
Group check box.

4. Select File > Close to close the worksheet. You do not need to save the
worksheet.
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Pivoting, Retaining, and Suppressing Data

After you retrieve data into the worksheet, you may want to manipulate the data in
various ways. For example, you may want to move rows and columns to different
positions in the worksheet, or you may want to tell Essbase to suppress or retain
specific data during data retrievals.

To help you manipulate worksheet data, this section steps you through the
following procedures:

e “Pivoting Rows and Columns” on page 59

e “Retaining a Data Subset” on page 63

e “Removing a Data Subset” on page 66

e “Navigating Through the Worksheet Without Retrieving Data” on page 66

e “Suppressing Missing Values, Zero Values, and Underscore Characters” on
page 70

Pivoting Rows and Columns

With the Pivot command, you can change the orientation of worksheet data. Use
the Pivot command to do any of the following:

e Move a row group to a column group
e Move a column group to a row group
e Change the order of row groups

e Change the order of column groups

You can execute the Pivot command in two ways:

e Select the member cell that you want to pivot, and select Essbase > Pivot. This
method applies only to moving a row group to a column group or a column
group to a row group.

e Click in the center of the member cell that you want to pivot, press and hold
the secondary mouse button, and drag the group to the desired location. This
method applies to swapping row and column groups and to changing the order
within groups.
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» To pivot Year data from a row group to a column group:

1. To open a new worksheet, select File > New or click the QI icon.

Note: You should already be connected to the Sample Basic database. If you are
not connected, follow the steps in “Connecting to a Database” on page 45.

Select Essbase > Retrieve.

Drill down (double-click) on Measures and Product (in cells B1 and C1,
respectively).

4. Press and hold the Alt key, and, in cell E1, drill down (double-click) on

Scenario.

Figure 27: View Before Pivoting

B [Cc] D E [ F [ G [ H |
L1 tarket
L2 | Actual Budget Wariance “arance % Scenario
L3 [100 Profit Wear 30465 415840 -11472) -27 35336195 30465
4 | Inventary Wear 29445 31590 2142 6780626751 29445
5 | Ratios Year 5727288145 &7 6240049 0351123447 -0.609335377 67 27288145
6 | Measures fear 30465 415840 -11472) -27 35336195 30465
|7 [200 Profit Wear 27554 35540 7996 -22.24200275 27554
I8 | Inventary Wear 33000 31090 -1910) -6.1434544687 33000
9 | Ratios Year 5553966595 57 46674162 -1.927075664 | -3.353375551 5553966595
10| Measures fear 27554 35540 7996 -22.24200275 27554
|11 {300 Profit Wear 25799 29360 3861 -12.1287 4659 25799
12 | Inventary Wear 26865 27140 -1725) -6.355932203 26865
113 | Ratios Wear 5423795671 57.13950487 -2.9015458161 -6.078007152 54 23795671
|14 | Measures fear 25799 29360 3861 -12.1287 4659 25799
|15 [400 Profit Wear 213M 22130 -829| -3.746046091 213M
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5. 1Incell C3, select Year and select Essbase > Pivot.

Figure 28: Result of Pivoting a Row Group to a Column Group

A B [ C [ D [ E [ F |
L1 ‘fear tarket
L2 | Actual Budget Wariance “ariance %
L3 [100 Profit 30465 415840 -11472) -27 35336195
4 | Inventary 29445 31590 2142 6780626751
5 | Ratios 5727288145 &7 6240049 -0.351123447 | -0.609335377
6 | Measures 30465 415840 -11472) -27 35336195
|7 [200 Profit 27554 35540 7996 -22.24200275
I8 | Inventary 33000 31090 -1910) -6.1434544687
9 | Ratios 55.53966595 57 46674162 -1.927075664 | -3.353375551
10| Measures 27554 35540 7996 -22.24200275
|11 {300 Profit 25799 29360 3861 -12.1287 4659
12 | Inventary 26865 27140 -1725) -6.355932203
113 | Ratios 54.2379567 1 57.139504587 -2.9015458161 | -6.075007152
14 | Measures 25799 29360 3861 -12.1287 4659

Essbase pivots the Year dimension to a column group next to Market (above
the Scenario members).

As another example, in cell C2, select Actual.

Right click and drag Actual to product 100 in cell A3.

Figure 29: Pivoting a Column Group to a Row Group

A B [ C [ D [ E [ F |
L1 ‘fear tarket

2 Actual Budget Yariance Yariance %

3 100 [sctual Budget Yariance Yariance% Scenario| 1472 -27.35336135
L4 | Trventary iR E 3190 2142 B.780626731
5 | Ratios 5727288145 &7 6240049 -0.351123447 | -0.609335377
6 | Measures 30465 415840 -11472) -27 35336195
|7 [200 Profit 27554 35540 7996 -22.24200275
I8 | Inventary 33000 31090 -1910) -6.1434544687
9 | Ratios 55.53966595 57 46674162 -1.927075664 | -3.353375551
10| Measures 27554 35540 7996 -22.24200275
|11 {300 Profit 25799 29360 3861 -12.1287 4659
12 | Inventary 26865 27140 -1725) -6.355932203
113 | Ratios 54.2379567 1 57.139504587 -2.9015458161 | -6.075007152
14 | Measures 25799 29360 3861 -12.1287 4659

Note: The member label box that is displayed under the cursor during the pivot
operation displays the names of the members that you are pivoting. The orientation
of the member label box, however, does not determine the orientation of the pivot
result. Essbase determines the data orientation by the location of the destination
cell.
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Essbase pivots the Scenario members (Actual, Budget, Variance, and
Variance%) from a column group to a row group that is displayed to the left
of the Product members.

Figure 30: Result of Pivoting a Column Group to a Row Group

A [ B ] C [ D [ E ] F |
L1 ‘fear tarket
2 |Actual 100 Profit 30465
3 I Inventary 29445
4 | Ratios 57. 27288145
L9 | Measures 30465
6 | 200 Profit 27554
L7 | Inventary 33000
I8 | Ratios 55.53966595
L9 | Measures 27954
10| 300 Profit 25799
11| Inventary 28865
12 | Ratios 54.2379567 1
113 | Measures 26795
14 | 400 Profit 213M

» To transpose the order of row groups:

1.
2.

In cell A2, select Actual.
Right-click and drag Actual to Profit (cell C2).

Figure 31: Pivoting the Order of Row Groups

A [ B [ C [ D [ E ] F [ G |

L1 ‘fear tarket

| 2 |Actual 100 [Eroft_Betual Budget Variance Variance% Scenario|
L3 | Inventary iR E

4 | Ratios 57. 27288145

L9 | Measures 30465

6 | 200 Profit 27554

L7 | Inventary 33000

I8 | Ratios 55.53966595

L9 | Measures 27954

10| 300 Profit 25799

11| Inventary 28865

12 | Ratios 54.2379567 1

113 | Measures 26795

|14 | 400 Profit 213M

115 | Inventary 26032

|16 | Ratios 53.59966755
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The pivot changes the order of the row groups.

Figure 32: Result of Pivoting the Order of Row Groups

A B [ C [ D [ E ] F |
L1 ‘fear tarket
L2 [100 Profit IActuaI _| 30465
3 | Budget 415840
L4 | Wariance -11472
L9 | “arance % -27 35336195
L6 | Scenario 30465
L7 | Inventary Actual 25445
I8 | Budget 31590
L9 | Wariance 2142
|10 | “arance % 670626731
11| Scenario 25445
|12 | Ratios Actual a7 27285145
113 | Budget 57 6240043
|14 | Wariance -0.351123447
115 | “arance % 0605335377
|16 | Scenario | 57 27285145

In this example, notice that both the source cell and the destination cell are
now members. Whenever the source cell and the destination cell are members
of different row groups, Essbase exchanges the member groups. You must
select a destination cell that contains a member name to exchange row
members. You can also exchange column members by choosing a destination
cell in another column that contains a member name.

Retaining a Data Subset

The Keep Only command retains only selected member rows or columns and
removes all other data from the worksheet view. This command provides a
powerful way to remove dimensional slices without having to delete individual
cells.
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» To keep only Actual and Budget data in the current worksheet:
1. Incell C2, select Actual and, in cell C3, select Budget.

Figure 33: Selecting Members for the Keep Only Command

A B [ C [ D [ E T F ]
L1 ‘fear tarket
L2 [100 Profit Actual 30465
3 | I} 415840
L4 | Wariance -11472
L9 | “arance % -27 35336195
L6 | Scenario 30465
L7 | Inventary Actual 25445
I8 | Budget 31590
L9 | Wariance 2142
|10 | “arance % 670626731
11| Scenario 25445
|12 | Ratios Actual a7 27285145
113 | Budget 57 6240043
|14 | Wariance -0.351123447
115 | “arance % 0605335377
|16 | Scenario | 57 27285145

2. Select Essbase > Keep Only.

Essbase removes the Variance, Variance%, and Scenario rows from the
worksheet and retains only Actual and Budget data.

Figure 34: Result of Retaining a Data Subset (Adjacent Cells)

A B [ € ] D [ E [ F ]
L1 ‘fear tarket
L2 [100 Profit Actual 30465
3 | I} 415840
L4 | Inventary Actual 25445
5 | Budget 31590
L6 | Ratios Actual | 67 27283145
L7 | Budget | 57 6240043
L8 | Measures Actual 30465
9 | Budget 415840
|10/ {200 Profit Actual 27554
11| Budget 35540
|12 | Inventary Actual 33000
113 | Budget 31090
|14 | Ratios Actual | 55535966595
115 | Budget | 57 46674162
|16 | Measures Actual 27954

Occasionally, the data that you want to remove from the worksheet does not lie in
an adjacent range of cells.
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» To select and retain nonadjacent cells.
1. Press and hold the Alt key, and, in cell D1, zoom in (double-click) on Year.
2. Select Qtr2 (in cell E2).
3. Press and hold the Ctrl key and select Qtr4 (in cell G2).

Figure 35: Selecting Nonadjacent Members for the Keep Only Command

A | B [ € ] D [ E [ F [ G |
1

2| atrt
L3 [100 Profit Actual 7048 7872 8511 7037
4 | Budget 9780 10660 11440 10050
L9 | Inventary Actual 25445 25860 36461 35811
6 | Budget 31590 29550 34830 32340
L7 | Ratios Actual | 67 40178857 67 28473167 57 395509978 56.99467561
I8 | Budget | 57 7376566 57.39041794 57 45231167 57 96344648
L9 | Measures Actual 7043 7E72 3511 7037
10| Budget 9780 10660 11440 10050
|11 [200 Profit Actual 6721 7030 70048 7158
12 | Budget 8480 8540 8530 9800
113 | Inventary Actual 33000 31361 35243 3Z7E0
|14 | Budget 31090 28040 30260 26460
115 | Ratios Actual | 5538738674 5549797453 55.06764011 ) 56.21773123
|16 | Budget | 57 36255286 57.40395375 57.111436%6 57 9954955
17 | Measures Actual G721 7030 7005 7193

4. Select Essbase > Keep Only.

Essbase retains only Qtr2 and Qtr4 data and deletes the other Year members.

Figure 36: Result of Retaining a Data Subset (Nonadjacent Cells)

A | B [ € ] D [ E [ F |

L1 tarket

L2 | Qtr2 Oitrd

L3 [100 Profit Actual 7872 7037
4 | Budget 10660 10050
L9 | Inventary Actual 25860 35811
6 | Budget 29550 32340
L7 | Ratios Actual | 67 28473167 56.99467561
I8 | Budget | 57.390417594 57 96344645
L9 | Measures Actual 7E72 7037
10| Budget 10660 10050
|11 [200 Profit Actual 7030 7158
12 | Budget 8540 9800
113 | Inventary Actual 31361 3Z7E0
|14 | Budget 28040 26460
115 | Ratios Actual | 5549797453 56.21773123
|16 | Budget | 57.40395375 57 9954955
17 | Measures Actual 7030 7193
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Removing a Data Subset

The Remove Only command is the counterpart to the Keep Only command. With
Remove Only, you can remove selected member rows or columns and retain all
other data in the worksheet view.

» To remove a data subset from the current worksheet view:

1. 1Incell B7, select Ratios.
2. Press and hold Ctrl, and, in cell B9, select Measures.
3. Select Essbase > Remove Only.

Essbase removes data for Ratios and Measures but retains data for Profit and
Inventory.

Figure 37: Result of Removing a Data Subset

Navigating Through the Worksheet Without

Retrieving Data

A | B [ ¢ [ b [ E [ F |

L1 tarket

L2 | Qtr2  Citrd
L3 [100 Profit  |Actual | 7872 7037
4 | Budget | 10660 100&0
L9 | Inventory Actual | 259860 35311
6 | Budget | 29950 32340
|7 [200 Profit  |Actual | 7030 7198
I8 | Budget | 5840 59800
L9 | Inventory Actual | 31361 32760
10| Budget | 25040 26460
|11 {300 Profit  |Actual | B763)  B403
12 | Budget | 7680 7000
113 | Inventary Actual | 30334 35142
14 | Budget | 28460 35460

66 W

With the Navigate Without Data feature, you can perform navigational operations,
such as pivot, zoom in, zoom out, keep only, and remove only, without retrieving
any data into the worksheet.

This feature is especially useful when dealing with dynamic calculation members,
which are usually specified by the application designer. By activating Navigate
Without Data, you are effectively telling Essbase not to dynamically calculate
values (that is, calculate the database at retrieval time) while you are creating the
spreadsheet report. Dynamic calculation is discussed in more detail in “Retrieving
Dynamic Calculation Members” on page 156.

Essbase Spreadsheet Add-in for 1-2-3



A Basic Essbase Tutorial

» To navigate through the worksheet without retrieving data:
1. Select Essbase > Navigate Without Data.

Essbase displays a check mark next to the menu item.

Note: You can also disable Navigate Without Data by clearing the appropriate
option in the Essbase Options dialog box (Global Tab) or by clicking the Navigate
Without Data button on the Essbase toolbar.

2. In cell D2, double-click the secondary mouse button to drill up on Qtr2.

Essbase shows the collapsed Year dimension but withholds retrieving any
data that is changed as a result of drilling up. The cells where data would
normally be displayed are blank.

Figure 38: Result of Zooming Out (Navigate Without Data Enabled)

A [ B [ € [ b [ EJF]
L1 tarket
L2 | ‘fear
L3 (100 Prafit Actual
L4 | Budget
L9 | Inventary Actual
L6 | Budget
¥ (200 Prafit Actual
L8 | Budget
L9 | Inventary Actual
|10 | Budget
|11 (300 Prafit Actual
|12 | Budget
113 | Inventary Actual
14 | Budget

3. Incell D2, drill down (double-click) on Year by pressing and holding the
Alt key.

Essbase drills down without retrieving data.
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4. 1In Cell C3, select Actual and select Essbase > Pivot.

Essbase executes the pivot but does not retrieve data.

Note: You get the same result by pivoting any of the other Scenario members.

Figure 39: Result of Pivoting (Navigate Without Data Enabled)

A | B [c[p[] EJF] G [HJI] J [JEJL]
L1 tarket
L2 | LActual Budget
L3 | Otrl Qe Gtr3 Oted Year Ol Ot Qb3 Qtrd Year
I 4 [100 Profit
L9 | Inventary
|6 [200 Profit
L7 | Inventary
|8 [300 Profit
L9 | Inventary
100 {400 Profit
11| Inventary
|12 |Diet Prafit
113 | Inventary
14| Product Prafit

5. In cell GI, click the secondary mouse button on Market and drag Market to
product 100 (cell A4).

Essbase executes the pivot without retrieving data.

Figure 40: Result of Pivoting (Navigate Without Data Enabled)

A [ B

C

[DTET F

[GIH] VI TJ] K L]

Market 100
I

200

300

400

Diet

Product

TEEEE

Profit
Irventory
Profit
Irventory
Profit
Irventory
Profit
Irventory
Profit
Irventory
Profit
Irventory

Actual
Qtrl Q2 Otr3

Budget
Qtrd [ Year Qtrl Ot2 Qi3 Otrd

Navigating without data also works with the Keep Only and Remove Only

commands.
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» To navigate without data when using the Keep Only or Remove Only command:
1. Select Qtrl (cell D2) and Qtr2 (cell E2) and select Essbase > Keep Only.

Essbase retains only the selected members and does not retrieve data.

Figure 41: Result of Keep Only (Navigate Without Data Enabled)

A B [ € [DbJEJ]F [G[H]

Qtr2

Market 100 Profit
Irventory

200 Profit
Irventory

300 Profit
Irventory

400 Profit
Irventory

Diet Profit
Irventory

Product |Profit

=y
=

-
pry

-
M

-
(=%

2. Select products 300 (cell B7), 400 (cell B9), and Diet (cell B11) and select
Essbase > Remove Only.

Essbase executes the Remove Only command without actually querying the
database for information.

Figure 42: Result of Remove Only (Navigate Without Data Enabled)

Al B [ € [DJE]FJG[H]
Actual Budget
Qtrl Q2 Qi1 Qtr2

Market 100 Profit
Irventory

200 Profit
Irventory

Product IProfit
Irventory

» To turn off Navigate Without Data when you are ready to retrieve data:
1. Select Essbase > Navigate Without Data.

Essbase removes the check mark next to the menu item.

Note: You can also disable Navigate Without Data by clearing the appropriate
option in the Essbase Options dialog box (Global Tab) or by clicking the Navigate
Without Data button on the Essbase toolbar.
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In cell A3, drill down (double-click) on Market.

Essbase drills down on the Market dimension and also retrieves data into the
worksheet.

Figure 43: Result of Drilling down (Navigate Without Data Disabled)

A [ B [ C D E F G
L1 Actual Budget
2 Qitrl Qtr2 Gt Qtr2
3 |East l100 Prafit 2747 33520 2880 3480
L4 | Inventory 5384 4450 5200 3530
L5 | 200 Prafit 562 510 950 1070
L6 | Inventory 5957 B442 5610 5910
L7 | Product | Profit 5380 6429 G500 7sE0
L8 | Inventory 25744 26214 24710 24030
L9 |West 100 Prafit 1042 849 2380 2130
|10 | Inventory B892 9656 10250 10950
11| 200 Prafit 2325 2423 25700 220
1112 | Inventory 11755 11643 11070 10900
|13 | Product | Profit 7137 7815 8960 9290
14 | Inventory | 35751 41574 39020 42820

Note: If you want to retrieve data without changing the current worksheet view,
you can also retrieve data by simply double-clicking in any data cell or by
selecting Essbase > Retrieve (after disabling Navigate Without Data).

Suppressing Missing Values, Zero Values, and
Underscore Characters

Several types of data can be returned to a worksheet view:

Numeric data values

#NoAccess strings, which are displayed when you do not have the proper
security access to view a data value

#Missing strings, which indicate that no data exists for that member
intersection

Zero data values

A missing value is not the same as a zero value that is loaded into the Essbase
database. When data does not exist for a data cell in Essbase, a value of #Missing
is returned to the worksheet. If any cell in a row contains a value, that row is not
suppressed on a retrieval.
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With Essbase, you can suppress missing and zero values from the display in the
worksheet. In addition, you can tell Essbase to suppress underscore characters that
are in some member names.

» To suppress rows that contain missing values from displaying in the worksheet:
1. Incell C3, double-click the secondary mouse button to drill up on Profit.
2. Pivot Measures (in cell C3) to Actual (in cell D1).
3. In cell B4, drill down (double-click) on product 100.

Notice that, in the South, the product 100-30 row contains all missing values,
indicating that this product is not sold in the South. You may need to scroll
down the worksheet to see this row.

Figure 44: Worksheet View Displaying Missing Data Values

A B C D E F
L1 Measures
L2 | Actual Budget
L3 | Qtrl Qtr2
|4 |East 100-10 2461 25940 2580 3050
L5 | 100-20 212 303 220 300
L6 | 100-30 74 109 110 130
L7 | 100 2747 3352 2880 3480
L8 | 200 562 510 250 1070
L9 | Product 5380 5493 G500 75480
|10 |WWest 100-10 1047 1189 1720 1200
11| 100-20 £7 177 320 200
1112 | 100-30 52 -163 310 30
|13 | 100 1042 849 2350 2130
|14 | 200 2325 2423 2570 2720
|15 | Product 7137 7515 8560 290
|16 | South 100-10 745 835 1160 1280
|17 | 100-20 306 363 570 560
|18 | 100-30 #dissing #lissing | #Missing #lissing

4. Select Essbase > Options, and select the Display tab.

In the Suppress option group, select the #Missing Rows check box and
click OK.

Note: The Suppress #Missing Rows and Zero Rows options are not available
when any of the Formula Preservation options are selected in the Essbase Options
dialog box. For more information on Formula Preservation, see “Preserving
Formulas When Retrieving Data” on page 145.
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6. Select Essbase > Retrieve to update the worksheet.

Note: After you change a worksheet option in the Essbase Options dialog box, you
must perform a retrieval or drill operation to have the new setting take effect.

Essbase suppresses product 100-30 from the South member group.

Figure 45: Result of Suppressing Missing Data Values

A B [ C D E F [ G |
| 4 [East 100-10 2461 2940 2550 3080
15 | 10020 212 303 2200 300
| 6 | 100-30 74 103, 110 130
| 7 | 100 2747 3352 2880 3480
| 8 | 200 E62 610 960 1070
EN Product| 5380 E499 6500 7540
|10 [west 100-10 1047 1183 1720 1800
K 10020 7 77 320 20
|12 | 100-30 £2 163 30 @0
|13 | 100 1042 849 2350 2130
|14 | 200 2325 2423 2570, 2720
|15 | Product| 7137 7515 8960 9290
|16 |South 100-10 745 835 1160 1280
|17 | 10020 306 33 570 6D
|18 | 100 1051 1198 1730 1940
|19 | 200 1465 1540 1640 1700
|20 | Product| 3077 3267 41800 4410
1|Central  100-10 843 928 1080/ 1180

7. Select File > Close to close the worksheet. You do not need to save

the worksheet.

Note: After you enable the Suppress #Missing Rows feature in the Essbase
Options dialog box, any missing values suppressed during a data retrieval are not
retrieved again by simply disabling the feature. If you disable the feature in the
Essbase Options dialog box, missing values are retrieved from only that point on.
For example, in the tutorial task described above, Essbase could not go back and
return the missing values for product 100-30. To return these missing values to the
worksheet, you disable the Suppress #Missing Rows feature, drill up on a Product
member, and then drill down again.

You can also suppress zeros and underscore characters as described in the task
above by clicking the appropriate options in the Suppress option group in the
Essbase Options dialog box (Display tab).
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In addition to suppressing specific values and characters during retrieval, Essbase
enables you to define a label for missing values (#Missing) or for data you do not
have access to (#NoAccess). If you define a replacement label for these values,
Essbase displays the replacement labels instead of the default labels. For more
information on defining replacement labels for the #Missing and #NoAccess
labels, see the Essbase Spreadsheet Add-in online help.

Formatting the Worksheet

Essbase provides you with various ways to customize the worksheet view. For
example, you may want to apply visual cues, or styles, to certain member names
or to data cells in the worksheet, or you may want to display alternative names, or
aliases, for member names. This section steps you through the following
formatting procedures:

e “Formatting Text and Cells” on page 73

e “Displaying Aliases for Member Names” on page 82
e “Displaying Both Member Names and Aliases” on page 84
e “Repeating Member Labels” on page 85

This section of the tutorial starts with a new worksheet.

Formatting Text and Cells

In a spreadsheet report, you may have many hierarchical levels of database
information displayed. By defining and applying visual cues, or styles, to the text
and cells in the worksheet, you can easily keep track of specific database members,
dimensions, and cell functions. Styles are a great way to help view and distinguish
data in Essbase Spreadsheet Add-in.

Note: Keep in mind that applying styles requires additional processing during a
retrieval request. For more information, see “Removing Styles” on page 82.
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This section of the tutorial describes the following:

“Applying Styles to Parent Members” on page 74

e “Applying Styles to Dimension Members” on page 77

e “Applying Styles to Data Cells” on page 80

e “Determining the Precedence of Overlapping Styles” on page 81

e “Removing Styles” on page 82

Note: For a discussion of the relationships among Essbase database members, see
“Database Outlines” on page 26.

Applying Styles to Parent Members

Each dimension in a database may contain a large number of hierarchical levels.
As you view data in the worksheet, you may not be familiar with all the
hierarchical levels of the database outline. To indicate which members have
underlying children, you can apply formatting styles to parent members, including
those with attributes.

» To apply styles to parent members:

[

1. To open a new worksheet, select File > New or click the —l icon.

2. Select Essbase > Retrieve.

Note: You should still be connected to the Sample Basic database. If you are not
connected, follow the steps in “Connecting to a Database” on page 45.

In cell A2, drill down (double-click) on Year.

Select Essbase > Options.
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5. In the Essbase Options dialog box, select the Style tab.

Note: The Style tab is available only when you are connected to a database.

Essbase displays the Style tab.

Figure 46: Essbase Options Dialog Box, Style Tab

Essbase Options E
Display I Zoom I Mode  Style | Global I
— Member
— Sample

v
[ Chid Farem
[ Shared

— Dimenszion
= — Sample
v Measures Year
v Product LI
¥ Cell Border
Background Color: I Mone j Format... |

— Drata Cell

— Sampl
[WlLinked Objects s
I Integration Server Drill-Through
[ Read Only LI
Farmat.. |

Connection Information:

’7 Localhost:S ample: B azic ‘

QK | Cancel | Help |

In the Members area, you can define styles for various types of database
members, such as parent, child, and shared members.

6. In the Members group box, select the Parent check box.

Clicking this box defines a font and color style for parent member names.
Essbase defines a default color of navy for all parent members. You can select
a font format by clicking the Format button to the right of the Members box

and using the Font dialog box.

Essbase Spreadsheet Add-in for 1-2-3 75



A Basic Essbase Tutorial

7. Click the Format button.
Essbase displays the Font dialog box.

Figure 47: Font Dialog Box

Font

Font: Font style:
| Bold
M Albertus Extra Bold ﬂ Fegular
T Albertuz Medium |talic
Anna Eold
T Antique Olive Bold Italic
o Avial
Avial Black
T Arial Narmow LI
— Effect: — Sample
[ Stikeout
™ Underline
Lolor:

I- Mawy vl Script:

8. In the Font style list box, select Bold and then click OK.

Note: Essbase displays an example of the selected style in the Sample box.
9. Click OK again.

Even though you have defined styles, they are not enabled until you select the

Use Styles check box from the Essbase Options dialog box and refresh the
worksheet.

10. Select Essbase > Options, and select the Display tab.

11. In the Cells option group, select the Use Styles check box to enable your
styles, and then click OK.
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12. Select Essbhase > Retrieve to refresh the worksheet and apply the styles.
Essbase displays parent member names in bold, navy font.
13. In cell A2, drill down (double-click) on Qtrl.

Essbase displays Jan, Feb, and Mar in a regular font, because these members
do not have underlying children.

Figure 48: Styles Applied to Parent Members

A [ B [ ¢ | 0 [ E ]
|1 Measures Product  Market  Scenario
| 2 [Jan 8024
| 3 |Feb 5346
| 4 [Mar 5333
15| Qut 24703
|6 | Qa2 2na7
|7 Qul 27912
18| ot 25500
| 9 | Year | 105522

Applying Styles to Dimension Members

In addition to applying styles to parent members (as you did in the previous
section), you can also apply styles to members of a dimension in a database.
Applying styles to dimensions makes it easy to view the various dimension
members in Essbase Spreadsheet Add-in.

» To apply styles to dimensions:
1. Select Essbase > Options and select the Style tab.

2. In the Dimensions group box, select Year.

3. Select the Cell Border check box to create a border around each cell that
contains a member from the selected dimension.
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4. From the Background Color list box, select Yellow.

9.

Figure 49: Selecting a Background Color from the Style Tab

Essbase Options E
Display I Zoom I Mode  Style | Global I
— Member
Attribute: — Sample
e Parent
[ Chid
LjShared LI Farmat. |
— Dimenszion
Dimension: - Sample
v
[ Measures Year
I Product LI
¥ Cell Border
Background Color: ||:| ellow - Format... |
—Data Cells =
Attribute: — Sample
Farmat.. |

Connection Information:
’7 Poplar. 5 ample:Basic

QK I Cancel | Help |

Click the Format button that is to the right of the Dimensions list. Essbase

displays the Font dialog box.

From the Font style list box, select Bold, and then click OK.

Note: Essbase displays an example of the selected style in the Sample box.

From the list of dimensions, select the Measures dimension and, from the
Background Color list box, select Fuschia.

From the list of dimensions, select Product, and clear the Cell Border check

box.

From the Background Color list box, select Aqua.

10. Scroll down the list of dimensions, and select Market.
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Select the Cell Border check box, and click the Format button that is to the
right of the Dimensions list.

When the Font dialog box is displayed, from the Font style list box select
Italic, and then click OK.

From the list of dimensions, select Scenario, and from the Background
Color list box, select Red.

Click the Format button, and from the Color list box, select White.

Click OK twice to return to the worksheet.

Note: When you define styles, your choices are saved to the Windows Registry on
your local machine. You can define one set of styles per database.

In cell D1, drill down (double-click) on Market.

Press and hold the Alt key and drill down (double-click) on Scenario
(in cell E1).

Select Essbase > Retrieve to refresh the worksheet.

Essbase redisplays the worksheet and implements the newly defined styles.
For example, members of the Scenario dimension are displayed with a red
background.

Figure 50: Dimensions with Styles Applied

A B C D | E [ F [ 6 ]
|1 Product
L2 | Actua “ariance ance
| 3 |East Jan 2080 1732
| 4 | Feb 1843 2230 1843
| & | Mar 1805 2190 1805
| B | Qur1 5380 G500 5380
| 7| Q2 5493 75480 5493
| & | O3 G346 75480 G346
| & | Otrd 5536 5790 5536
| 10| Year 24161 25320 24161
| 11 |West Jan 2339 2580 2339
|12 | Feb 2394 2590 2394
| 13| Mar 2404 2590 . 2404
|14 | Qur1 7137 8560 -1823) -20.346 7137
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Applying Styles to Data Cells

You can apply styles to data cells, such as read-only cells, read/write cells, linked
object cells, and Essbase Integration Server drill-through cells to distinguish them
from other cells in the worksheet. The Sample Basic database that you are using
for this tutorial does not contain data cells with any of these characteristics. In the
advanced tutorial presented in Chapter 3, you attach a linked reporting object to a
data cell and apply a style to the cell.

Note: You cannot perform the actions in light-shaded boxes.

» In general, to apply styles to data cells, follow these steps:

1.
2.

Select Essbase > Options, and select the Style tab.

In the Data Cells option group, select the Linked Objects, Integration
Server Drill-Through, Read Only, or Read/Write check box.

Click Format.

In the Font dialog box, specify the font, font size, font style, color, and
effects, and click OK.

Note: Essbase displays an example of the selected style in the
Sample box.

Figure 51: Sample Style for Read/Write Data Cells

Sample———
Linked Objects

Data Cells

[EllLinked Objects
I Integration Server Drill-Through
[ Read Only LI

Repeat Step 2 through Step 4 to set styles for other data cells.

Select the Display tab and select the Use Styles check box to apply styles
to the worksheet.

Click OK to close the Essbase Options dialog box.

Select Essbase > Retrieve to display the new styles in the worksheet.
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Determining the Precedence of Overlapping Styles

The only way you can apply a background color to data is to define a style for
dimensions. If dimension styles are defined, and the Use Styles setting is turned
on, members of a dimension always have the background color defined for their
dimension.

The text styles that you can apply to members, dimensions, and data cells have a
hierarchy that determines which characteristics are applied. Member styles are at
the top of that hierarchy. Thus, member styles are always applied (as long as styles
are turned on). Note that in Figure 50, the Qtr1 label in cell B6 is in bold, navy
font, and has a yellow background. The navy font comes from the style defined for
parent members, and the yellow background comes from the style defined for
Year.

Essbase uses the following order of precedence when applying multiple text styles:
e Linked object cells

e Integration Server Drill-Through cells
e Read-only cells

e Read/write cells

e Parent member cells

e Child member cells

e Shared member cells

e Cells containing formulas

e Dynamic calculation member cells

e Attribute cells

e Dimension cells

If you want to see a child member style, make sure that the parent member style is
turned off. If you want to see a shared member style, make sure that both parent
and child member styles are turned off.
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Removing Styles

Styles can be very helpful tools for keeping track of data in Essbase Spreadsheet
Add-in. Applying styles, however, involves additional processing time during a
retrieval request. This additional processing has a slight impact on the speed of
Essbase retrievals.

If you do not want to apply styles to the worksheet view, you can clear them. You
can also turn off styles so they are not displayed when you refresh the view (by
selecting Essbase > Retrieve, for example). So that the worksheet matches the
illustrations presented in the following tasks, do not remove styles if you are
stepping through the tutorial.

Note: If you have styles applied to the worksheet and you execute the FlashBack
command, these styles are temporarily removed from the current view. The styles are
re-applied whenever you initiate a retrieval. You cannot perform the actions in the
light-shaded boxes.

» To remove all styles from a worksheet:

1. Select all cells in the worksheet.

2. From the Lotus 1-2-3 menu bar, select Edit > Clear > Styles.

» To disable styles:

1. Select Essbase > Options and, select the Display tab.
2. In the Cells option group, clear the Use Styles check box, and click OK.

Note: If you turn styles off without clearing them from the worksheet, the styles remain
in the current worksheet view when you refresh the view. The styles remain to avoid
removing any styles that you may apply to individual cells using native worksheet
formatting options.

Displaying Aliases for Member Names

Aliases are alternate names for database members. You can create reports that use
the database member name, which is often a stock number or a product code, or an
alias name, which can be more descriptive. Aliases are defined by the Essbase
application designer. Each database can contain one or more alias tables.
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For example, members of Product in the Sample Basic database are defined as
codes, such as 100 and 200. A descriptive alias for each member of Product, such
as Colas and Root Beer, is defined in an alias table. In some cases, alias names may
vary depending on the combination of other database members. For example, a
Product member may have a different alias for each market in which it is sold. For
more information, see the Essbase Spreadsheet Add-in online help or the Essbase
Database Administrator’s Guide.

» To display the alias of a member rather than its database name:

1. In cell C2, double-click the secondary mouse button to drill up on Actual.

2. Press and hold the Alt key and drill down (double-click) on Product (in
cell D1).

Select Essbase > Options, and select the Display tab.

In the Aliases option group, select the Use Aliases check box to display
member aliases.

5. Select Default from the Alias list box.
Figure 52: Enabling Aliases in the Essbase Options Display Tab

Essbase Options E
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™ Underscore Characters far Row Dimensions
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V' Use Styles Ifefaur:t j
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= Aute Sort Homs Query Designer
" Bepeat Member Labels ’7|_ Use Sheet Options with Query Designer

— Dynamic Time Serie
™ Latest Time Period IJan j

QK I Cancel Help
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Click OK.

Select Essbase > Retrieve to refresh the worksheet and display the alias
names.

Essbase changes the Product codes (100, 200, and so forth) to their predefined
aliases (Colas, Root Beer, Cream Soda, and so forth). In the Sample Basic
database, Product is the only dimension with predefined aliases.

Figure 53: Result of Displaying Aliases

A B [ ¢ [ D E F G
1

| 2 | Colas Root Beer Cream Soda  Fruit Sod: Diet Drinks
EX

| 4 |East Jan 924 184 466 181
| 5 | Feh B85 242 200 513 188
| 6 | Mar 935 162 207 501 189
|7 Qur1 2747 562 591 1480 555
| 8 | Q2 33582 610 922 1615 652
19| Qi3 3740 372 522 1712 G44
| 10 Qted 2817 990 592 1537 567
| 11| Year 12656 2634 2627 5344 2408
| 12 |West Jan 378 762 785 454 BE3
| 13 | Feh 337 781 797 479 683
| 14 | Mar 327 792 811 474 679

Notice that Essbase is still displaying the styles that you created and applied
in the previous sections.

Displaying Both Member Names and Aliases

In addition to displaying aliases for database members, you can also tell Essbase
to display both aliases and database member names in Essbase Spreadsheet
Add-in.

2
3.
4

To display the name and alias of a member:

1.

In cell B8, double-click the secondary mouse button to drill up on Qtr2.
In cell C2, select Colas, and then select Essbase > Pivot.
In cell C3. select Year, and then select Essbase > Pivot.

Select Essbase > Options, and select the Display tab.
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5. In the Aliases option group, select the check box for Use Both Member
Names and Aliases for Row Dimensions.

Be sure that Use Aliases is already checked.
6. Click OK to return to the worksheet, and select Essbase > Retrieve.

Essbase displays both member names and their aliases for row dimensions.
Because the only row dimension in this example that has preassigned aliases
is Product, only the Product members display their aliases. Region members
simply repeat the member name instead of displaying an alias.

Figure 54: Result of Displaying Both Member Names and Aliases

A [ B [ ¢ [ D ] E F

|1 Year

| 2 |

| 3 [T00 Colas East East 12656
| 4 | West West 3549
| 5 | South South 4773
| 6 | Central  Central 2490
| 7| Market  Market 30465
|8 [200 RootBeer  East East 2534
| 9 | West West 9727
| 10| South South G114
|11 Central  Central 9573
| 12 | Market  Market 27954
| 13 |300 Cream Soda Fast East 2627
| 14 | West West 10731
| 15 | South South 2350

Repeating Member Labels

By default, Essbase displays member labels only once for each nested row and
column group. If you are connected to a large database when using Essbase
Spreadsheet Add-in, you may have to scroll down or across the worksheet to see
additional data rows and columns. In some cases, as you scroll down or across,
member labels may disappear from view. Essbase provides a feature for repeating
member labels in each row or column cell that represents a data point so that you
can always see a member label in the worksheet view.
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» To repeat member labels down and across the worksheet:
1. Select Esshase > Options, and select the Display tab.

2. Inthe Aliases option group, clear the Use Both Member Names and Aliases
for Row Dimensions check box.

3. In the Cells option group, select the Repeat Member Labels check box, and
then click OK.

Figure 55: Enabling the Repeat Member Labels Option
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4. 1In cell E1, drill down (double-click) on Year.

Essbase displays a member label in every column and row cell. For the Sample
Basic database that you are using for this tutorial, repeating member labels is
probably not necessary because the database is relatively small. This feature
is particularly helpful for keeping track of member labels when scrolling
through large worksheets.

Figure 56: Result of Repeating Member Labels

A [ B [ ¢© D

11|

El Scenario
| 3 |Qurd Colas East 2747
| 4 |Qurd Colas West 1042
| 5 |Qurd Colas South 1051
| B |Qurd Colas Central 2208
| 7 Qurd Colas Market 7048
| 8 |Qurd Root Beer  Fast 562
|9 |Qurf Root Beer  VWest 2325
| 10| Qtrd Root Beer  South 1465
| 11| Qrd Root Beer  Central 2369
|12 | Qtrd Root Beer Market 6721
|13 | Qurd Cream Soda  Fast 591
| 14 | Qtrd Cream Soda West 2363
| 15 | Qtrd Cream Soda  South 561
| 16 | Qtrd Cream Soda  Central 2414

Note: Even if you clear the Repeat Member Labels check box in the Essbase
Options dialog box, Essbase retains the repeated member labels in the worksheet
view. To remove the repeated labels, you need to do one of the following:

® (Clear the check box and open a new worksheet
® (Clear the check box and pivot the row group to a column group and

then pivot it back to a row group (or vice versa)
® Select Essbase > FlashBack and clear the check box
5. Before returning to the tutorial, complete the following actions:

a. Select Essbase > Options, and select the Display tab.

b. In the Cells option group, clear the Repeat Member Labels check box,
and then click OK.

c. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Essbase Spreadsheet Add-in for 1-2-3 W 87



A Basic Essbase Tutorial

Creating Queries Using Essbase Query
Designer

So far, you have seen how easy it is to retrieve data and navigate through Essbase
Spreadsheet Add-in in an ad hoc fashion. Essbase also provides a query designer
so that you can define a database query for retrieving dimensions and database
members into the worksheet. Essbase Query Designer (EQD) replaces Retrieval
Wizard, and is used to define queries in previous versions of Essbase Spreadsheet

83 W

Add-in.

Before Hyperion Essbase actually retrieves data, Essbase Query Designer
provides a series of panels so you can request the data that you want to view in the
worksheet. It is particularly helpful when you know exactly which data you want
to retrieve from the server. In addition, you can save a query and use it again.

The Essbase Query Designer window (Figure 57) consists of the following panels:

e The navigation panel provides access to the various features in Essbase Query
Designer. You can display all the dimensions used in a particular query and
access the various properties of each dimension member.

e The hint panel provides a brief description of the feature that is selected from
the navigation panel.

e The properties panel provides access to the following functions:

Layout: Design the layout of the spreadsheet report. To change the default
layout, select a dimension tile and drag it to one of the other dimension
boxes. To access the member select panel and to define a member for a
query, double-click a dimension tile.

Member Select: Select members that you want to display in the rows of
the spreadsheet report. To select a member, right-click the member, and
select Add to Selection Rules. You can also double-click a member to add
it to the selection rules.

Member Filter: Filter the member selection by attribute, generation name,
level name, pattern string, or UDA.

Data Filter: Retrieve rows of data. The retrieval is based on the ranking
of the rows within certain columns. Use this panel to access the data
restriction panel.

Data Restriction: Filter data by comparing it to a fixed data value
(including a negative value), a set of data values, or #Missing data values.
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— Data Sort: Sort rows in ascending or descending order. The sort is based
on column data values.

—  Messages and Confirmation: Turn on and turn off certain messages from
Essbase Query Designer.

— Help: Access documentation about Essbase Query Designer.

Creating and Changing Queries

To access any of the Hyperion Essbase Query Designer panels, select the
appropriate feature listed in the navigation panel.

As you create a query or make changes to an existing query, the changes are
reflected in the navigation panel. To view a dimension or a member of an open
query, click on the specific dimension or member in the query outline that is
displayed in the navigation panel. Selected members are displayed in the member
selection panel on the right.

You can also revise an existing query in the member selection panel. For example,
you can delete a member or add a member to the query by selecting a member in
the navigation panel and making the appropriate changes in the properties panel.

Note: Files created using the obsolete Retrieval Wizard feature can be opened in
Essbase Query Designer. However, if a query contains more than two member filters
per selection rule or more than two data restrictions, the member filters may be out of
order. To ensure correct results, rearrange the member filters in the navigation panel, if
necessary.

For complete information on Essbase Query Designer options, see the Essbase
Spreadsheet Add-in online help.

CAUTION: Manipulation of worksheets in VBA such as naming worksheets
or moving worksheets may not work when EQD is running.
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Creating Queries

» To create a query using Essbase Query Designer:

1. Select Essbase > Query Designer.

Essbase displays the Essbase Query Designer welcome panel.

Figure 57: Essbase Query Designer Displaying Welcome Panel

_r'T Hyperion Essbase Query Designer
1 Spreadshests - Latus 1-2-3

E@ <<chlotusiiork T2 ntitled 123>
<<cilotusiiork 123 ntitled 123>
B Messages & Confimations
Help

OGN
000
O 0

Hyperion

Hiyperion Esshase Query Designer replaces the Retrieval Wizard
tocreate repotts using a more advanced user interface. Use this
feature to:

Create and modifyy spreadsheet gqueries.

Specify which dimensions display in rows and columns.
Cuickly select members and attributes to view in repotts.
Filter members to create more detailed repotts.

Analyze data in reports by sorting, ranking, and filtering data.

To start a new gquety:

1. Fromthe navigation panel (the screen to the left of this panel), select the name of the
wotksheet; for example, [Bookl]3heet] in Excel, or <<Untitled 123>>4 in Lotus 1-2-3.
2. With the wotksheet selected, click the right mouse button, and from the pop-up menu,
select Qu Mew > Query.
Hote: If you have not logged into a database, the Esshase System Login dialog boxis
displayed. Youneed to log into a database before proceeding,

Refer to the hint panel (the panel above this screen) for help on other panels.

Click the question mark icon in the navigation panel (the screen to the left of this panel) to
access a tutorial and online help for Hypetion Esshase Query Designer.

Click the question mark icon in the title bar of this screen to access What's This? Help.
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2. To create a new query, select <<c:\lotus\Work\123\Untitled.123>>A,

right-click, and select New > Query.

A Basic Essbase Tutorial

Hyperion Essbase displays the layout panel of Hyperion Essbase Query

Designer.

Figure 58: Essbase Query Designer Displaying Layout Panel

r'} Hyperion Essbase Query Designer

- JE Help

Elij Spreadsheets - Lotus 1-2-3
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] Column
U. ear
=-{£] Awailable Dimensions
Caffeinated [Baze:Product]
Intro D ate [Baze: Product]
Ounces [Baze:Product]
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52 Data Filkering
=] Data Sorting
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Tse this layout panel to design the lagout of the

teport.

1. Belect a dimension tile from a dimension box.

2. Dragthe dimension tile to a page, row, or column
dimension hox.

3. Double-click a dimension tile to access the
memmber select panel to define members for the
uery.

tou have completed designing the layout of the

query.
Page Dimengions:
Product | Market | Scenario
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Row Dimensions: Calumn Dimenzsions:
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B
=
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]
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=
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3. Define the worksheet layout by dragging the dimension tiles as follows:

a. Drag Market and Product to the Row location.

b. Drag Measures to the Page location.

c. Drag Scenario below Year (in the Column location).
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Figure 59: Changing the Worksheet Layout

r'Tp Hyperion Essbase Query Designer EHE
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Tse this layout panel to design the layout of the report.

1. Belect a dimension tile from a dimension box.

2. Dragthe dimension tile to a page, row, ot column dimension
hox.

3. Dowble-click a dimension tile to access the member select
panel to define members for the query.

ou have completed designing the layout of the query.

Page Dimengions:

Intro D ate [Baze: Product] Measures |
Ounces [Baze:Product]
Pkg Type [Baze:Product] LI LI
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B
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52
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4. To select the Measures dimension in the navigation panel, select the Measures
icon. Alternatively, double-click the Measures tile in the layout panel.

Essbase displays the member select panel, where you can select a member
from the Measures dimension.

Note: You can select only one member from the dimension in the Page location.
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5. Select Profit, right-click, and select Add to Selection Rules. Alternatively,
double-click Profit to add it to the selection rules.

Profit is displayed in the selection rules list.

Figure 60: Hyperion Essbase Query Designer Displaying the
Member Select Panel

r'} Hyperion Essbase Query Designer
=] Spreadsheets - Lotus 1-23

- JE Help

E@ <<chlotusiiork T2 ntitled 123>
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ntro Date [Base:Product]
unces [Base:Product]

lg Type [Base:Product]
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S Attribute Caloulations

----- 52 Data Filkering

----- =] Data Sorting

----- B Messages & Confimations

[Tse this member select panel to select a member for the page
dimension. You can select only one member per page dimension.
1. Belect a member in the "hMembers" list box.

: 2. With the member selected, click the right mouse button, and
a, from the pop-up men, select Add to Selection Fules.
3. Select the member in the "Selection Rules" list box.
Tou have completed defining the member for the page dimension.
Members:
El- Measures
- Prafit
Inventory
[#- Ratios

Selection Rules:

Note: In Essbase Query Designer, after you make your selections, you do not
need to confirm them; for example, you do not have to click OK. If you do not select
members from any given dimension, Essbase uses the top member of the

dimension.
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6. To select members of the Year dimension, complete the following actions:

a. In the navigation panel, click the Year icon. Alternatively, double-click

the Year tile in the layout panel.

Essbase displays the member select panel for the Year dimension.

b. Select Qtrl, right-click, and select Add to Selection Rules.

c. Add Qtr2, Qtr3, and Qtr4 to the selection rules in the same manner.
Because Year is in a Column location, you can select one or more

members.

Figure 61: Adding Members to the Selection Rules
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Tse this member select panel to select a member for the column
dimension.
1.
2.

.
.

Mote: Follow Step 44f you want to filter the member selection;
otherwize, you have completed the member selection for the

column dimension.

Select a member in the "IMembers" list box.

With the member selected, click the tight mouse button, and
from the pop-up men, select Add to Selection Fules.

Select the member in the "Selection Rules" list box.

With the member selected, click the tight mouse button, and
from the pop-up men, select ember Filter.

Members:

- ear

- Gtrl
- Q2
- Q3
- Qtrd

[ [ [

Selection Rules:
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7. To select members of the Scenario dimension, complete the following actions:

a. In the navigation panel, select Scenario. Alternatively, double-click the
Scenario tile in the layout panel.

The members of the Scenario dimension are displayed in the member
select panel.

b. Select Actual, right-click, and select Add to Selection Rules.
Actual is added to the Selection Rules box.
c. In the same manner, add Budget to the Selection Rules box.
8. To select members of the Product dimension, complete the following actions:

a. In the navigation panel, select Product. Alternatively, double-click the
Product tile in the layout panel.

The members of the Product dimension are displayed in the member
select panel.

b. Select product code 100, right-click, and select Add to Selection Rules.
Repeat the process for product codes 200, 300, and 400.

In the Selection Rules list box, select product code 100, right-click, and
then, from the popup menu, choose Select > Children.

This action selects all children of 100. Essbase displays All Children next
to 100 in the Selection Rules list box.
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e. In the Selection Rules list box, select product code 400, right-click, and
choose Select > Descendants.

Essbase displays All Descendants next to 400 in the Selection Rules list

box.

Figure 62: Selecting Members of Product
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Mote: Follow Step 44f you want to filter the member selection;
otherwize, you have completed the member selection for the row
dimension.

[ 7] %]
Tse this member select panel to select a member for the row
dimension.
1. Belect a member in the "IMMembers" list box.
: 2. With the member selected, click the right mouse button, and
a, from the pop-up men, select Add to Selection Fules.
3. Select the member in the "Selection Rules" list box.
4. With the member selected, click the right mouse button, and

from the pop-up men, select ember Filter.

Members:

=1~ Product

7100
200
300
400
- Diet

Selection Rules:

-100, Al Children

-200
-300

% H
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f. To view the list of all product codes that will be retrieved into the
worksheet, select any of the entries in the Selection Rules list box
(for example, 200), right-click, and select Preview.

Hyperion Essbase displays the Member Selection Preview dialog box.

Figure 63: Selected Members of Product Dimension

Member Selection Preview E
Selected Members:
100-10 -
100-20 _I
100-30
200
300
400-10
400-20
400-30
The selected rule returned 8 members.

g. Click Close to close the Member Selection Preview dialog box.
9. To select members of the Market dimension, complete the following actions:

a. In the navigation panel, select Market. Alternatively, double-click the
Market tile in the layout panel.

The members of the Market dimension are displayed in the member select
panel.

b. Inthe Member list box, select East, right-click, and select View by >
Generation.

c. To pick the second generation of the Market dimension, in the Member
list box, select Region, right-click, and select Add to Selection Rules.
Alternatively, double-click Region to add it to the selection rules.

Region is displayed in the Selection Rules list box.
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d. To view the list of members that will be retrieved into the worksheet, in
the Selection Rules list box, select Region, right-click, and select
Preview.

Essbase displays East, West, South, and Central in the Member Selection
Preview dialog box.

Figure 64: Generation Name Selection

Member Selection Preview E
Selected Members:
East ;I
et
South
Central
The selected rule returned 4 members.

e. Click Close to close the Member Selection Preview dialog box.

You have now defined a basic Essbase query. The outline of the query is
displayed in the navigation panel.
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10. In the navigation panel, select <<c:\lotus\Work\123\Untitled.123>>A -
Queryl, and then right-click and select Save Query.

Essbase displays the Essbase Query Designer Save As Query dialog box.
You can save your query to the server or to your own client machine. To save
to the server, you must have a security level of database designer or higher.
Contact the Essbase system administrator for more information.

11. Select Client.

Figure 65: Essbase Query Designer Save As Query Dialog Box
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|

12. Click the File System button.
Essbase displays the Save As dialog box.

Figure 66: Save As Dialog Box

Save jn: IaTemD j gl IEE_

Wbe
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13. Select a location, in the File name text box, type Basicl and then click Save.

You will use the Basicl query again in Chapter 3

Figure 67: Hyperion Essbase Query Designer Displaying
Query Information Panel
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14. In the navigation panel, select
<<c:\lotus\Work\123\Untitled.123>> A - Basicl, then
right-click, and select Apply Query.

The result of the query is displayed in the worksheet.

Figure 68: Results of a Essbase Query Designer Query

A B C D F G H J
1

12 Otr3
| 4 |East Cola 2451 2550 3050 3298 3440 2410
|5 | Diet Cola 212 220 300 312 310 240
= Caffeine Free Cola 74 110 130 130 190 150
L7 | Root Beer 562 960 1070 372 B30 1500
| 8 | Cream Soda 591 770 1010 522 BE0 530
|9 Grape B45 840 860 710 820 800
| 10 | Orange 290 350 380 377 420 440
| 11] Strawberry 545 700 750 625 780 670
| 12| West Cola 1047 1720 1800 1339 2120 1780
|13 Diet Cola 57 320 200 -1564 250 320
| 14 | Caffeine Free Cola 62 310 30 -286 -130 70
|15 Root Beer 2325 2570 2720 2540 2820 2840
| 16 | Cream Soda 2363 2620 2970 2937 3230 2850
|17 | Grape 1143 920 980 1271 1020 920
| 18| Orange 1002 B10 340 1192 1000 630
|19 Strawberry 738 -310 -380 -900 -440 -400
|20 |South  Cola 745 1160 1280 1031 1440 1510
21 Diet Cola 306 570 660 261 570 550

Note: In the Display tab under Essbase > Options, if you select Use Styles and
Use Sheet Options with Query Designer, the styles you selected for dimension
members will be applied to the initial query results. If you do not select Use Sheet
Options with Query Designer, even if you have selected Use Styles, they will not
be applied to the initial query results. To apply styles, select Essbase > Retrieve.
When Essbase returns the data to the worksheet, you are free to further investigate
the data by performing Zoom, Keep Only, Remove Only, and Pivot operations.

Deleting Queries

You can delete a query only from the location where you saved that query. For
example, if you save a query in the /essbase/client/sample directory, you
can delete the query from within the sample directory. You cannot delete the

query from within Hyperion Essbase Query Designer.

Viewing Messages and Confirmations

Hyperion Essbase Query Designer displays messages and confirmations about
certain actions, such as moves and deletes, in the messages and confirmations

panel.
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3.

that message.

box).

» To turn on or turn off messages and confirmations:
1.
2.

Select the Messages and Confirmations icon in the navigation panel.

To turn on (enable) a message, select the check box that is displayed next to

To turn off (disable) a message, select the check box again (clear the check

Figure 69: Messages and Confirmations Panel

Colurnn

I'_—'l---':'. Scenario

B Actual

I'_—'I--Ej Available Dimensions

Ounces [Baze:Product]

----- % Attribute Calculations
W [Drata Filtering, Top 30
Otr1, Actual <= 500

----- B 400, &1l Descendants

Tse this messages and confirmation panel to tuen on

and off certain messages from Hypetion Esshase Query

Diesighet.

1. Belect the cotresponding check boxnext to a
message to enable that message.

2. Select the check box again to clear the check box
and turn off a message.

ou have completed selecting the message

notifications that you want turned on or off.

[ 1Dimension move deletes member selection rules
[w] Dimengion move deletes zorting and filtering rules
[ 1Confirm delete of member filker

[ 1Confirm delete of member selection rule

[ 1Confirm delete of data restriction

[ 1Confirm delete of data sorting rule

[ lAction deletes data sorting and filtering rules
[C15ave query only on spreadsheet application cloze

----- B Caffeinated (Basze:Product)
Intro D ate [Baze: Product]

Pkg Type [Baze:Product]
Population [Base:Market]
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Accessing Help

Access online help or the tutorial for Hyperion Essbase Query Designer by using
the help panel. To access the help panel, in the navigation panel, select Help. For
more information on a particular topic, click the Online Help button in the

properties panel. To access the online tutorial, click the Tutorial button in the
properties panel.

Figure 70: Essbase Query Designer Help Panel

e

[ 7] x]
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%% Data Filtering, Top 30
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OR Qtr, Actual <= Qtr2, Actual
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-
« | 2
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Connecting to Multiple Databases from Essbase Query
Designer

You can connect to several databases and create separate queries on each database
from Essbase Query Designer.

104 W

To connect to multiple databases from Essbase Query Designer:

1.
2.
3.

Logon to Essbase and connect to the server you want to access.
Select Essbase > Query Designer to open Essbase Query Designer.

Select <<c:\lotus\Work\123\Untitled.123>>A, right-click, and select
Connect.

Essbase displays the Essbase System Login dialog box.
Type your password, and click OK. Select Sample Basic, and click OK.

Select <<c:\lotus\Work\123\Untitled.123>>A, right-click, and select New >
Worksheet.

Select the new worksheet, <<c:\lotus\Work\123\Untitled.123>>B, right click,
and select Connect.

Essbase displays the Essbase System Login dialog box.
Type your password, and click OK. Select Samppart Company, and click OK.

Note: You are restricted to one connection per worksheet. The connection
information is displayed in the query information panel of the Hyperion Essbase
Query Designer only when you open an existing query or create a new query.

To create a new query based on Sample Basic, select
<<c:\lotus\Work\123\Untitled.123>>A, right click, and select New > Query.

To create a new query based on Samppart Company, select
<<c:\lotus\Work\123\Untitled.123>>B, right-click, and select New > Query.

10. To open an existing query, right click, and select Open Query.

You are now ready to proceed with the process of creating queries or opening
existing queries.
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Applying Worksheet Options to Essbase Query

Designer Results

You can also apply any of the worksheet options you have previously set from the
Essbase Options dialog box to the results of a query created in Essbase Query
Designer.

» To enable Essbase Query Designer to use your previously set worksheet options:

1.
2.

Essbase Spreadsheet Add-in for 1-2-3

Select Essbase > Options.

In the Essbase Options dialog box, select the Display tab.

Select the Use Sheet Options with Query Designer check box, and select

OK.

Select Essbase > Retrieve to refresh the worksheet.

Essbase displays the results of the query you created in Essbase Query
Designer and implements your previously set worksheet options.
For example, note that aliases, instead of the numeric codes, are now

displayed for the Product dimension.

Figure 71: Results of Query with Options Applied

A ] C D E F G 1]
| 1]
| 2 |
=N c al [Bud al |[Budg
| 4 [East | Cola 2461 25600 2940 3050 3298 3440 24300 2410
| 5 | Grape B45 8400 BB 860 710 920 B18 800
| 6 | Cream Soda 591 770 922 1010 522 G660 592 &30
| 7 | Root Beer 862 950 B0 10700 372 830 990 1500
| 5 | Strawherry B45 7000 B12 780 B25  7A0 A28 &0
ER Orange 290 3500 37 380 377 4200 394 440
| 10| Diet Cola 212 2200 303 3000 3120 MO 287 290
|11 | Caffeine Free Cola. 74/ 110 109 130, 130 190 100 140
| 12 |West Cream Soda 2363 2620 2739 2970 2937 3230 2692 2840
| 13| Root Beer 2325 25700 24273 27200 2540 2820 2439 2840
| 14 | Grape 1143 8200 1167 9600 1271 10200 1218 920
|15 | Cola 1047 17200 1189 19000 1332 21200 1018] 1780
| 16 | Orange 10020 810 1120 890 1192 1000/ 940 GA0
|17 | Caffeine Free Cola. 620 310 -163 30 -286 130 -123 70
|18 | Diet Cola 57 320 177 2000 154 2800 136 320
| 19| Strawherry 738 30| 783 -380| 900 -440 779 -400
| 20 |South Root Beer 1465 1640 1840 17000 1612 1710 1438 1330

Select File > Close to close the worksheet. You do not need to save the

worksheet.
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Selecting Members

A Essbase database may contain hundreds or even thousands of members, making
it difficult to remember each member name. You can use the Essbase Member
Selection dialog box to find and select members and to define the layout of
members in the worksheet. In addition, you can use Boolean operators, such as
AND, OR, and NOT, or other search parameters to specify criteria and conditions
that members must meet for the member selection. Member selection is an
important method of creating a spreadsheet report for the data you want to retrieve.

Note: For complete information on the Essbase Member Selection dialog box, see the
Essbase Spreadsheet Add-in online help.

» To view specific members from the Product dimension:

1. To open a new worksheet, select File > New or click the QI icon.

Note: You should be connected to the Sample Basic database. If you are not
connected, follow the steps in “Connecting to a Database” on page 45.

2. Select Essbase > Retrieve.

3. Select Product and select Essbase > Pivot to display Product as a row, rather
than a column, dimension.

Figure 72: Initial Worksheet for Member Selection

n | B [ D E F |
M arket
[Product  Jrear 105522

O B |G [P =t
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4. Select Product again, and select Esshase > Member Selection.

A Basic Essbase Tutorial

Essbase displays the Essbase Member Selection dialog box. In the Essbase
Member Selection dialog box, Essbase displays the Product dimension in the
Dimension list box and its children, Colas, Root Beer, Cream Soda, Fruit

Soda, and Diet Drinks, in the Members list box.

Figure 73: Essbase Member Selection Dialog Box

Essbase Member Selection
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' By Level Mame

) By Dpriamic: Time S enes

Bules:

Mote: Uze the right mouze button to apply
advanced selection rules.

Cancel

Help

Open...

Save...

Eresieg..

LB el

ove ltem g | Eremoye (e
e ltem Davwmn | Eremaye Al |
Output Optio:
¥ Use Aliases Default 5

I= | Suppress Shared i emtiers
¥ Place Down the Sheet
™ Irsert List Before Active Cel
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5. Select Colas and click the Member Information button.

Essbase displays the Member Information dialog box. The dialog box
provides information about the selected member, such as dimension,
generation, level, storage setting, formula, UDAs, and member comments.

Figure 74: Member Information Dialog Box

Member Information E
Member Information for - Colas:
Dimension: Product
Generatior: 2

Lewvel: 1
Storage Setting:  Mormal

Formula: ;I
<] _>l_I
Uszer Defined o
Attributes [UDA]: —I
Kl 3
Member Comment: ;I
<] _>l_I

6. To close the Member Information dialog box, click OK.

7. In the Essbase Member Selection dialog box, click Add to add Colas to the
Rules list box.

Note: Alternatively, you can double-click an item in the Members list box to add
the item.
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8. Select Cream Soda, and click the Find button.
Essbase displays the Find Member dialog box.

In the Find Member dialog box, you can do pattern-match searches for
members in the selected dimension. You can use Wildcard patterns—(trailing
asterisk, *) and (single-character match, ?). Hyperion Essbase locates the
members that match the text string (in alphabetical order) and keeps them
selected so that they can be selected as a group.

Note: You can use the trailing asterisk wildcard and single-character wildcard in
the text string. The * wildcard replaces a string of characters, whereas the ?
wildcard replaces a single character. J?n and 100* are examples of valid wildcard
strings; *-10 and J*n are examples of invalid wildcard strings.

9. In the Find Member dialog box, type D* in the text box.
Figure 75: Find Member Dialog Box

Find Member E

Enter ember Mame or Pattem in Field Below:
P

End | Fidides || Cese || Hep |

10. Click Find to locate all members that match D*.

Essbase locates and selects Diet Cream. Its parent, Cream Soda, is also
selected because it was highlighted before the search.

11. To close the Find Member dialog box, click Close.

12. Clear Cream Soda, leaving only Diet Cream selected, and click Add. Essbase
displays Colas and the new selection, Diet Cream, in the Rules list box.

13. In the Essbase Member Selection dialog box, select Colas in the Rules list
box, and then right-click. From the pop-up menu, select All Children and
Member.

Essbase displays All Children and Member next to Colas in the Selection
Rules list box.

14. In the Selection Rules list box, select Colas, All Children and Member, and
then right-click again.
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15.

16.

17.

18.

19.

20.

From the pop-up menu, select Subset.

Essbase displays the Subset Dialog box, where you can further define
conditions for the selected member.

Note: You can define a maximum of 50 conditions in the Subset Dialog box.

In the Subset Dialog box, in the first list box, select Caffeinated. In the second
list box, select Is. In the third list box select Caffeinated_True.

Click the Add as AND Condition button.

Essbase displays Caffeinated = Caffeinated_True in the Conditions list box.

When you use Add as AND Condition, the subsetting condition in the
Conditions list box is evaluated using AND logic. AND logic means that the
selection must meet the current condition and the following condition in the
Conditions list box.

Figure 76: Subset Dialog Box (Before Adding Conditions)

Subset Dialog E
Select member Colas and its children where: oK |

IEaffeinated j Iis j IEaffeinated_True j T |

Add as OR Candition | (e i a5 ANB Eandiion | Help |
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Add| add] |

Eemoye [ ] |

Remoye il [ ] |

Freview... |

In the first list box, select Ounces. In the second list box, select the logical
operator “=". In the third list box, select Ounces_12.

Click the Add as AND Condition button.
Essbase displays Ounces = Ounces_12 in the Conditions box.

In the first list box, select Ounces. In the second list box, select the logical
operator “<=". In the third list box, select Ounces_32.
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21. Click the Add as OR Condition button.
Essbase displays Ounces <= Ounces_32 in the Conditions box.

When you use the Add as OR Condition, the subsetting condition in the
Conditions list box is evaluated using OR logic. OR logic means that the
selection must meet the current condition or the following condition in the
Conditions list box.

22. In the first list box, select Pkg Type. In the second list box, select Is. In the
third list box, select Bottle.

23. Click the Add as AND Condition button.
Essbase displays Pkg Type = Bottle in the Conditions list box.

24. In the Conditions box, select Ounces <= Ounces_32, and then click the
Add ( button.

25. Select Pkg Type = Bottle, and click the Add ) button.

The Add ( and Add ) buttons add a left parenthesis and right parenthesis,
respectively, to selected items. Use parentheses for grouping multiple
subsetting conditions to determine the order of priority for analyzing the
conditions. Each item in the Conditions list box can have either the left

or right parenthesis, but not both. In this example, Essbase first evaluates
members that are equal to or less than 32 ounces and are packaged in a bottle.
Essbase then evaluates the results from this condition against members that
are 12 ounces.

Note: Use the Remove () button to remove an individual group of parentheses
from a selected item in the Conditions list box. Use the Remove All () button to
remove all parenthetical groupings from the Conditions list box.
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The Subset Dialog box is displayed as follows:

Figure 77: Subset Dialog Box (After Adding Conditions)

Subset Dialog E
Select member Colas and its children where: oK |
IF'kg Type j Iis j IBottIe j

Cancel |
AddasOR Condion | Addas AND Condition | T |
LConditions:

Caffeinated = Caffeinated_True
AND Femove [tem |
Ounces = Ounces_12
oR
[ Ounces <= Ounces_32
AND e add] |
Fkg Type = Bottle |
Bemove [ ] |
Removedl (] |

26. To open the Member Preview dialog box, click Preview.

In the Member Preview dialog box, you can view the member selection that
results from the conditions you defined.

Figure 78: Member Selection That Results from Subsetting Conditions

Member Preview E
Selected Members:

Cala
Diet Cala

Caffeine Free Cola Help |

-]

The Selected rules retumed 3 members
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27. To close the Member Preview dialog box, click Close.

28. To close the Subset dialog box and return to the Essbase Member Selection
dialog box, click OK.

The conditions you set in the Subset dialog box are displayed in the Selection
Rules list box.

29. To change the order in which Diet Cream is displayed in the worksheet, select
Diet Cream and click the Move Item Up button.

Each time you click the Move Item Up or Move Item Down button, the
selected item and its associated subset conditions move up or down one
position in the Selection Rules list box. You can move only the top-level item
(the item you added from the Members list box), not the individual subset
conditions.

Figure 79: Selecting Members Completed
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30. To preview the members that will be retrieved in the worksheet, click
Preview.

Essbase displays the Member Preview dialog box.

Essbase Spreadsheet Add-in for 1-2-3 B 113



A Basic Essbase Tutorial

31. After previewing the list, click Close.
Figure 80: Members to be Retrieved in Worksheet

Member Preview E

Selected Members:

Diet Cream
Cala

Diet Cala
Caffeine Free Cola ﬂl

-]

The Selected rules retumed 4 members

32. To close the Essbase Member Selection dialog box and insert the new
members into the worksheet, click OK.

Figure 81: Result of Selecting Members

A [ B[ ¢ D E
|1 Market

Diet Cream Year 106522
Cola

Diet Cola

Caffeine Free Cola

[gul

a1}

s

o

Note: The FlashBack command cannot undo a Member Selection action.

33. Starting with Diet Cream, type Year next to each product.

You need to do this step so that every product has a matching Year dimension
associated with it in the report.

Figure 82: Worksheet After Adding the Year Dimension to All States

A [ B[ ¢ D E
|1 Market

| 2 |Diet Cream Year 108522
| 3 |Cola Year
4 |Diet Cola Year

o

Caffeine Free Cola Year
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34. To update the values in the worksheet, select Esshbase > Retrieve.

Essbase retrieves data for the members that you selected and also applies the
styles you previously set.

Figure 83: Result After Retrieving with Member Selection

A [ B C D E
|1 Market
2 |Diet Cream Year 110321
| 3 |Cola Year 2577
| 4 |Diet Cola Year 4703
| & |Caffeine Free Cola Year 1983

Saving and Disconnecting

After performing basic retrieval, navigation, and formatting tasks, you can save
worksheets and disconnect from Essbase. This section instructs you in the
following procedures:

e “Saving a Worksheet” on page 115
e “Disconnecting from Essbase” on page 115

e “Logging Off” on page 116

Saving a Worksheet

At any point during the Essbase session, you can save the active worksheet with
the Lotus 1-2-3 commands, File > Save or File > Save As. Thus, you can keep a
personal library of database views. You can open the worksheet during a later
session and retrieve the latest data values to update the view.

Note: Saving a worksheet saves the settings from the Essbase Options dialog box
unless the worksheet is protected. Essbase cannot save option settings for a protected
worksheet.

Disconnecting from Essbase

When you finish retrieving and navigating through data, disconnect from the
Essbase server to free up a port (or user count) on the server for other Essbase
Spreadsheet Add-in users.
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» To disconnect from the server:
1. Select Essbase > Disconnect.

Essbase displays the Essbase Disconnect dialog box, where you can
disconnect any worksheet that is connected to a database.

Figure 84: Essbase Disconnect Dialog Box

Essbase Disconnect E

Sheet ServerApplication-> D atabase

—
Cloze |

Help |

2. From the list, select a worksheet name, and then click Disconnect.
3. Repeat Step 2 until you have disconnected all active sheets.

4. Click Close to close the Essbase Disconnect dialog box.

Note: You can also disconnect from the server by simply closing Lotus 1-2-3. An
abnormal termination of a Lotus 1-2-3 session, such as a power loss or system failure,
does not disconnect your server connection.

Logging Off
Essbase provides two administrative facilities that control user connections:

e Forced Logout, where an administrator disconnects users at any point in time.
This logoff usually occurs when maintenance operations are performed on
databases.

o Auto Logout, where Essbase automatically disconnects users that are inactive
for a time interval specified by an administrator.

For further information, contact the Essbase system administrator.
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Moving on to Advanced Tasks

Now that you have completed the basic Essbase tutorial, you are ready to move on
to more complex tasks. In the next chapter, you will use the sample Lotus 1-2-3
files to see how to perform advanced tasks in Essbase Spreadsheet Add-in.
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An Advanced Essbase
Tutorial

The tutorial you completed in Chapter 2 teaches basic data retrieval and navigation
concepts for Essbase Spreadsheet Add-in. This chapter builds on your basic skills
and expands your knowledge of Essbase and Essbase Spreadsheet Add-in.

This chapter provides the following sections on advanced tasks:

“Preparing to Begin the Tutorial” on page 120
“Performing Advanced Retrieval Tasks” on page 126
“Using Linked Reporting Objects” on page 173
“Connecting to Multiple Databases” on page 189
“Accessing Linked Partitions” on page 190

“Updating Data on the Server” on page 193
“Calculating a Database” on page 195

“Creating Multiple Worksheets from Data” on page 197

“Working with Currency Conversions” on page 203

In this advanced tutorial, you use several sample Lotus 1-2-3 files that were
installed as part of the default Essbase installation. These files are stored in
the \Essbase\client\sample directory. You also reconnect to the Sample
Basic database.
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Preparing to Begin the Tutorial

Before you begin the advanced tutorial, complete the steps in the next two
sections, “Connecting to a Database” on page 120 and “Setting Essbase Options”
on page 122. In addition, be sure to read “Following Guidelines During the
Tutorial” on page 43 and “Reviewing the Sample Basic Database” on page 44 for
important information about what you should expect as you perform the tutorial
steps.

Connecting to a Database

To access Essbase data for the advanced tutorial, first connect to the Sample Basic
database on the server. This tutorial assumes that you have the appropriate
privileges to connect to a server, an application, and a database.

1. Select Essbase > Connect.

Essbase displays the Essbase System Login dialog box.
Figure 85: Essbase System Login Dialog Box

Essbase System Login E

Server. ILocthost j K I
Usemame: W ﬂl
Password: l— Help |

[EhanaeFassword.. |

Application/D atabase:

[ pdate |
Tote.. |

Note: To complete the steps that follow, you need to know the name of the
Essbase server, your username, and your password. If you do not have this
information, contact the Essbase system administrator.

2. From the Server list box, select the server that you want to access. (If the
server name that you want is not shown in the list, type the name of the server
that you want to access.)
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3. To move to the Username text box, press Tab and then, in the Username text
box, type your username.

4. To move to the Password text box, press Tab, and then, in the Password text
box, type your password.

Note: You can change your password when you are connected to a server. See
“Changing a Password” on page 48.

5. To connect to the server, click OK.

Essbase displays a list of available application/database pairs in the list box.
An Essbase server enables simultaneous access to multiple applications. An
application can contain multiple databases. Only the databases to which you
have security access display in the list.

For this tutorial, you use the Sample Basic database. If the Sample Basic
database was installed as part of the Essbase installation, it is shown in the list.
If Sample Basic is not shown in the Application/Database list, ask the
Essbase system administrator to install it.

Figure 86: Available Application and Database Pairs

Essbase System Login E

Server. ILocthost j oK I
Usemame: W ﬂl
Password: lm Help |

LChange Password... |

Application/D atabase:

Demo Basic Update |

S ampeast East

S ample Intemtl Hote... |
S ample Hchgrate

S amppart Company

Sourcel Basic

Targetl Basic

6. In the Application/Database list, double-click Sample Basic, or, from the
Application/Database list select Sample Basic and then click OK.
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Setting Essbase Options

122 |

If the application is not already running, Essbase automatically starts it. There may
be a brief pause as the application loads; the time required to start an application
depends on the number of databases, the sizes of the databases, and the sizes of the
indexes of the databases that are contained within the applications.

Before you begin the tutorial, make sure that the worksheet options are set to the
initial settings shown in the Figure 87 through Figure 90.

Note: For information on each option in the Essbase Options dialog box, see the
Essbase Spreadsheet Add-in online help.

1.

Select Essbase > Options.

In the Essbase Options dialog box, select the Display tab.

Select the appropriate check boxes and option buttons so that your display

matches Figure 87.

Figure 87: Initial Settings for Display Options
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Select the Zoom tab.

Select the appropriate check boxes and option buttons so that your display
matches Figure 88.

Figure 88: Initial Settings for Zoom Options

Essbase Options
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Select the Mode tab.

Select the appropriate check boxes and option buttons so that your display
matches Figure 89.

Figure 89: Initial Settings for Mode Options

Essbase Options

8. Skip the Style tab.
9. Select the Global tab.
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10. Select the appropriate check boxes and option buttons so that your display
matches Figure 90.

Figure 90: Initial Settings for Global Options

Essbase Options E

Displayl Zoom I Mode I Style  Global |

— Display Messages
; ' Information
[¥ Enable Double-Clicking C Warmings
V¥ Enable Linked Object Browsing & Enars
' Mone
- Memony [ Display Unknown Members
[V Enable Flashback
—Log File
Member Select———————— | F Boute Messages to Log File
™ Display Save Dialog V¥ Purge Log File Every Session
—Mode
™ Mavigate withaut Data Addns. . |

QK I Cancel | Help |

11. To save the settings for this session and close the Essbase Options dialog box,
select OK.

Note: The settings in the Essbase Options dialog box may change as you access
the various sample Lotus 1-2-3 files as part of the tutorial. Leave the settings as
they are unless the tutorial advises you to change them. If you have different option
settings, the illustrations presented in this chapter may not match the worksheet
view.
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Performing Advanced Retrieval Tasks

The tutorial in Chapter 2 describes how to perform basic data retrieval and
navigation tasks in Essbase Spreadsheet Add-in. This section walks you through
performing the following advanced retrieval tasks:

“Filtering Data” on page 126

“Sorting Data” on page 134

“Retrieving Data into Asymmetric Reports” on page 137

“Working with Formatted Worksheets” on page 139

“Preserving Formulas When Retrieving Data” on page 145

“Retrieving a Range of Data” on page 149

“Retrieving Data by Using a Function” on page 152

“Retrieving Dynamic Calculation Members” on page 156

“Specifying the Latest Time Period for Dynamic Time Series” on page 159

“Using Free-Form Reporting to Retrieve Data” on page 163

Remember that you can perform common data retrieval tasks in any of the
following ways:

Selecting commands from the Essbase menu on the Lotus 1-2-3 menu bar
Clicking the appropriate buttons on the Essbase toolbar

Double-clicking the primary or the right-mouse button in the appropriate cell
(for Retrieve, Zoom In, and Zoom Out commands only, and the Linked
Objects command, if you have enabled that option).

Filtering Data

126 W

Despite the ease and speed with which you can navigate through large Hyperion
Essbase databases, it is not practical to use the capabilities of Lotus 1-2-3 to filter
and sort very large databases; however, the Essbase server includes powerful data
filtering and sorting capabilities. In Chapter 2, you learned to use Essbase Query
Designer to define a dimensional layout and to select members to view. Essbase
Query Designer also provides a powerful, yet easy-to-use tool to define
conditional retrievals.
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To become familiar with the capabilities of Hyperion Essbase Query Designer,
work with the query, Basicl, that you saved in Chapter 2, and perform the
following steps:

Note: If you skipped the tutorial in Chapter 2, follow the steps in “Creating Queries
Using Essbase Query Designer” on page 88 to create and save the Basic1 query.

1. Select Essbase > Query Designer.
Essbase displays the query information panel of Essbase Query Designer.

2. In the navigation panel, select <<c:\lotus\Work\123\Untitled.123>>A.
Right-click and select Open Query.

Essbase displays the Open Query dialog box.
From the location that you specified in Chapter 2, select the Basicl file.
Click OK.

The member selection, displayed in the properties panel, remains unaltered
from the last Essbase Query Designer session.
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From the navigation panel, select Data Filtering.

Essbase displays the data filter settings in the data filter panel. The filter
controls the number of data rows that are retrieved. The number is based on
the column criteria that you define. You can define data filtering criteria on
data values that reside in one or more columns of the view.

Figure 91: Data Filter Panel

r'} Hyperion Essbase Query Designer
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=-{£] Awailable Dimensions
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ntro Date [Base:Product]
unces [Base:Product]

lg Type [Base:Product]
Population [Base:Market]
S22 Attribute Caloulations

----- 52 Data Filkering

=] Data Sorting

----- B Messages & Confimations

Tse this data filter panel to retrieve data basedon =

the rank order that you have specified.

1. Belect the Top or Bottom check box, or both.

2. Bpecify how many rows you want to rettieve.

3. Select a dimension from the "Dimension being
ranked" drop-down list box.

4. Belect the column from the "Column used for
ranking" drop-down list box.

5. Double-click in the "Data Restrictions" box to
create additional data filters.

Mote: Follow Step 5 only if you want to define

Jud

| o~

Rank:

25 = Rows ™ Bottom |25 _I::[ Rows

Dimenszion being ranked:

I Product

Column used for ranking:
I Ot Actual

D ata Restrictions:

----- [double click to create a new data restriction)

6. The data filtering panel contains the following items:

e A check box for ranking so many of top rows or so many bottom rows of
data. You can select the highest or lowest rows. Your selection is based on
previously selected row dimension members. When using the top or
bottom criterion, you specify the number of rows, such as “top 10.” The
default is the top 25 rows.

e A Dimension being ranked list box to specify the dimension to which
ranking should be applied.
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o A Column used for ranking list box to specify the data column on which
data values are based.

e A Data Restrictions box to specify standard data comparison operations,
such as greater than, less than, and equal to. You can apply the comparison
operator to data values, including negative data values, in one or more
data columns; you can even apply criteria to compare values between two
columns.

e Buttons for OR and AND operators. If you define more than one column
criterion, you can use these operators to link the criteria.

7. Click the Top check box, and enter a value of 30 in the Rows text box.

When you apply the query, Essbase retrieves the top thirty rows of the
dimension.

8. From the Dimension list box, select Product. Product is the dimension to
which ranking should be applied.

9. From the Column list box, select Qtrl, Actual. Qtrl, Actual is the column on
which data values are based.
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10. In the navigation panel, select the Data Filtering icon. Right-click and select

Apply Query.

Your query results should look as shown below.

Figure 92: Data Filtering Query Results

A B c | b | F G | H | [0 =
1 =
| 2 |
| 4 |East Cola 2461 2580 3080 3440 2410
| 5 | Grape 645 840 860 920 800
| 6 | Cream Soda 591 770 1010 60 530
| 7 | Root Beer 562 960 1070 830 1500
| & | Strawherry 545 700 780 780 670
| 9 | Orange 290 350 380 420 440
| 10| Diet Cola 212 220 300 310 290
111 | Caffeine Free Cola 74 110 130 190 150
| 12 |West Cream Soda 2363 2620 2970 3230 2840
| 13 | Root Beer 2328 2570 2720 2820 2840
| 14 | Grape 1143 920 960 1020 920
| 15 | Cola 1047 1720 1500 2120 1780
| 16 | Orange 1002 810 890 1000 680
| 17 | Caffeine Free Cola 52 310 30 -130 70
| 18 | Diet Cola &7 320 200 260 320
| 19 | Strawherry 734 -310 -380 -440 -400
| 20 |South Root Beer 1465 1640 1700 1612 1710 1330
121 | Cola 745 1160 1280 1031 1490 1510
| 22 | Cream Soda 561 810 770 591 840 930
| 23 | Diet Cola 306 570 60 281 570 550
| 24 |Central Cream Soda 2414 2770 2930 2648 2980 2650 —
| 24 | Root Beer 2369 3310 3340 2481 3470 4130
| 26 | Grape 1080 1030 1120 1220 1150 890
| 27 | Orange 991 910 1020 1073 1010 890
24 Diet Cola 905 1130 1320 1082 1340 1180 =
[4[4]» il Sheet1  Sheetz f Sheets / |« | LIJ_J
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You can further filter your data output by specifying data comparison
operations in the Data Restrictions box.

11. In the navigation panel, select the Data Filtering icon.

The data filters that you specified are displayed in the properties panel.
12. In the Data Restrictions box, double-click.

The data restriction settings are displayed in the properties panel.
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Select the Value option and type 500 in the Value box.
Observe that the is option in the Data list box changed to =.
Click the down arrow of the Data list box and select <=.
Select Qtrl, Actual in the Column list box.

In the navigation panel, select the Data Filtering icon. Right-click, and select
Apply Query.

Notice that the query results now reflect only Actual and Budget data that are
less than or equal to 500.

In the navigation panel, select the Data Filtering icon to display the data filter
setting in the properties panel.

In the Data Restrictions box, select Qtrl, Actual <= 500, right-click and
select New Data Restriction.

In the Data box, click the down arrow and select <.

In the data values list box, select Qtr2, Actual. Under Combined With Other
Restrictions, click the Or button.

In the navigation panel, click the Data Filtering icon to access the data filter
panel.

In the Data Restrictions box, double click to create a new data restriction.
In the Data box, click the down arrow and select Is Not.
Click the button for the #Missing Value option.

This option instructs Essbase to discard data that have #Missing values.
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25. In the Column list box, select Qtrl, Actual. Under Combined With Other
Restrictions, select the And button.

The data restrictions should display as follows:

Figure 93: Data Filtering

r'} Hyperion Essbase Query Designer EHE
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-F7 100, Al Children 3. Select a dimension from the "Dimension being
""" o 200 ratked" drop-down list box
----- I:‘E| 300 4. Select the column from the "Column used for
----- BE 400, &1l Descendants ranking" drop-down list box.
] Column 5. Double-click in the "Data Restrictions" boxto
create additional data filters.
Mote: Follow Step 5 only if you want to define LI
Rark: W Top |3U _I::' Fiows | Bottom |25 _I::' Rows
o -
& .--':S‘Ee:::[tﬁal Dimenszion being ranked:
B Budget IF'roduc:t j
B Available Dimensions )
B Caffeinated (Basze:Product) Calumn used for ranking:
Intro D ate [Baze: Product] IQtr‘I L Actual j
Ounces [Baze:Product]
Pkg Type [Baze:Product] [rata Restrictions:
Fopulation (B aze:b arket) [t Actual <= 500
Attribute Calculations

OR Qtr, Actual < Q2, Actual
AND G, Actual is not #missing
[double click ta create a new data restriction)

[rata Sorting
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26. Select the Data Filtering icon, right-click, and select Apply Query.
Essbase retrieves data for all the quarters. Notice that the retrieved data for
Qtrl, Actual is less than or equal to 500 or is less than Qtr2, Actual. The results
should display as follows:
Figure 94: Data Filtering Results
A B [ ¢ [ o | E F 6 | v [ v a
- =]
2|
| 4 |East Cola 2461 2550 3050 3440 2410
| 5 | Grape B45 B840 B0 520 800
| 6 | Cream Soda 591 770 1010 BEO 530
|7 | Root Beer 562 560 1070 830 1500
|8 | Strawberry 545 700 750 780 670
Ex Qrangs 290 350 380 420 440
10 Diet Cola 212 220 300 310 290
111 | Caffeine Free Cola 74 110 130 190 150
| 12 | West Cream Soda 2363 2620 2970 3230 2850
13| Root Beer 2325 2570 2720 2620 26840
14 Grape 1143 520 560 1020 520
15| Cala 1047, 1720 1900 2120 1780
16| Qrangs 1002 810 890 1000 B0
| 17 | Caffeine Free Cola 52 310 30 -130 70
18| Diet Cola &7 320 - 200 - 250 - 320
19| Strawberry 738 -310 783 -380 800 -440 779 -400
| 20 |South Root Beer 1465 1640 1540 1700 1612 1710, 1498 1330
21 | Cala 745 1160 835 1280 108 1490 %65 1510
22| Diet Cola 308 570 363 BEO 281 570 247 550
| 23 | Central Cream Soda 2414 2770 2579 2930|2648 2980 2450 2650
E Root Beer 2389 3310 2457 3350 2481 3470 2271 4130
| 25| Grape 1050 1030 1155 1120 1220 1150 570 890
| 26 | Qrangs 591 910 1075) 10200 1073 1010) 1070 890
|27 | Diet Cola 508 1130) 1045 1320 1083 1340 883 1180
| 28| Cala 843 1080 928 1180 815 1170 793 1060
| 29| Caffeine Free Cola 457 £20 500 B10 556 B30 567 730
30 Strawberry 77 50 &7 50 130 140 205 210=
[4[4]» il Sheet1  Sheetz f sheets / |4 | LD‘
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Note: To delete all data restrictions, select the Data Filtering icon in the navigation

panel, right-click, and select Delete All Data Restrictions. Alternatively, select any data
restriction in the Data Restriction box, right-click, and select Delete All Data
Restrictions.

Note: To delete a particular data restriction, select the data restriction in the query
outline, right-click, and select Delete Data Restriction. Alternatively, select the data
restriction in the Data Restriction box, right-click, and select Delete Data Restriction.
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Sorting Data

Using the data sort panel, you can sort the output from the Basicl query in

ascending or descending order.

1. From the navigation panel, select the Data Sorting icon.

The data sorting settings are displayed in the properties panel. You can specify
data sorting criteria that affect the order in which the selected rows are
retrieved in the data sorting panel.

The data sorting panel contains the following items:

Figure 95: Data Sorting Panel

A Column used for sort list box that you use to select one or more
dimensions to be specified in column format in the query.

A Dimension being sorted list box that lists the dimensions specified in
row format in the query.

An Ordering list box that you use to apply an ascending or descending sort
order for the selected column. You can also specify sorting to occur over
a specific row dimension group. For example, you can sort by Product or
by Market.
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2. In the Column used for sort list box, double-click.

The selection defaults to Qtr1, Actual. The sort order defaults to Ascending in
the Ordering list box.

Click Ascending. A down arrow is displayed next to Ascending.
Click the down arrow. Descending is displayed below Ascending.

In the Ordering list box, select Descending.

Figure 96: Specifying Data Sorting Order

r'} Hyperion Essbase Query Designer EHE
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6. In the next row of the Column used for sort list box, double click.
The selection defaults to Qtrl, Actual.
7. Click the down arrow and select Qtrl, Budget.
Observe that the order in the Ordering list box has defaulted to Ascending.

8. In the navigation panel, under Data Sorting, select Ascending, Qtrl, Budget.
Right-click and select Delete Sorting Rule.

The Ascending, Qtrl, Budget sorting rule is deleted from the query.
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9.

In the navigation panel, select the Data Sorting icon. Right-click and select

Apply Query.

Essbase returns the results sorted in descending order for each quarter, as

shown below:

Figure 97: Result of Filtering and Sorting Data

B C D E F G H [ 1 [0
1 =
| 2 |
| 4 [Cola 2461 2580 3080 3440 2410
| 5 |Grape 645 840 860 920 800
| 6 | Cream Soda 591 770 1010 60 530
| 7 | RootBeer 562 960 1070 830 1500
| B |Strawherry 545 700 780 780 670
| 9@ |Orange 290 350 380 420 440
| 10 |Diet Cola 212 220 300 310 290
| 11 |Caffeine Free Cala 74 110 130 190 150
| 12| Cream Soda 2363 2620 2970 2937 3230 2840
| 13| RootBeer 2328 2570 2720 2540 2820 2840
| 14 |Grape 1143 920 960 1271 1020 920
| 15 |Cola 1047 1720 1500 1332 2120 1780
| 16 |Qrange 1002 810 890 1192 1000 680
| 17 |Caffeine Free Cala 52 310 30 -206 -130 70
| 18 |Diet Cola &7 320 200 -154 260 320
| 19 |Strawherry 734 -310 -380 800 -440 -400
| 20| RootBeer 1465 1640 1540 1700 1612 1710 1498 1330
| 21 |Cola 745 1160 835 1280 1031 1490 965 1510
| 22 |Diet Cola 306 570 363 60 281 570 247 550
|23| Cream Soda 2414 2770 2579 2930 2648 2980 2480 2650
| 24| RootBeer 2369 3310 2457 3340 2481 3470 2271 4130
| 25 |Grape 1080 1030 1155 1120 1220 1150 970 890
| 26 |Qrange 991 910 1075 1020 1073 1010 1070 890
| 27 |Diet Cola 908 1130 1045 1320 1082 1340 889 1180
| 26 |Cola 843 1080 928 1180 915 1170 793 1060
| 29 |Caffeine Free Cola 457 620 500 610 556 690 567 730
30 | Strawberry 77 90 87 a0 130 140 205 210/~
44> [M]'Sheet1 ¢ Sheetz f Sheets / 1Kl 1>l

Note: The values that you are ranking and sorting must be the same. For example,
you cannot specify Product in the Dimension Being Ranked box and Market in the
Dimension Being Sorted box. If you specify different values, Hyperion Essbase
Query Designer automatically changes both values to the last specified value.

10. To close the worksheet, select File > Close. You do not need to save the
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worksheet.
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Retrieving Data into Asymmetric Reports

When you retrieve data into a worksheet, the resulting report can be either
symmetric or asymmetric. Symmetric reports are characterized by repeating
identical groups of members. For example, Figure 97 shows a symmetric report
that contains Actual and Budget members nested below Year members (Qtrl,
Qtr2, Qtr3, and Qtr4).

An asymmetric report is characterized by groups of nested members that differ by
at least one member. There can be a difference in the number of members or in the
names of members.

You can create asymmetric reports in one of the following ways:
e Enter member names into the worksheet in free-form retrieval mode.

e Use adrill action with the Within Selected Group option selected from the
Essbase Options dialog box (Zoom tab).

e Suppress rows that contain missing values, zero values, or underscore
characters during data retrievals.

If you retrieve data into an asymmetric report, Essbase must perform additional
internal processing to maintain the asymmetric layout. This processing may
increase the retrieval time on large reports. For more information regarding
optimizing reports, see the Essbase Database Administrator’s Guide.

As part of the default Essbase installation, Hyperion Essbase provides a sample
file, Asymm. 123, that illustrates how to create asymmetric reports.
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» To view the sample file, Asymm. 123:
1.
2.

Select File > Open.

From the \Essbase\client\sample directory, open the Asymm. 123 file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Essbase
system administrator for more information.

Figure 98: Asymmetric Report

A B [ C D E F [ G|
L1 |Sales
2]
L3 | Acts! | Budgst! | Bvdge?! | Sudgs?
L4 ] Ol Owr2 Otr3 Otr4
L5 [East Colas G292 G760 7300 5570
L6 | Foaot Beer 5726 5650 5600 5780
L7 | Fruit Soda 3735 4150 4350 3850
8
L9 [\West RootBeer 8278 7970 8320 7820
|10 | Cream Soda | 8043 7e0 4300 7570

In Asymm. 123, row and column dimension groups are asymmetric. Thus, the
nested member groups from the Product dimension differ in member content
within respective markets. For example, Colas and Fruit Soda are included in
East but not in West. In addition, Actual data is displayed for Qtrl, whereas
Budget data is displayed for Qtr2, Qtr3, and Qtr4. Also notice that the sample
file displays styles for members of the Scenario and Year dimensions.

Leave the Asymm. 123 file open for the next tutorial task.
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Pivoting in Asymmetric Reports

When you pivot a group of members in an asymmetric report, Essbase keeps only
unique members from dimensions that are not involved in the pivot.

» To use the open Asymm. 123 file to illustrate this point:

1.

Using the right-mouse button, drag East to the cell below Qtr1.

Figure 99: Result of Pivoting in an Asymmetric Report

A [ B [c] b [JEJ] F Ja[ H J1]
L1 Sales
2]
L3 | Acts! Sudgs? Sudgs? Sudgs?
L4 ] Otrl Otr2 Otr3 Otr4
L5 | East IWest!East Wiest East West East Wiest
L6 [Colas G292 B350 G760 8800 7300 9100 5570 8430
|7 [FootBeer B7Z6 8278 BEE0 7970 5600 8320 5780 7820
L8 [FruitSoda 3735 8403 4150 5840 4350 6070 3850 5280
L9 [Cream Soda| 4868 8043 40300 7720 3850 8300 3170 7570

Essbase combines the Product members into all unique members. For
example, Root Beer, which is displayed twice in Figure 98, is displayed only
once in the current view. Colas, which is displayed in only one market in
Figure 98, now is displayed in East and West.

Essbase also removes the blank line between Product row groups. A pivot
action always eliminates any rows or columns in which all cells are empty.

Close Asymm. 123 without saving the changes.

Working with Formatted Worksheets

In addition to providing flexible, ad hoc retrievals, Essbase supports retrieving
data into formatted worksheets. A worksheet can contain the following formats:

Essbase Spreadsheet Add-in for 1-2-3

Spaces between rows and columns
Cell values that contain text or data that is not defined in the database outline
Member names in noncontiguous locations at the top of a worksheet

Lotus 1-2-3 formulas (see also “Preserving Formulas When Retrieving Data”
on page 145)

Visual cues (styles)
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After you format and save a worksheet, you may want to retrieve and navigate
through new data in the existing worksheet format. This section provides the
following information on working with formatted worksheets:

e “Observing the Rules for Working with Formatted Worksheets” on page 140
e “Retrieving Data into Formatted Worksheets” on page 141

e “Pivoting Data on Formatted Worksheets” on page 143

Observing the Rules for Working with
Formatted Worksheets

Observe the following rules when retrieving data into a formatted worksheet:

Rule 1

In the worksheet, no numeric cells can be located before the first Hyperion Essbase
data cell. For example, in Figure 100, the first Essbase data cell is B6. Neither any
cell in rows 1 through 5 nor cell A6 can contain numeric values. Also, these cells
cannot contain formulas that resolve to numeric values.

Rule 2

A cell that lies within a row or column of Essbase data cannot contain text or
numeric values. For example, in Figure 100, the cells in columns B, C, D, and F
and rows 6 through 9 and 11 through 14 cannot contain any nondata text or
numbers, for such values may be overwritten (or emptied) by the retrieved data.
These cells can contain formulas, however, if Formula Preservation options are
used. For more information on Formula Preservation options, see ‘“Preserving
Formulas When Retrieving Data” on page 145.

Tip: If you need to preserve text in a cell, define that text or value as an Lotus 1-2-3
formula, and use the Formula Preservation options.
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Rule 3

The Pivot command is not available when the Retain on Retrieval check box is
selected in the Essbase Options dialog box (Mode tab).

Rule 4

The Pivot command removes all cells that contain text other than database member
names.

Retrieving Data into Formatted Worksheets

As part of the default Essbase installation, Essbase provides a sample file,
P&1.123, that illustrates how to retrieve data into a formatted worksheet. The
P&1.123 sample file illustrates how to retrieve data into a worksheet that contains
formatted text, formulas, and protected cells.

» To view the P&1.123 worksheet:
1. Select File > Open.

2. From the \Essbase\client\sample directory, open the Ps1.123 file.

Depending on how software is installed on your machine, the file may not be
available or may be located in a different directory. Contact the Essbase
system administrator for more information.

Figure 100: A Sample Formatted Worksheet

A [ B [ € | o [ E [ F ] G [ H
L1 Market: Central The Beverage Company
L2 | Product: 200 Planning Dept.
L3 | Scenario: Budget
4
I—
6 |Misc 5 10 10 25 0.30
7 |Payroll 200 200 200 500 0.07
8 |Marketing 350 350 350 1050 12.47
9 Total Expenses 555 560 560 1675 19.89
10
11 |COGS 1170 1180 1200 3550 42.16
12 |Sales 2740 2520 2860 8420 100.00
13 targin 1570 1640 1660 4570 57.84
14 Prafit 1015 1080 1100 3195 37.95
15
16 [Ratio Analysis
17 | Markup 57.3% 558.2% 558.0% 57.8%
18 |Marketing % 12.8% 12.4% 12.2% 12.8%

3. Select Essbase > Options and select the Display tab.
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In the Cells option group, make sure that Adjust Columns is checked.
Select the Mode tab.

In the Formula Preservation group, select the Retain on Retrieval check
box to enable Formula Preservation mode.

Note: When Retain on Retrieval is enabled, there may be a slight delay in retrieval
time.

Click OK.

By default, an Essbase retrieval overwrites Lotus 1-2-3 formula with

data values in the retrieval area of a worksheet. The retrieval process also
eliminates formulas in cells outside the retrieval area. However, the Retain on
Retrieval option enables you to define retrievals that do not overwrite
formulas in any area of the worksheet.

Select Essbase > Retrieve to update the worksheet with the latest data values.

Essbase determines that some text cells in the worksheet do not correspond to
database member names. When Essbase is unable to resolve text in the
worksheet, the following message is displayed:

Figure 101: Essbase Unknown Member Message

Essbhase Message ]

The sheet contains ah unknown member: barket:.
Thiz item will be ignored when you retrieve data from the server.

There may be additional cells that contain unknown database members.
Do you want to display additional unknown members in this retrieval ?

[ % [ mo |

In this example, the first unknown member detected is Market: (in cell Al).
Essbase does not recognize the colon (:) that follows Market in the cell. If you
click Yes, Essbase displays the next unknown member; if you click No,
Essbase continues with the retrieval.

Note: If you work with formatted worksheets often, you may want to tell Essbase
not to display this message. For more information, see “Pivoting Data on Formatted
Worksheets” on page 143.
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9. Click No to close the dialog box and continue with the retrieval.

Essbase retrieves new data but retains the formatting and formulas in the
worksheet.

Figure 102: Result of Retrieving on a Formatted Worksheet

A [ B [ € | o [ E [ F ] G [ H
L1 Market: Central The Beverage Company
L2 | Product: 200 Planning Dept.
L3 | Scenario: Budget
4
]
6 |Misc Eissing  BMissing #Missing .
7 |Payroll 210 210 210 530 0.07
8 |Marketing 300 310 320 930 11.05
9 Total Expenses 510 520 530 1560 18.53
10
11 |COGS 1170 1180 1200 3550 42.16
12 |Sales 2740 2520 2860 8420 100.00
13 targin 1570 1640 1660 4570 57.84
14 Prafit 1060 1120 1130 3310 3.3
15
16 [Ratio Analysis
17 | Markup 57.3% 558.2% 558.0% 57.8%
18 |Marketing % 10.9% 11.0% 11.2% 11.0%

10. Close p&1.123 without saving it.

Note: This chapter’s section on “Preserving Formulas When Retrieving Data” on
page 145 provides additional tutorial tasks that show you how to take advantage of all
the Formula Preservation options.

Pivoting Data on Formatted Worksheets

With the Pivot command, you can produce ad hoc reports in both formatted and
unformatted worksheets. However, a formatted worksheet may contain labels and
formulas that make the result of a pivot operation ambiguous. The pivot is
designed to compress and retain only the database elements represented in the
worksheet. The worksheet also retains labels in areas that are not overwritten by
pivoted data.

Note: Essbase prevents pivot operations on worksheets that contain formulas when
Formula Preservation mode is active.

Inv.123, a sample file installed as part of the Essbase installation process,
illustrates how to pivot data in a worksheet. It was saved with the Retain on
Retrieval option disabled so that you can pivot on its worksheets.
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» To view the Inv.123 worksheet:
1. Select File > Open.
2. From the \Essbase\client\sample directory, open the Inv.123 file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Essbase
system administrator for more information.

Figure 103: Formatted Worksheet Before Pivoting

n [ B [ e [ o J E [ F | &=
1 [Market frveniany: Analvsrs
2 |Actual
3 Jan Feb Mar Gt
4
5 |[Sales 100 8314 g327 8407 25048
6 200 8716 8960 8951 26627
7 300 7874 046 8077 23997
8 400 G634 G736 G778 20148
9 Produst 31638 32069 32213 95820
10
11 Opening [nventony 100 29448 28124 28929 29448
12 " Adjusted for Audit 200 33000 32100 31125 33000
13 300 28865 28964 29095 28865
14 400 26092 26246 26409 26092
15 Produst 117408 116434 1156558 117408
16
17 [Stock to Sales 3.72 3.63 3.59
18 ===== ===== =====

Select Essbase > Options and select the Global tab.

In the Display Messages group, clear the Display Unknown Members check
box to avoid seeing the Essbase messages when working with formatted
worksheets.
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Using the right-mouse button, drag Sales (in cell AS5) to the cell nested below

Essbase pivots the Sales member group so that it is nested below the monthly
members. However, during the pivot, Essbase retains only database elements.
For example, all data for Stock to Sales and Adjusted for Audit is deleted

during the pivot.

Figure 104: Result of Pivoting on a Formatted Worksheet

6. Close Inv.123 without saving it.

f B C o | E F ] ] |
1 fmventary Analvsis M arket
2 Astual
3 Jan Feb Mar
4 Sales  [Cpening Inventory  [Rales Opening [nventorySales Cipening Inventory
5
6 100 314 20448 2327 20124 8407 28820
¥ 200 8716 33000 o460 32100 8951 3125
8 300 Tav4 28865 8046 28064 8077 20095
9 400 G634 26092 G736 26246 G778 26408
10 Product 3538 117408 32069 116434 32213 115658
11
12 " Adjusted for Audit
13
14
15
16
17 [Stock to Sales
18 —===o] —===o] —===o]

Preserving Formulas When Retrieving Data

In “Retrieving Data into Formatted Worksheets” on page 141, you used the Retain
on Retrieval option to preserve formatting and formulas in an existing worksheet.
Collectively, the Formula Preservation options enable you to retain formulas

during data retrievals, keep and remove only

operations, and drill operations. In

addition, Essbase can replicate formulas for additional members retrieved into the
worksheet as part of a drilling operation. This section steps you through using all
of the Formula Preservation options in a report that you create.
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You must enable some options before you can enable other options. Keep in mind
the following guidelines and restrictions when using the Formula Preservation
options:

On the Mode tab of the Essbase Options dialog box, you must have the
Advanced Interpretation option selected to enable Retain on Retrieval. The
Formula Preservation options do not work with free-form retrieval mode.

You must enable Retain on Retrieval to enable Retain on Keep and Remove
Only and Retain on Zooms.

You must enable Retain on Zooms to enable Formula Fill.

When you select the Retain on Retrieval check box, the Suppress #Missing
Rows and Zero Rows options on the Display tab become disabled.
Conversely, if you have either of the Display options selected, the Formula
Preservation options are automatically disabled.

When you select the Retain on Zooms check box, the Remove Unselected
Groups option on the Zoom tab is disabled. When you enable the Remove
Unrelated Groups option, Retain on Zooms is automatically disabled.

When Retain on Retrieval is enabled, there may be a slight delay in retrieval
time.

As a general rule, insert a blank row as the last row in the formula range to
ensure that the cell range in the formula expands properly when you drill down
on members with Retain on Zooms enabled. For more information, see the
Essbase Spreadsheet Add-in online help.

Formula arrays are not supported in Essbase Spreadsheet Add-in when the
preserve formula option is on. If you have formula arrays in the worksheet,
Essbase does not preserve these types of formulas.

To preserve formulas when retrieving or retaining data:

PO np

To open a new worksheet, select File > New or click the QI button.
Select Essbase > Retrieve.
In cell A2, drill down (double-click) on Year.

Press and hold the Alt key and, in cell E1, drill down (double-click) on
Scenario.
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Select cell G3 and enter the following formula in the cell: =B3/B$7*100.
Note: The $ in front of the 7 anchors the formula to the Year member.

Figure 105: Entering an Lotus 1-2-3 Formula into a Cell

A [ B [ ¢ [ ©O ] E T G |
|1 Measures Product  Market
2 Actual Budget  “ariance Variance % Scenario
| 3 o 24703 30880 -6877 -19.21844343  24703|=B3/B§7*100 |
| 4 |Gt 07 32870 -5763 -17.53270459 07
| & [Gtr3 2Nz 33980 6065 | -17.85756327 2Nz
| B |Citrd 25800 31950 45150 -19.24582629 25800
L7 | Year 1055622 129380 -235858 -18.44025352 105522

Lotus 1-2-3 calculates the formula that you entered in cell G3 and now reflects
Qtrl as a percentage of Year.

Figure 106: Result of Lotus 1-2-3 Formula with Essbase Data

A [ B [ ¢© [ b ] E [ F G |
|1 Measures Product  Market
| 2 | Actual Budget  “ariance ‘Variance % Scenario
L3 |Gt 24703 30580 6877 -19.21844343 24703
| 4 |Gtr2 2na7 32870 6763 -17.53270459 2na7
| 5 |Gtr3 27912 33580 606G | 1765756327 27912
| B |Gtrd 25800 31580 6160 -19.24852629 25800
L7 | ‘ear 108522 129380  -23858 -15.44026352 105522

Select Essbase > Options and select the Mode tab.

In the Formula Preservation area, select the check boxes for Retain on
Retrieval and Retain on Keep and Remove Only. Click OK.

In cells D2, E2, and F2, respectively, select Variance, % Variance, and
Scenario.

Essbase Spreadsheet Add-in for 1-2-3 W 147



An Advanced Essbase Tutorial

10.

11.
12.

13.

14.
15.
16.
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Select Essbase > Remove Only.

Essbase removes the selected columns but retains the Lotus 1-2-3 formula that
you entered, keeping it with the retained dataset.

Figure 107: Result of Removing Columns with Retain on Keep or
Remove Only Enabled

A [ B [T ¢ ] D [ E ]
|1 Measures Product  Market
| 2 | Actual Budget
L3 |Gt 24703 30580 23.410284111
| 4 |Gtr2 2na7 32870
| 5 |Gtr3 27912 33580
| B |Gtrd 25800 31580
L7 | ‘ear 108522 1289380

Select Essbase > Options and select the Mode tab.

In the Formula Preservation area, click the box for Retain on Zooms and

click OK.

In cell A3, drill down (double-click) on Qtrl.

Essbase drills down on Qtrl and moves the formula down with the Qtrl

member.

Figure 108: Result of Drilling Down with Retain on Zooms Enabled

A | B c_ ] D [ E ]

|1 Measures Product  Market

| 2 | Actual Budget

| 3 [Jan 8024 9940

| 4 |Feb 5346 10350

| & |Mar 5333 10290

L6 aGir 24703 30580 23.410284111
|7 | Gt2 2na7 32870

|8 | Gt3 27912 33580

|9 | Ctrd 25800 31580

|10 Year| 108522 129380

Select Essbase > FlashBack.

Select Essbase > Options and select the Mode tab.

In the Formula Preservation area, select the Formula Fill check box.

Click OK.
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17. In cell A3, drill down (double-click) on Qtrl.

Essbase drills down on Qtrl and replicates the formula for each member of
Qtrl (Jan, Feb, and Mar). To view the replicated formulas, click in cells D3,
D4, D5, and D6 and look at the new syntax in the Lotus 1-2-3 formula bar.

Figure 109: Result of Drilling Down with Formula Fill Enabled

A [ B [ ¢ ] D [ E ]
|1 Measures Product  Market
| 2 | Actual Budget
| 3 [Jan 8024 9940 7.604101514
| 4 |Feb 5346 10350 7.909251141
| & |Mar 5333 10290 7.896931446
|6 | Gt 24703 30580 23.41028411
|7 | Gt2 2na7 32870
|8 | Gt3 27912 33580
|9 | Gtrd 25800 31580
|10} Year| 108522 129380

18. Before moving on with the tutorial, complete each of the following actions:

Select Essbase > Options and select the Mode tab.

T 9

Clear all of the Formula Preservation options.

c. Select File > Close to close the worksheet. You do not need to save the
worksheet.

Retrieving a Range of Data

In a typical Lotus 1-2-3 worksheet, you can select a range of cells by dragging the
mouse across the worksheet. You can also select a range of cells and tell Essbase
to restrict the data retrieval to the selected range in the worksheet. Retrieving a
range of data is particularly useful in the following situations:

e A worksheet contains multiple reports.

e A worksheet contains extraneous information that is not supported in a
formatted report retrieval.

e You need to retrieve only a small subset of values from the server, thus
dramatically decreasing retrieval time for large datasets.

e You need to retrieve data to an area of the worksheet other than the first
column.

As part of the default Essbase installation, Essbase provides a sample file,
Profit.123, that illustrates how to retrieve a range of data.
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» To view the Profit.123 file:

1. Select File > Open.

2. From the \Essbase\client\sample directory, open the Profit.123 file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Essbase
system administrator for more information.

Profit.123 has already selected a range of cells (B2 through F9) for you.

Figure 110: Selected Range of Cells for Retrieval

Actual

iy O By

Citr3

Central
Citrl Citr2
100-10 220 220
100-20 220 220
|16 | 100-30 220 220

2z2.0
2z2.0
220

Profit %2

Citr4 Year
220 220
220 220
220 220

3. Select Essbase > Retrieve to update the selected range.

Figure 111: Result of Retrieving First Range of Data

Actual

iy O By

Essbase updates only the data in the selected range of cells.

Central
Citrl Citr2
100-10 220 220
100-20 220 220
|16 | 100-30 220 220

Citr3

2z2.0
2z2.0
220

Profit %2

Citr4 Year
220 220
220 220
220 220

Essbase Spreadsheet Add-in for 1-2-3




An Advanced Essbase Tutorial

4. Select cells B12 through G16.

Figure 112: Selecting Cells for Retrieval

iy O By

—
o

A [ B [ ©€ | D [ E F

100 Central

Actual Budget

Sales Frofit%  Sales Profit %2
Ot 8074 27.3 s2o0 345
Otr2 8701 28.4 3870 351
Otr3 5894 28.8 3060 353
Otrd 8139 276 7800 381

Year 33808 28.1 33430 357

iy O By

—
o

A [ B [ ©€ | D [ E F

100 Central

Actual Budget

Sales Frofit%  Sales Profit %2
Ot 8074 27.3 s2o0 345
Otr2 8701 28.4 3870 351
Otr3 5894 28.8 3060 353
Otrd 8139 276 7800 381

Year 33808 28.1 33430 357

6. Close profit.123 without saving it.
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Retrieving Data by Using a Function

The Essbase cell retrieve function, EssCell, retrieves a single database value into
a worksheet cell. Enter an EssCell function directly into a worksheet or select an
EssCell function from the Lotus 1-2-3 menu bar.

Note: You must be connected to a database to use EssCell.

EssCell retrieves data when you perform an Essbase retrieval or when you
recalculate a worksheet through Lotus 1-2-3. As part of the default Essbase
installation, Hyperion Essbase provides a sample file, Summary . 123. This file has
EssCell functions already set in cells B16 and B17.

» To view the Summary. 123 file:

1. Select File > Open.

2. From the \Essbase\client\sample directory, open the Summary.123
file.

Depending on how software is installed on your PC, the file may not be
available or may be located in a different directory. Contact the Essbase
system administrator for more information.

Figure 114: Worksheet Containing EssCell Functions

152 W

A A B 1T ¢ [ b [T E [ F [ G |
1 200

2 |Texas

3

4 Budget

] Cirl Otz 3 Citrd ear

B |Sales 1130 1260 1440 1200 5030

7 |COGS 450 500 570 490 2010

a Margin 680 760 870 10 3020

9 |Marketing 270 300 360 2490 1220

10 |Payroll 120 120 120 100 460

11 |Misc #hdissing  #Missing  #Missing  #hissing  #Missing

12 Total Expenses 340 420 480 340 1680

13 Profit 2490 340 3490 320 1340

14

15

16 “ear Sales

17 “ear hargin ¥

18

18 N ETBIR@ESSCELL{"Sales" 200" A2, "Budget", "Yaar' "NULL" "NULL", "
20 {LET B17.(2ESSCELL{"Margin 3" "200",A2 "Budget","rear,"WULL" "MUILL

Cells B19 and B20 in Summary . 123 contain the EssCell function, which
will display the results of the function in cells B16 and B17, respectively.
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The EssCell function is defined in a cell as follows:

{LET cellref,@EssCell (mbrList)}

where cellrefis a reference that points to the cell where Hyperion Essbase
should return the database value.

mbrList is one of the following:

e A null value. If the parameters of the function are empty, Essbase returns
the data value from the top of each dimension.

e A comma-delimited list of member names. Member names must be
enclosed in double quotes, with only one member per dimension allowed.
If you list no members from a particular dimension, the function returns
the data value from the top member of the unspecified dimension.
Furthermore, you can include aliases in the member list, subject to the
same rules as member names.

o A Lotus 1-2-3 cell reference. The reference must point to a cell that
contains a valid member name. Member names, such as 200 and 300-10,
need to be formatted as text cells, rather than numeric cells.

For example, the syntax for the EssCell function in cell B19 in the
Summary . 123 file is the following:

{LET B16,@ESSCELL("Sales", "200", "A2", "Budget",
"Year", "NULL", "NULL", "NULL", "NULL", "NULL", "NULL", "NULL",
"NULL" , "NULL" , "NULL" ) }

When you open the worksheet, the values in these cells are #N/A. To update
the values with the data in your database, you must run the macro function.
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3. Select cell B19, then select Edit > Scripts & Macros > Run. In the Run
Scripts & Macros dialog box, select the Macro option, then click Run.

Figure 115: Run Scripts & Macros dialog box

Run Scripts & Macros E
" Script * Macro Eun

__________ 5o |

EI Cancel |

Help |

4. Essbase calculates the EssCell functions in cells B16 and B17.

Figure 116: Retrieval on a Worksheet Containing the EssCell Function

A [ B [ ¢ | b [ E [ F ]
1 200 !
| 2 |Texas
3]
L4 ] Budget
L5 | Oitrl Otrz Otr3 Oitrd “rear
L6 [Sales 1460 1560 1630 1320 5970
L7 [COGS 560 540 630 500 2280
L8 [ Margin Ja0 370 1000 gz20 36490
L9 [Marketing 160 160 170 120 610
|10 [Fayroll 1] 1] 1] 110 240
11 |Misc #issing  #Missing #Missing #Missing #Missing
|12 | Tatal Expenses 220 220 230 230 Bl
13 | Profit Ga0 750 770 540 2740
4]
15 ]
|16 | rear Zales 5870
1 Year Margin % £1.81

Now update the EssCell functions to retrieve data for a different state.

154 W
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Change the contents of cell A2 from Texas to Florida.

Select cell B19, then select Edit > Scripts & Macros > Run. In the Run
Scripts & Macros dialog box, select the Macro option, then click Run.

Hyperion Essbase recalculates the EssCell functions in cells B16 and B17.

Figure 117: Updating the EssCell Function

A [ B [ ¢ | b [ E [ F ]
1 |200
2 [Florida I
3]
L4 ] Budget
L5 | Oitrl Otrz Otr3 Oitrd “rear
|6 |Sales 1460 1560 1630 1320 5470
L7 |COGS 56D 540 B30 500 2280
L8 | Margin a00 970 1000 G20 3640
L9 |Marketing 160 160 170 120 610
|10 |Payrall 60 60 60 110 240
11 |Misc #issing  #Missing #Missing #Missing #Missing
|12 | Tatal Expenses 220 220 230 230 Bl
13 | Prafit BE0 750 770 540 2740
4]
15 ]
|16 | rear Zales 5030
|17 |  ‘vearMargin 3 E0.04

Tip: If the worksheet contains many EssCell functions, change Lotus 1-2-3 to
manual calculation mode. This change prevents the cell retrieve from calculating
until you retrieve data or calculate the worksheet manually. For more information,
see the Lotus 1-2-3 documentation.

Essbase returns an error message if EssCell is unsuccessful. The following
table lists messages that Essbase displays in the EssCell cell and explains the
conditions that cause the messages:

Message Reason

#N/A The worksheet is not connected to a database.

#VALUE! A member name in the list or reference is invalid.

#NAME? A text name in the function does not contain double
quotation marks.

6. Close Summary.123 without saving it.
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The sample file that you used for this tutorial task already had EssCell functions
defined.

Note: Tasks that you should not perform as part of the tutorial are shown in
light-shaded boxes.

» To enter your own EssCell function into a worksheet, you do the following:

Enter the EssCell syntax in the 1-2-3 formula bar at the top of the sheet.

Note: For more information on EssCell functions, see the Essbase Spreadsheet
Add-in online help.

Retrieving Dynamic Calculation Members

156 W

Dynamic calculation members are database members that are excluded from the
batch calculation process, thus shortening the regular database calculation time.
The Essbase application designer tags dynamic calculation members in the
database outline so that Essbase knows not to calculate those members until a data
retrieval requests them. This process is referred to as dynamic calculation.
Dynamically calculating database members benefits the Essbase server in the
following ways:

e Reduced disk usage

e Reduced database restructuring time

e Reduced time to back up the database

Database values that Essbase calculates dynamically take slightly longer to
retrieve in Essbase Spreadsheet Add-in because Essbase must perform
calculations before retrieving data into the worksheet. For more information on
dynamic calculation, see the Essbase Database Administrator’s Guide.

Tip: Enable the Navigate Without Data feature while you arrange the spreadsheet
report so that Essbase does not dynamically calculate the database when you are
creating the report. For more information on the Navigate Without Data feature, see
“Navigating Through the Worksheet Without Retrieving Data” on page 66.
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Because there may be a performance impact on retrieving data for dynamic
calculation members, define visual cues, or styles, for these members so that you
can identify them in Essbase Spreadsheet Add-in.

To illustrate how to use Dynamic Calculation members, use the Asymm. 123 file.

» To view the Asymm. 123 file:
1. Select File > Open.
2. From the\Essbase\client\sample directory, open the Asymm. 123 file.
3. Dirill up on Actual by double-clicking the right-mouse button in cell C3.
4. In cell C3, drill down on Scenario to display all members of Scenario.

Essbase displays only the Scenario members for Qtr1.

Figure 118: Displaying Scenario Members

A B [ ¢ [T b | E ] F [ & |
L1 Sales
2]
L3 | |,4mw' _l Budget | Vanance | Yanance & | Soanaia
L4 ] Ol Ot Otrl Otrl Otrl
L5 |East Calas 6292 5870 422 7.188087104 6292
L6 | Fioot Beer 5726 5460 266 4.871794872 5726
L7 | Fruit Soda 3735 3860 -145| -3.737113402 3735

8

L9 |west RoaotBeer 8278 7700 578 7.506493506 8278
|10 | Cream Soda | 6043 BEA0 11683 16.73434768 8043

5. Select Essbase > Options and select the Style tab.

Note: You must be connected to the Sample Basic database to display the Style
tab. For more information on connecting to a database, see “Connecting to a
Database” on page 120.

In the Members group, scroll down until you see Dynamic Calculations.

Select the Dynamic Calculations check box and click the Format button.

© N o

In the Font style list, select Bold Italic.

9. In the Color list, select Gray.

10. Click OK and then select the Display tab.

11. In the Cells option group, click Use Styles. Click OK.
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12. Select Essbase > Retrieve.

Essbase displays the data and applies all the visual cues, or styles, that you set,
including the newly set styles for dynamic calculation members and the styles
you set in Chapter 2. You can tell that the columns for Variance and
Variance% are dynamically calculated because Hyperion Essbase displays
these members in gray, bold, italicized font. (Variance and Variance% also
have a red background because that style was previously set for all members
of the Scenario dimension.)

Figure 119: Result of Retrieving Dynamic Calculation Members

A B [ c ] D H F I
L1
|2
| 3 | | Varance | Yarnance % ||
| 4 Ol Qtrl Ol Otrl Otrl
| 5 |East [Colas £292  BA70 422/ 7183087104 6292
| 6 | Root Beer 5726 54E0 266 4871734872 5726
| 7| Fruit Soda 3735 3880 -145)  -3737113402 37385
]
| 8 |west Root Beer g27a 7700 578 7506493506 g278
| 10 Cream Soda 8043 5390 1183 16.73439768 043

Note: Occasionally, other styles you have set may override a style for dynamic
calculation members. For example, if a parent member is also a dynamic
calculation member, and if you have styles set for both parent and dynamic
calculations, the style for the parent member overrides the style for the dynamic
calculation member. In this case, you need to remove the style for parent members
in order to see the style for dynamic calculation members. For more information on
the precedence of styles, see “Determining the Precedence of Overlapping Styles”
on page 81.

13. Close the Asymm. 123 file without saving it.
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Specifying the Latest Time Period for
Dynamic Time Series

Dynamic Time Series members are predefined database members that are used in
dynamic, to-date reporting, such as year-to-date or month-to-date values. Dynamic
Time Series members do not display as individual members in the database
outline; instead, they correspond to a generation name that uses a key term for
time, such as year, month, or day.

For example, in the Sample Basic database, a generation name called Quarter was
created for generation 2 in the Year dimension. Generation 2 includes the members
for Qtrl, Qtr2, Qtr3, and Qtr4. When the generation name Quarter was created,

Essbase created a Dynamic Time Series member called Q-T-D, or quarter-to-date.

To take advantage of Dynamic Time Series in Essbase Spreadsheet Add-in,
choose the latest time period for which you want data in a to-date calculation. The
calculated value of the Dynamic Time Series member is derived when you define
the latest time period to be reported. In the Sample Basic database, for example,
the level 0 members of the Year dimension are the months of the year: Jan, Feb,
Mar, and so on. If the current month is August, and you want to know the sales data
for the quarter up to the current month, a quarter-to-date calculation gives you the
sales data for the months of July and August.

» To illustrate the concept of Dynamic Time Series:

To open a new worksheet, select File > New or click the Ql button.
Select Essbase > Options and select the Zoom tab.

In the Zoom In option group, select Next Level.

Clear the Within Selected Group check box and click OK.

Select Essbase > Retrieve.

In cell B1, drill down (double-click) on Measures.

In cell B2, click Year.

N o a ko b=
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8. Type 0-T-Din cell B2 and press Enter to enter a predefined Dynamic Time
Series member (Q-T-D):

Figure 120: Entering a Dynamic Time Series Member into a Worksheet

[ A [ B ] C e E
Product Market

1
2 Q.T.0 105522
E Year 117405
4 Year 5526162527
5 Year 105522
B
7

Note: For alist of other possible Dynamic Time Series members, see the Essbase
Spreadsheet Add-in online help.

9. Select Essbase > Options and select the Display tab.
10. In the Dynamic Time Series area, select the Latest Time Period check box.
11. From the list box, select May. Click OK.

Figure 121: Specifying Latest Time Period in a Dynamic Time Series

Essbase Options E

Display |Zoom I tode I Style I Globall

Indentation—————— ~ Feplacement
" Mone #higzing Label: I
' Subitems
& Totak #Mo Access Label: l—
— Suppre — Aliaze:
™ #Missing Fows V' Use Aliases
™ Zemo Rows ™ Use Both Member Names and Aliases
™ Underscore Characters far Row Dimensions
= Alias:
™ Use Styles IDefauIt j
V' Adiust Columng
= Aute Sort Homs Query Designer
" Bepeat Member Labels ’7|_ Use Sheet Options with Query Designer

— Dynamic Time Serie

[+ Latest Time Period IMH

QK I Cancel | Help |

Note: If you do not specify a latest time period, Essbase uses the first level 0
member (Jan) as the default.

Essbase Spreadsheet Add-in for 1-2-3



An Advanced Essbase Tutorial

12. Select Essbase > Retrieve.

Note: The Retrieve & Lock, Zoom In, and Zoom Out commands are not supported
with Dynamic Time Series members.

Essbase displays data for the Q-T-D member. The data values in the
worksheet are the aggregated values for April and May, because May is the
month you specified as the latest month in the quarter-to-date Dynamic Time
Series.

Figure 122: Result of Specifying Latest Time Period in a
Dynamic Time Series

[ A B ] C e E
Product Market

1

2 Q-T-D 17573
E Year 117405
4 Year 5526162527
5] Year 105522

13. To close the worksheet, select File > Close. You do not need to save the
worksheet.

Note: You can also create a report like the one shown above by simply typing the name
of the Dynamic Time Series member followed by the name of latest time period in
parentheses: for example, Q-T-D (May). If you are using free-form retrieval mode, you
must enter the Dynamic Time Series member and the latest time period in separate,
adjacent cells. You can also select a Dynamic Time Series member and a latest time
period through Hyperion Essbase Query Designer or through Member Selection.

Note: For more information on Dynamic Time Series, see the Essbase Spreadsheet
Add-in online help.

Using Substitution Variables

The Essbase application designer uses substitution variables to define global
variables to represent values that are specific to Essbase. For example, Latest can
be a substitution variable representing the latest time period in a Dynamic Time
Series. Using Essbase Application Manager, the application designer sets
substitution variables and their corresponding values for a specific application.
Essbase stores these variables and their values on the Essbase server. You can take
advantage of the predefined substitution variables in Essbase Spreadsheet Add-in
during Dynamic Time Series reporting.
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For example, say the application designer sets a substitution variable on the server
for the current month. The variable is called CurMnth and has a value of August.
If you use the substitution variable in the worksheet, a retrieval returns values for
August, because August is set as the current month on the server. If, at a later date,
the application designer changes the value of the CurMnth substitution variable to
October, a retrieval returns data for October.

The Sample Basic database you are using for this tutorial does not contain
predefined substitution variables. If the application designer had set a substitution
variable in the database you are using, you could enter a substitution variable
directly into a worksheet. For example, you could open a blank worksheet and type
member names as follows:

Figure 123: Entering a Substitution Variable in a Worksheet

A [ B[] € [DJ] E ]
Product Measures Market Scenario

&Curtnth

Note: Notice the substitution variable (CurMnth) in cell A2. When you enter a
substitution variable directly into a cell, you must precede it with an ampersand (&).

In this example, a retrieval produces the following results:

Figure 124: Result of Retrieval on a Substitution Variable

Al B | € [ bpb[] E [ F |
L1 Praduct Measures Market Scenario
2 |Aug 9545

(=%

s

Essbase queries the server for the value of the substitution variable CurMnth,
which is August. Data is returned only for August.

Note: If you save a worksheet containing a substitution variable as a template, make
sure that you save the worksheet before you retrieve data. For example, if you save the
worksheet shown in Figure 124 as a template, each time you retrieve the template,
August rather than the substitution variable CurMnth is displayed.
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Using Free-Form Reporting to Retrieve Data

So far, you have learned how to retrieve Essbase data into a worksheet through ad
hoc retrieval, Hyperion Essbase Query Designer queries, and Member Selection
operations. In addition to these retrieval methods, Essbase supports free-form
reporting. Free-form reporting enables you to tell Essbase specifically what you
want to retrieve by simply typing data into the worksheet. Free-form reporting is
especially useful when you are familiar with the dimensions and members in the
database outline.

Essbase provides two different retrieval modes for free-form reporting:
e Advanced Interpretation

e Free-Form

In both retrieval modes, enter member names directly into the worksheet. The
following sections describe the similarities and differences between the two
modes.

Using Advanced Interpretation Mode

The Essbase server contains an advanced spreadsheet interpretation engine that
scans a worksheet and interprets its content when fulfilling retrieval requests.
When you construct a report by entering names directly into a worksheet in
Advanced Interpretation retrieval mode, Essbase interprets the member names and
creates a default view that is based on the location of the labels.

Keep in mind the following guidelines when you are working in Advanced
Interpretation mode:

e Precede all member names that consist of numbers with a single quotation
mark. For example, for Product dimension member 100, type '100 in the
worksheet.

e If you define a report that does not contain all of the database dimensions, you
may need to enter a dummy value, such as 0, in the first data cell. Essbase
overwrites this value with the contents of the database cell upon retrieval. Be
sure to use a numeric value as the dummy value.

Essbase Spreadsheet Add-in for 1-2-3 B 163



An Advanced Essbase Tutorial

» To construct a free-form report in Advanced Interpretation retrieval mode:

1. To open a new worksheet, select File > New or click the QI button.
2. Select Essbase > Options and select the Mode tab.

3. In the Retrieval option group, select Advanced Interpretation (the default
setting) and click OK.

4. Enter member names and data as in the following illustration.

Note: If amember name consists of a number, such as 100, you must precede the
member name with a single quotation mark (for example, '100). This rule also
applies to member names with spaces between words.

Figure 125: Creating a New Free-Form Report

A [ B [ ¢ [ b [ E [ F ]
Sales East Budget

Qtr1 Qtr2
100
200
300
400

5. Select Essbase > Retrieve or double-click in a data cell.

Essbase retrieves data for the members you entered into the free-form report
and implements the Use Aliases option that you set in the Essbase Options
dialog box in the beginning of this chapter.

Figure 126: Retrieving Data into a Free-Form Report

A [ B T ¢ T o [ E [ F |

L1 [Sales East  Budget

2]

3 | Gtrl G2

L4 [Colas 5870 6760

| 5 |Root Beer Sde0 AmA0

|6 [Cream Soda 3630 4030

L7 _|Fruit Soda 3880 4140
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a free-form report that does not contain all of the dimensions from the

database. In Advanced Interpretation mode, you may need to enter a dummy data

value, such

as 0, into the first Essbase data cell to tell Essbase where the data starts

in the worksheet. Be sure to use a numeric value as the dummy value.

For example:

1.
2.
3.

Figure

Select Essbase > FlashBack.
Delete cells Al, B1, and C1.

In cell B4, type 0 in cell B4 to provide Essbase with a data cell reference point.

127: Defining a Free-Form Report Without All Dimensions

c [ o [ E [ F ]

100
200
300
400

Otrl Q2
0

Select Essbase > Retrieve.

Essbase adds the dimensions that were omitted from the free-form report to
the worksheet and retrieves data.

Figure

128: Retrieval in a Free-Form Report Without all Dimensions

A [ B [ c [ o [ETJF |

Colas
Root

worksh
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Cream Soda
Fruit Soda

Measures Market  Scenario
Qtr1 Qtr2

7048 a2

6721 7030

5929 G769

5005 5436

Beer

Select File > Close to close the worksheet. You do not need to save the

eet.
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Using Free-Form Mode

Similar to Advanced Interpretation mode, Free-Form mode enables you to

enter member names into any location in a worksheet and then interprets the
contents of the worksheet when fulfilling the retrieval request. In addition, with
Free-Form mode, you can use Essbase report script commands to retrieve data into
a worksheet.

Report script commands are most useful for defining member references that can
bring back the most current member information dynamically. For example, if you
need to create a report that shows every product, including the products added
since the last retrieval, standard retrieval mode reflects changes only when you
zoom in on the product. If you use the report script command <IDESCENDANTS,
Essbase retrieves all descendants of a specified member, including the specified
member. For more information on the syntax of report script commands and on
guidelines for developing reports, see the Technical Reference in the docs
directory and the Essbase Database Administrator’s Guide.

Keep in mind the following guidelines when working in Free-Form retrieval
mode:

e You must precede all member names that consist of numbers with a single
quotation mark. For example, for the Product dimension member 100, you
need to type '100 in the worksheet.

e You cannot cancel a retrieve in Free-Form mode.
e You cannot apply Essbase styles in Free-Form mode.
e Essbase removes blank rows and columns on any retrieval action.

e When you are in Free-Form mode, an Auto Sort Rows option is enabled in the
Display tab of the Essbase Options dialog box. If you select this feature,
Essbase retrieves data in symmetric rows. The rows are sorted according to the
order specified in the database outline.

e Notall Formula Preservation and Modes options (Essbase Options dialog box,
Mode tab) are available in Free-Form mode.

e To use Dynamic Time Series in Free-Form mode, do not put the Dynamic
Time Series member and the latest time period (for example, Q-T-D (Feb)) in
the same cell. You need to type the Dynamic Time Series member, Q-T-D in
one cell, and the latest time period within parentheses, (Feb), in a separate,
adjacent cell.
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» To construct a free-form report in Free-Form retrieval mode:

I

Essbase Spreadsheet Add-in for 1-2-3

To open a new worksheet, select File > New or click the QI button.
Select Essbase > Options and select the Mode tab.

In the Retrieval option group, select Free Form.

Select the Display tab.

In the Cells option group, select Auto Sort Rows. Click OK.

Enter the member names into the worksheet as shown in Figure 129:

Figure 129: Typing Member Names In a Free-Form Report

A [ B T ¢ T o [ E [ F |
L1 [Product COGS
L2 [Jan
|3 |East
| 4 [Budget
5 |Actual
6 |
L7 |

Select Essbase > Retrieve.

Essbase retrieves data for the members and creates a default view according
to the location of the labels. Note that three members were pivoted from row
groups to column groups.

Figure 130: Result of Retrieving in Free-Form Retrieval Mode

A [ B[ c [ p [ E [ F |
Product COGS  Jan East
Budget 25001
Actual 3007

Select File > Close to close the worksheet. You do not need to save the
worksheet.
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Now create a report by entering member names and a report script command:

To open a new worksheet, select File > New or click the QI button.

Enter the member names into the blank worksheet as shown in Figure 131.

Figure 131: Typing Member Names in a Free-Form Report

Al B [CID[E] F |
L1 Actual  Sales East

L2 | Jan Feh IMar_l
3

In cell A3, type <IDESCENDANTS Product. Press Enter.

Figure 132: Typing a Report Script Command in a Free-Form Report

A [ B | ¢ T D |
|1 Actual Sales East
| 2 | Jan Feh tlar
| 3 |<IDESCENDANTS I _|
4

Select Essbase > Retrieve.

Essbase retrieves data into the worksheet for all descendants of Product and
for the members you entered in the worksheet.

Figure 133: Result of a Retrieve with a Report Script Command

A [ B [ € | o [ E ]

L1 Actual  Sales  East

L2 | Jan Feh tlar

L3 [Cola 1512 1754 1805
|4 [Diet Cola I 2DD_| 206 214
| 9 |Caffeine Free Cala 93 10 107
L6 | Colas 21048 2061 2126
|7 |Qld Fashioned 647 &lais) 672
| 8 |Diet Root Beer 310 310 312
L9 [Sasparilla #issing #lissing #issing
|10 |Birch Beer 896 985 923
11| Root Beer 1853 15966 1807
|12 |Dark Cream 959 12 1026

Note: When Essbase completes the retrieval, the report script command is
overwritten by the data it returns. You can use FlashBack to restore the previous
view in Free-Form mode.

Select File > Close to close the worksheet. You do not need to save the
worksheet.
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Using Attributes in Free-Form Reporting

Essbase enables you to retrieve data selectively by specifying attributes that are
associated with a base dimension. For example, in the Sample Basic database, the
Product base dimension is associated with attributes such as packaging and size.
You can enter an attribute name into the worksheet to retrieve data that is
associated with that attribute.

» To use attributes in a free-form report:
1. To open a new worksheet, select File > New or click the QI button.

2. Enter member names as shown in the Figure 134.

Caffeinated is an attribute dimension associated with the Product base
dimension. Bottle is a level 0 member of the Pkg_Type attribute dimension.
The Pkg_Type dimension is associated with the Product base dimension. A
level 0 member is the lowest level member in a dimension.

Figure 134: Using Attributes in Free-Form Reports

A [ B [ ¢ [ b [ E |
| 1 |Caffeinated Bottle Prafit Qtrl East
2

3. Click in any empty cell and select Essbase > Retrieve or double-click in an
empty data cell.

Essbase retrieves information on profits for the first quarter of the year for all
members of the Product base dimension that are associated with both the level
0 attribute members of the Caffeinated attribute dimension (Caffeinated_True
and Caffeinated_False) and the level 0 member Bottle of the Pkg_Type
attribute dimension. The results should display as shown below:

Figure 135: Result of Using Attributes in Free-Form Reports

A [ B [c [ D J[ETJEF]
Caffeinated Bottle | Profit  Qtr1 East
Scenatio 2604
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4. You can drill down to data on the level 0 attribute members of the Caffeinated
attribute dimension. The results should display as shown below:

Figure 136: Drilling Down on Attributes in Free-Form Reports

A [ B [T c Db JETJF]
Bottle Profit  Qtr1 |East
Caffeinated_True Scenario 142
Caffeinated_False Scenario 2462

5. To drill down further for data on profits for the first quarter for all members of
the East base dimension, double-click on cell E1. The results should display
as shown below:

Figure 137: Result of Drilling Down on East

A [ B e[ o [EJ F ]
1] 1 Bottle Profit | Scenario
| 2 |Mew Yark Caffeinated_True Year -2050
=N Caffeinated_False Year EB754
| 4 | Caffeinated  “ear 4704
| & |Massachusetts Caffeinated_True “ear 30
| 6 | Caffeinated_False Year 1577
| 7| Caffeinated  “ear 1607
| 8 |Flarida Caffeinated_True Year 1727
| 9 | Caffeinated_False Year 934
| 10| Caffeinated  “ear 26G1
| 11 |Connecticut Caffeinated_True  Year 1134
| 12 | Caffeinated_False Year 742
| 13 | Caffeinated  “ear 1878
| 14 |Mew Hampshire Caffeinated_True Year -84
| 15 | Caffeinated_False Year 842
| 16 | Caffeinated  “ear 743
| 17| East Caffeinated_True Year 757
| 18 | Caffeinated_False Year 10349
1 Caffeinated  |Year 116086

Entering Generation and Level Names

In addition to entering database member names into a free-form report, you can
enter generation or level names directly into a worksheet to retrieve specific
members. The Essbase application designer defines generation and level names for
database dimensions in the database outline. You have two options for discovering
what generation and level names are defined in the database:

e View generation and level names in the Essbase Member Selection dialog box
or through Essbase Query Designer.

e Contact the Essbase application designer to see what generation and level
names are defined in the database outline.
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» To enter generation and level names directly into a free-form report:

A O np

To open a new worksheet, select File > New or click the QI button.
Select Essbase > Options and select the Mode tab.
In the Retrieval option group, select Advanced Interpretation. Click OK.

Enter member names as shown in Figure 138:

Figure 138: Entering Member Names in a Free-Form Report

A [ BJ] c[] o [ E [ F ]
Sales | Budget West Year

Enter a generation name as shown in Figure 139:

Family is a generation name in the Product dimension. The name is already
defined in the Sample Basic database.

Figure 139: Entering a Generation Name in a Free-Form Report

A [ BJ] c[] o [ E [ F ]
Sales | Budget West Year

Farnily

|-h- (=% I\J|_‘.

Select Essbase > Retrieve.

Essbase retrieves data for the member and generation names that you entered.
The Family generation name expands to its individual members.

Figure 140: Result of Free-Form Retrieval with Generation Name

Essbase Spreadsheet Add-in for 1-2-3

A [ B [ ¢ | o [ E T F ]

L1 Sales Budget  West ‘fear

L2 [Colas 34830

| 3 |Root Beer 3810

L4 [Cream Soda 30430

|9 |Fruit Soda 24730

|6 |Diet Drinks 35690

7
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7. Change Year to a level name (LevO0, Year) as shown in the following

illustration.

Figure 141: Entering a Level Name in a Free-Form Report

172 1

A [ B [ ¢ [ o | E [ F |

1] Sales Budget West  [Levd Year]

L2 [Colas 34830

| 3 |Root Beer 3810

L4 [Cream Soda 30430

|9 |Fruit Soda 24730

|6 |Diet Drinks 35690

7

Note: Be sure not to insert a space between the comma after 0 and the word Year.
Generation and level names that are entered directly into a worksheet must be
precise.

Select Essbase > Retrieve.

Essbase retrieves data for the level 0 members of the Year dimension, which
are the individual months (Jan, Feb, Mar, and so forth).

Figure 142: Result of Free-Form Retrieval with Level Name

A | B [ C [ E [ F ]
L1 Sales Wyest
L2 [Jan Calas 2860
L3 | Foat Beer 2540
L4 | Cream Soda 2220
L9 | Fruit Soda 1340
L6 | Diet Drinks 2810
¥ |Feb Calas 2520
L8 | Foat Beer 2560
L9 | Cream Soda 2310
|10 | Fruit Soda 1340
11| Diet Drinks 2500
|12 |Mar Calas 2520

Select File > Close to close the worksheet. You do not need to save the

worksheet.
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Using Linked Reporting Objects

A linked reporting object is an external file, cell note, or World Wide Web
resource that you link to a cell in a Essbase database. The file, note, or Web
resource (indicated by a URL, or Uniform Resource Locator) can then be retrieved
by the Essbase Spreadsheet Add-in users who have access to the database.

Note: If your organization has licensed and implemented Essbase Partitioning option,
you can also access linked partitions from cells in Essbase Spreadsheet Add-in. For
more information on linked partitions, see “Accessing Linked Partitions” on page 190.

This section describes the following procedures:

e “Linking a File to a Data Cell” on page 173

e “Linking a Cell Note to a Data Cell” on page 177

e ‘“Linking a URL to a Data Cell” on page 178

e “Accessing and Editing Linked Reporting Objects” on page 181

Note: For additional information on using linked reporting objects, see the Essbase
Spreadsheet Add-in online help.

Linking a File to a Data Cell

With the linked reporting objects feature, you can link an external file to a data
cell in Essbase Spreadsheet Add-in. Essbase stores the file on the Essbase server.
Users who have access to the database can then retrieve the file and view the data
contained in the cell.

The following example uses the Asymm . 123 sample worksheet with data from the
Sample Basic database. It links a sample file, Budasmp . txt, to a cell containing
the Budget figure. Budasmp . txt details the budgetary assumptions for the
current year.

Follow these steps to link a file to a data cell:
1. Select File > Open.
2. From the \essbase\client\sample directory, open the Asymm. 123 file.

3. Make sure that you are connected to the Sample Basic database. If you are not
connected, see “Connecting to a Database” on page 120.
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4. Select cell D5.

Note: You can link objects only to data cells, not to cells containing member
names.

Figure 143: Selecting a Data Cell for Linking an External File

A B [ ¢c I b | E [ F [ G |
L1 |Sales
2]
L3 | Acts! | Budgst! | Bvdge?! | Sudgs?
L4 ] Ol 02 Otr3 Otr4
L5 [East Colas G292 7300 5570
L6 | Foaot Beer 5726 5650 5600 5780
L7 | Fruit Soda 3735 4150 4350 3850
8
L9 [\West RootBeer 8278 7970 8320 7820
|10 | Cream Soda | 8043 7e0 4300 7570

5. Select Essbase > Linked Objects.
Essbase displays the Linked Objects Browser dialog box.

Figure 144: Linking a File

Linked Objects Browser -- Aspen:5ample:Basic
ember Combination: IQtr2,8aIes,EoIas,East,Budget
Linked Objects:
Object Type |Dbiect Drescription File Mame Created By Last Modified
Attach... | Edit.. | Eiew.-"Launc:hl [elete | Help | Lloze |

6. In the Linked Objects Browser dialog box, click the Attach button.
Essbase displays the Attach Linked Object dialog box.
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7. Under the Attachment Type option group, select File.
Figure 145: Linking a File to a Data Cell

ember Combination: IQ tr2,5 ales Colas E ast Budget

—Attachment Type
' Cell note

IS : Cancel |
" URL Help |
File M ame:

Browse. ..

File Description:

= ¥

8. Click the Browse button (next to the File Name text box).
Essbase displays the Browse Files dialog box.

9. Gotothe\Essbase\client\sample directory and select the
Budasmp . txt file.

10. Click Open.

11. Under File Description, enter a brief description for the file as indicated in
Figure 146.

Figure 146: Selecting and Describing a File to Link

ember Combination: IQ tr2,5 ales Colas E ast Budget

Attachment Type
' Cell note

& : Cancel |
" URL Help |
File M ame:

IE:\ESSBASE\ELIENT\SAMPLE\Budasmp.txt Browse. .. |

File Description:

Budgetary azsumption report

= ¥

Note: Entering text in the File Description text box is optional.
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12. Click OK to close the dialog box and link the file to the cell.

Essbase copies the file to the server and establishes a link to the current
data cell.

13. Click Close to close the Linked Objects Browser dialog box.

14. Do not close the Asymm. 123 file. You use it in the next tutorial task.

To recognize cells that have linked reporting objects attached to them, you may
want to apply a visual cue, or style, to the cells.

To apply styles:

© N o g k0N

Select Essbase > Options and select the Style tab.

In the Data Cells area, select Linked Objects.

Click Format.

In the Font style list box, select Italic.

In the Color list box, select Purple. Click OK.

Select the Display tab.

In the Cells option group, select the Use Styles box. Click OK.

Select Essbase > Retrieve to refresh the worksheet and apply the styles.

Cell D5 (the cell you just attached the linked file to) is now displayed in
purple, italic font. Essbase also refreshes the worksheet with the other options
set in the Essbase Options dialog box.

Figure 147: Result of Applying a Style to a Linked Reporting Object Cell

Z
-4
==}
1
=
I
I

2

3 Budget Budget Budget

4 Qtrl Qtr2 Qtr3 Qtrd

5 |[East [Colas G242 F 7300 8570
[ RootBeer h726 BEE0 BE00 5780
7 Fruit Soda 3735 4150 4350 3850
8

9 est  |RootBeer G275 7870 g3z0 7820
10 Cream Soda G043 7720 300 7570

Leave the Asymm. 123 file open for the next tutorial task.
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Linking a Cell Note to a Data Cell

In addition to linking external files to a data cell in Essbase Spreadsheet Add-in,
you can also link individual cell notes that contain information on particular data
cells. Cell notes can have no more than 599 characters. If you need to link
information to a data cell that is longer than 599 characters, you need to create
and save an external file and then link the file to the data cell.

»  To link a cell note to a data cell:

1. Inthe Asymm. 123 file, select cell C5.

Note: You can link objects only to data cells, not to cells containing member
names.

2. Select Essbase > Linked Objects.
Essbase displays the Linked Objects Browser dialog box.
3. In the Linked Objects Browser dialog box, click Attach.
Essbase displays the Attach Linked Object dialog box.
4. Under the Attachment Type option group, select Cell Note.

In the Cell Note box, type the note as indicated in the following illustration:
Figure 148: Creating a Cell Note to Link

Member Combination: IQ tr1,5ales Colas E ast Actual

—Attachment Type oK
ppiicil o |
s '_ Cancel |
" URL Help |

LCell Mote:

Thiz number needs to be updated by the E astern Sales Manager. ;I

|

6. To close the dialog box and link the cell note, click OK.

Essbase copies the note to the server and establishes a link to the current
data cell.
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7. To close the Linked Objects Browser dialog box, click Close.

8. Select Essbase > Retrieve to refresh the worksheet and apply the style you

defined for linked objects.

Now Essbase displays two data cells (C5 and D5) in purple, italic font to
represent a cell that contains a linked reporting object.

Figure 149: Result of Creating a Linked Cell Note

| n B [ ¢ e T F [ & ]
1
2
3 Actual Budget Budget
4 Qtrl Qtr3 Qtrd
5 |East [Colas B 5,707 7300 bh70
6 RootBeer | 5726 BEED] 5600 5780
7 Fruit Soda 3735 4150 4350 3850
8
9 est  |RootBeer | 8278 7970 8320 7820
10 Cream Soda 8043 7720 8300 7570

9. Leave the Asymm. 123 file open for the next tutorial task.

Linking a URL to a Data Cell

A URL is an address string that identifies resources on the World Wide Web, such
as documents, images, and downloadable files. With the linked reporting objects
feature, you can link a URL to a data cell so that users who have access to the
database can link directly to the specified URL. When you access the cell from
Essbase Spreadsheet Add-in, your default Web browser opens and displays the

specified URL.

Note: For more information on URL syntax, see the Essbase Spreadsheet Add-in

online help.
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If you have a Web browser and Internet access, follow these steps to link a data cell
to the Hyperion Web site:

1. Inthe Asymm. 123 file, select cell ES.

Note: You can link objects only to data cells, not to cells containing member
names.

Figure 150: Selecting a Data Cell for Linking to a URL

| A B ¢ [ o [ e | ¢ | & |
1
2
3 Budget Budget Budget
4 Qtrl Qtr2 Qtr3 Qtr4
5 |[East [Colas [EEE BT 7300 [0
6 Root Beer 5726 5ERD 5600 5780
7 Fruit Soda 3735 4150 4350 3850
8
9 est  |RootBeer 827a 7970 8320 7820
10 Cream Soda 8043 7e0 8300 7570

2. Select Essbase > Linked Objects.
Essbase displays the Linked Objects Browser dialog box.
3. In the Linked Objects Browser dialog box, click Attach.
Essbase displays the Attach Linked Object dialog box.
4. Under the Attachment Type option group, select URL.

Figure 151: Linking a URL to a Data Cell

Attach Linked Object E

ember Combination: IQ tr3,5ales Colas E ast Budget

Attachment Type

' Cell note

© Fie Cancel |
Help |

Location:
|

URL Description:
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5. Enter a URL in the Location text box and a brief description in the URL
Description text box, as indicated in Figure 152.

Figure 152: Entering and Describing a URL to Link

Attach Linked Object E
ember Combination: IQtr3,8aIes,EoIas,East,Budget
Attachment Type
' Cell note
© Fie Cancel |
Help |

Location:

Ihttp:.-".-"www.hyperion.com

URL Description:
Hyperion Solutions' home page ;I

|

Note: Entering text in the URL Description text box is optional. The text field for
entering the URL location is limited to 512 characters. The text field for entering the
URL description is limited to 80 characters.

6. To close the dialog box and link the URL to the cell, click OK.

Essbase copies the URL string to the server and establishes a link to the
current data cell.

Note: The syntax for the URL is not checked at creation time; Essbase checks the
syntax when the user accesses the URL from the worksheet. The default Web
browser checks for the existence (or validity) of the URL.

7. To close the Linked Objects Browser dialog box, click Close.

Select Essbase > Retrieve to refresh the worksheet and apply the style that
you defined for linked objects.

9. Leave the Asymm. 123 file open for the next tutorial task.

Now that you have learned to create linked reporting objects, you are ready to learn
how to access them from Essbase Spreadsheet Add-in.
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Accessing and Editing Linked Reporting Objects

You have two options for accessing and editing a linked reporting object that is
attached to a data cell:

e Select the cell (as identified by the style applied to it) and select
Essbase > Linked Objects.

e Enable double-clicking for linked object browsing.

Note: If you enable double-clicking for linked object browsing, double-clicking behavior
changes for retrieving data and performing drill actions. For more information on these
changes, see the Essbase Spreadsheet Add-in online help.

For this tutorial, you access the linked reporting objects that you created in the
previous sections by using the Essbase menu item instead of the double-clicking
action.

Accessing a Linked File

Sometimes you want to check an external file that is linked to a data cell.

» To access the external file that you previously linked to a data cell:
1. Inthe Asymm. 123 file, select cell D5.
2. Select Essbase > Linked Objects.

3. In the Linked Objects Browser dialog box, select the Budasmp . txt file.

Figure 153: Accessing a Linked External File

Linked Objects Browser -- Aspen:5ample:Basic

ember Combination: IQ tr2,5 ales Colas E ast Budget

Linked Objects:
Object Type Object Description File Mame Created By Last Modified

Budgetary assumption report  Budasmp.tst  Sups Mon Oct 27 14

Attach... Edit.. Wiew/Launch Delete Help | Lloze |
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4. To view the linked file, click View/Launch.

The Budasmp . txt file is opened from the source application.

Figure 154: Viewing the Contents of a Linked External File

B Budasmp.tzt - Notepad M=l E3
File Edit Search Help
The Beverage Company ;I

1998 Budget Assumptions
The following factors were used to estimate our 1998 Corporate Budget:

1) Sales increases will be 5% in Large Markets, due to market maturity
2) Sales increases will be 18% in Small Markets, due to our focused advertising
3) Expenses will be reduced by 7% across the entire company

We are faced with the challenge of continuing to grow our business, in spite
of increasing competition. We will have to seek out and implement as many cost
saving measures as possible. =

K| 2

Note: Edit the contents of a file in the source application. After the edits are made
and the file saved, you can re-attach the edited file by clicking the Edit button in the
Linked Objects Browser dialog box. Essbase displays the Re-attach Linked Object
dialog box, which you can use to re-attach, or relink, the edited file to the data cell.
For more information, see the Essbase Spreadsheet Add-in online help.

5. Close the Budasmp. txt file and click Close to close the Linked Objects
Browser dialog box.

6. Leave the Asymm. 123 file open for the next task.
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Accessing a Linked Cell Note

Sometimes you have to edit a cell note that was previously created.

» To access and edit the cell note that you previously created:
1. Inthe Asymm. 123 file, select cell C5.
2. Seclect Essbase > Linked Objects.

The Linked Objects Browser dialog box displays the cell note that is linked
to the selected data cell.

3. Inthe Linked Objects Browser dialog box, select the cell note.

Figure 155: Accessing a Linked Cell Note

Linked Objects Browser -- Poplar:5ample:Basic

Member Combination: IQ tr1,5ales Colas E ast Actual

Linked Objects:

Object Type Object Description Linked Object and Object Created By (L.

Cell Maote This number needs to be

« 2

Attach... Edit.. Wiew/Launch Delete Help | Lloze |
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4. To edit the contents of the cell note, click Edit.

Essbase displays the Edit Cell Note dialog box with the selected cell note
displayed.

Figure 156: Editing the Contents of a Linked Cell Note

Edit Cell Mote

Member Combination: |utr1 Sales,100,E ast Actual

LCell Mote:

Note: If you simply want to view the contents of the cell note, click the
View/Launch button instead of the Edit button in the Linked Objects Browser dialog
box.

Edit the contents of the cell note as indicated in the following illustration:
Figure 157: Result of Editing Cell Note Contents

Edit Cell Hote E

Member Combination: |utr1 Sales,100,E ast Actual
LCell Mote:

Thiz number was updated on 8/26/97. ;I QK I

Cancel

i

Help

|

Click OK to close the Edit Cell Note dialog box and save the edits you made
to the note.

Essbase saves the edits to the cell note on the server.
To close the Linked Objects Browser dialog box, click Close.

Leave the Asymm. 123 file open for the next tutorial task.
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Accessing a Linked URL

If you followed the steps in “Linking a URL to a Data Cell” on page 178, you can
access and edit the URL that you created.

» To access the URL:
1. Inthe Asymm. 123 file, select cell ES.
2. Seclect Essbase > Linked Objects.

The Linked Objects Browser dialog box displays the URL that is linked to
the selected data cell.

3. In the Linked Objects Browser dialog box, select the URL.

Figure 158: Accessing a Linked URL

Linked Objects Browser -- Poplar:5ample:Basic

ember Combination: IQtr3,8aIes,EoIas,East,Budget
Linked Objects:
Object Type Object Description Linked Object and Object Created By (L.

Hyperion Solutions' home hittp: £ e, .COom

Attach... Edit.. Wiew/Launch Delete Help | Lloze |
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4. To view the linked URL, click View/Launch.

Essbase checks the syntax of the URL. If there are syntax errors, Essbase
displays an error message. If the URL syntax is correct, the default Web

browser launches and connects to the specified site. In this case, the syntax for
the URL is correct, so the default Web browser launches and connects to the
Hyperion Web site.

Figure 159: Viewing a Linked URL

Welcome to Hyperion - Business Analysis Software Specialists - Metscape

File Edit “iew Go Communicator Help

Worldwide Hyperion

I Select a Nation - I

HYSL  Investor Relations
B Information Request

& Manage Briefcase

3')3, Login

going on with new customer acquisition?"..."What's going on with our sales
cycle?"."What's going on with our Web site sales and service?".. . Tough
guestions demanding real answers. We can help.

Thousands of custormers and millions of users - everyday and around the world -
lepend on busi lysis software from Hyperion to help answer
guestions like these and others.

Hypetion enables everyone in your company to quickly spot growth and profit
opportunities, identify and correct performance problems, eliminate decision
guesswork, improve execution and accountability, and remain focused on
your rost important business goals.

With Hyperion business analysis software, you'll always know what's going
on. Your customers, partners, employees, and suppliers will appreciate this.
Your competition won't.

= == |

|Document: Done

5. Close the Web browser.
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» To edit the URL:
1. In the Linked Objects Browser dialog box, select the URL.
2. To edit the linked URL, click Edit.
Essbase displays the Edit URL dialog box with the selected URL displayed.
Figure 160: Preparing to Edit the Contents of a Linked URL

Edit URL [X]

Member Combination: IIJ tr3.5ales.Colas. E ast. Budget

Location:

I hittp: £ A, hpperion, com

URL Description:

Hyperion Solutions' home page -
Cancel
v

3. Edit the URL location and description as show in the following illustration:

Figure 161: Editing the Contents of a Linked URL

Edit URL [X]

Member Combination: |utr3,sales,Colas,East,Budget

Location:

Ihttp: £ v hpperion. com/solutions. ofm

URL Description:

Hyperion Solutions' home page -
v

4. To close the Edit URL dialog box and save the edits that you made, click OK.

Essbase saves the edits to the URL on the server.
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5. To view the new URL, click View/Launch.

The Web browser launches and connects to the new URL.

Figure 162: Viewing an Edited URL
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6. Close the Web browser.

7. To close the Linked Objects Browser dialog box, click Close.

8. Close the Asymm. 123 file without saving it.
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Connecting to Multiple Databases

Essbase supports simultaneous access to multiple databases. The databases can be
in different applications and can be stored on different servers. In Lotus 1-2-3, you
can open multiple worksheets, each of which can be connected to a different
database. An individual worksheet can access only one database at a time. Use the
Connect command from the Essbase menu to switch the connection between
databases.

Note: Depending on the status of production applications at your site, you may not
have access to additional applications or databases. Check with the Essbase system
administrator if you need access to other applications.

For this tutorial, you do not need to connect to another database.

Note: Tasks that you should not perform as part of the tutorial are shown in light
colored boxes.

» To access multiple databases, use the following procedure:

1. Select Essbase > Connect.

2. In the Essbase System Login dialog box, select the server you want to
access from the Server list box (or type in the name of the server).

3. Press Tab to move to the Username text box and type your username.
4. Press Tab to move to the Password text box and type your password.
5. Click OK to connect to the server.

When the server connection is complete, a list of available application
and database pairs is displayed in the Application/Database list.

6. Double-click the Application/Database pair that you want to connect to
in the Application/Database list. Alternatively, you can select the
Application/Database pair and click OK.

If the application is not already running, Essbase automatically starts it.
There may be a brief pause as the application loads; the time required to
start an application depends on number of databases, the sizes of the
databases, and the sizes of the indexes of the databases contained within
the application.

7. Open a new worksheet and repeat the steps to connect to additional
databases. You can open one database at a time per worksheet.
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For information on connecting to multiple databases from Essbase Query
Designer, refer to Chapter 2.

Viewing Active Database Connections

If you frequently connect to multiple databases, you may need to check the active
database for each worksheet. There are two ways to view the database connection
status:

e The Style tab of the Essbase Options dialog box contains a Connection
Information text box. This box displays connection information for the active
worksheet.

e The Essbase Disconnect dialog box lists all active worksheets and their
connection information. This dialog box also enables you to disconnect one or
more worksheets from their respective databases.

Accessing Linked Partitions

190 W

Linked partitions are part of the Essbase Partitioning product. They provide the
ability to link Essbase databases that contain different dimensions without losing
access to all dimensions of both databases. If your organization has purchased and
implemented the partitioning product, you can take advantage of its powerful
capabilities. The Essbase Database Administrator’s Guide describes how to
design and implement a linked partition. The Essbase application designer usually
sets up partitioning.

Note: The Partitioning product also enables the Essbase application designer to set up
transparent or remote partitions. For more information on partitioning, see the Essbase
Database Administrator’s Guide.
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You can set visual cues, or styles, for cells tagged as linked objects. These cells
are access points to the linked partition within the linked database. You have two
options for accessing a linked partition from a data cell in Essbase Spreadsheet
Add-in:

e Select the cell and select Essbase > Linked Objects.
e Enable double-clicking for linked object browsing.

If you enable double-clicking for linked object browsing, double-clicking
behavior changes for retrieving data and performing drill actions. For more
information on these changes, see the Essbase Spreadsheet Add-in online
help.

When you select Essbase > Linked Objects from a linked partition cell, Hyperion
Essbase completes the following actions:

e Essbase displays the Linked Objects Browser dialog box, which contains a list
of possible partitions to access. From this dialog box, select the partition to
connect to.

Note: The Linked Objects Browser dialog box may also contain a list of linked
reporting objects, such as cell notes and external files. For more information, see
“Using Linked Reporting Objects” on page 173.

e After you select a partition, Essbase creates a new worksheet that contains
corresponding members and dimensions for the cell in the linked partition.

Note: Essbase does not preserve formulas across partitions.

e Essbase retrieves data values from the linked partition.

You can now perform operations such as drill down and drill up to get more
information on the new worksheet.

Note: The Sample Basic database that you are using for this tutorial does not contain
a linked partition. Tasks that you should not perform as part of the tutorial are shown in
light colored boxes.
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dialog box.

objects.

» To access a linked partition in Essbase Spreadsheet Add-in if the Essbase
application designer has a linked partition set up:

1. Locate a linked object cell, as indicated by the style applied to the cell.
2. Select Essbase > Linked Objects to open the Linked Objects Browser

Note: Alternatively, select the Enable Linked Object Browsing check box
in the Essbase Options dialog box to enable double-clicking to view linked

3. Select the partition that you want to connect to and click View/Launch.

Figure 163: Linked Objects Browser Dialog Box, Linked Partition

Linked Objects Browser -- Aspen:5ample:Basic

ember Combination: IQ tr2,5 ales Colas E ast Budget

Linked Objects:

Object Type Object Description
Linked Partition

File Mame

fiach.. | Edi | ViewsLaunch|

Created By Last Modified
‘whed Dec 31 1E;

i

[elete | Help | Lloze |

for the cell in the linked partition.

Essbase creates a new worksheet that contains the dimensions and members

Note: You need to have the proper privileges to access a linked partition. If your user
account and password match the account information for the linked partition, Essbase
establishes a connection with the linked partition. Otherwise, Essbase displays the
Essbase System Login dialog box for you to enter the user account and password

information manually.
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Updating Data on the Server

Data values are changed frequently in applications that involve planning,
budgeting, and forecasting. After you retrieve data into the worksheet, you can use
Essbase Spreadsheet Add-in to change values, enter formulas, and format data.
Essbase is also designed to permit multiuser, concurrent database access and
update. Depending on your security privileges, you may be able to modify all data
values or a certain subset of values. To recognize cells to which you have
read/write access, apply a visual cue, or style, to the cells. For more information,
see “Applying Styles to Data Cells” on page 80. To update data from a worksheet,
you must lock the database area that contains the values that you want to change.
Locking prohibits other users from changing the data that you want to update.
Other users can retrieve locked data but cannot lock or change the data. You have
exclusive update rights to that area.

Note: You cannot update attribute-related data on the server because attribute data is
always calculated dynamically and, hence, is not saved.

You can lock data values in three ways:

e The Retrieve & Lock command retrieves data into the worksheet while
locking the corresponding data area on the server. When you perform a
subsequent retrieval, Essbase automatically unlocks the previous data values.

Note: The Retrieve & Lock command is not supported with Dynamic Time Series
members.

o The Lock command locks information that you have already retrieved. When
you perform a subsequent retrieval, Essbase automatically unlocks the
previous data values.

e The Update Mode check box in the Mode tab of the Essbase Options dialog
box automatically locks the corresponding database area for each retrieval.

To update the server with data values from the worksheet, use the Send command
on the Essbase menu. After updating the server, the Send command automatically
unlocks data (unless you are in Update Mode). You must disable Update Mode to
stop locking blocks automatically.
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You can unlock data blocks in two ways:
e The Unlock command unlocks all blocks that you have locked.

e The server automatically unlocks data blocks that have been locked for the
maximum time allowed as defined by the Essbase system administrator.
Automatic unlock ensures that blocks are not locked for extended periods of
time.

P&1.123, a sample Lotus 1-2-3 file installed as part of the default Essbase
installation, illustrates how to update data on the server.

» To view the P&l .123 worksheet:
1. Select File > Open.
2. From the \Essbase\client\sample directory, open the P&1.123 file.
3. Select Essbase > Retrieve & Lock.

Essbase retrieves data and locks the appropriate area of the database.

Figure 164: P&L Worksheet After Retrieve & Lock

A [ B [ € | o [ E [ F ] G [ H
L1 Market: Central The Beverage Company
L2 | Product: 200 Planning Dept.
L3 | Scenario: Budget
4
]
6 |Misc Eissing  BMissing #Missing .
7 |Payroll 210 210 210 530 0.07
8 |Marketing 300 310 320 930 11.05
9 Total Expenses 510 520 530 1560 18.53
10
11 |COGS 1170 1180 1200 3550 42.16
12 |Sales 2740 2520 2860 8420 100.00
13 targin 1570 1640 1660 4570 57.84
14 Prafit 1060 1120 1130 3310 3.3
15
16 [Ratio Analysis
17 | Markup 57.3% 558.2% 558.0% 57.8%
18 |Marketing % 10.9% 11.0% 11.2% 11.0%

4. Change the value for Sales in Jan (cell B12) to 4000 and press Enter.

Essbase changes the affected data values.
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5. Select Essbase > Send to update the server with the new values.

Essbase updates the server and unlocks the data blocks.

Figure 165: P&L Worksheet After Sending New Values to the Server

A [ B [ € | o [ E [ F ] G [ H
L1 Market: Central The Beverage Company
L2 | Product: 200 Planning Dept.
L3 | Scenario: Budget
4
I—
6 |Misc 5 10 10 25 0.30
7 |Payroll 200 200 200 500 0.07
8 |Marketing 350 350 350 1050 12.47
9 Total Expenses 555 560 560 1675 19.89
10
11 |COGS 1170 1180 1200 3550 42.16
12 |Sales 2740 2520 2860 8420 100.00
13 targin 1570 1640 1660 4570 57.84
14 Prafit 1015 1080 1100 3195 37.95
15
16 [Ratio Analysis
17 | Markup 57.3% 558.2% 558.0% 57.8%
18 |Marketing % 12.8% 12.4% 12.2% 12.8%

6. Close ps1.123 without saving it.

Note: Essbase provides a worksheet update logging facility that tracks and logs all
data updates sent from Essbase Spreadsheet Add-in to the server. The Essbase
system administrator enables this facility for extra protection against data loss. For more
information, see the Essbase Database Administrator’s Guide or contact the Essbase
system administrator.

Calculating a Database

Sending updated data to the server does not automatically recalculate the database.
If you have the appropriate security privileges to perform database calculations,
you can calculate the database from Essbase Spreadsheet Add-in with the
Calculation command. For this tutorial, you will not actually calculate the Sample
Basic database. For more information on Essbase calculations, see the Essbase
Database Administrator’s Guide.

CAUTION: Do not perform any calculation operations for this tutorial.
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When you select Essbase > Calculation, Essbase displays the Essbase Calculation
dialog box.

Figure 166: Essbase Calculation Dialog Box

Essbase Calculation E
Connection Information
(Aspen:SampleoBasic

Cancel |
Calclanc

CalcDes
CalclDes il
Stop Calc |

Select Calc Script:

— Database State

Mo data values have been changed
since the last calculation.

The Essbase Calculation dialog box contains the following items:
e The Connection Information text box displays the active database connection.

e The Select Calc Script list box contains the server-based calculation scripts to
which you have access.

e The Database State text box indicates the current calculation state of the
database. The following states are possible:

— Calculating—indicates that a calculation is currently running on the
database.

— Data values have been modified since the last calculation—indicates that
data values have changed since the database was last calculated. The last
calculation may have been an entire calculation of the database or a
calculation of any subset of the database.
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— No data values have been changed since the last calculation—indicates
that the data in the database has not changed since it was last calculated.
The last calculation may have been an entire calculation of the database
or a calculation of any subset of the database.

CAUTION: I[f the last calculation was performed on a subset of the data,
the entire database may not have been calculated since values last
changed. To ensure that the results of calculations are up-to-date,

you may want to run a calculation of the entire database. For more
information, contact the Essbase system administrator.

Creating Multiple Worksheets from Data

One frequent requirement of budgeting and planning applications is to send
worksheets to various functional areas of an organization. After the worksheets
have been distributed, the recipients can review the contents, make modifications,
and send updates back to the distributor. Using the Essbase Cascade feature, you
can create multiple worksheet files based on a single database view. You can
specify at what level of detail you want to replicate the worksheets to tailor the
information to each recipient’s needs.

The Sample Basic database contains data for beverage products sold in different
states across the U.S. For example, assume that you want all product managers to
review and respond to a proposed budget and to return their changes to the finance
department. We must create a worksheet for each combination of budget and P&L
data to distribute to the product managers for their respective products.

» To create this set of worksheets:

1. Select File > Open.

2. From the\Essbase\client\sample directory, open the
P&1.123 file. This file contains the data that you need to
replicate for each worksheet.

3. Select Essbase > Retrieve.

Notice that the retrieval uses the Use Aliases option, which is already set for
this file in the Essbase Options dialog box. In this example, product 200
changes to Root Beer, which is its preassigned alias.
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Select Central (in cell B1) and Root Beer (in cell B2) as the members to be
represented in the resulting worksheets.

Select Essbase > Cascade.
Essbase displays the Essbase Cascade Options dialog box.
Click the Cascade Information tab.

The Cascade Information page contains the list of members that you selected
and the options for specifying the level at which the selected members are
retrieved into the cascaded worksheets.

Note: For more information on each option, see the Essbase Spreadsheet Add-in
online help.

Select Central in the Member list box, and select Same level in the Choose
Level for Selected Member option group.

Select Root Beer in the Member list box, and select Next level (the default
setting).

Figure 167: Cascade Information Tab

Essbase Cascade Options E

Cascade Information | Destination Dptionsl Format Dptionsl

- Cascade Or:

tember: Choose Level far
Selected Member:
Central Same level
iHoot Beer et [yl & NestLevel
Al Levels
© Battom Level
' Sibling Level

7 Same Level
7 Same Generation

 Formulas

QK I Cancel | Help |

The replicated, or cascaded, spreadsheet reports now provide data for
members at the same level as Central (East, West, and South) and for members
at the level below Root Beer (Old Fashioned, Diet Root Beer, Sarsaparilla, and
Birch Beer).
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9. Click the Destination Options tab.

10. In the Destination Directory text box, enter C: \ temp as the name of the
directory where you want the cascaded worksheets to be stored.

You can also click Browse to select a destination directory from the Browse
dialog box.

11. In the Destination Types option group, select Separate Workbooks (the
default setting) to create separate Lotus 1-2-3 files for each cascaded
worksheet.

You can also tell Essbase to create only one workbook with separate
worksheets for each cascaded report, or you can send the cascaded reports to
the printer.

12. In the File Information option group, click Overwrite Existing Files
(the default setting). This option tells Essbase to overwrite any cascaded
worksheets with the same file name.

You can also select Open Created Files to open each cascaded file in
Lotus1-2-3 as it is created.

CAUTION: Depending on the number of replicated worksheets that you
want to create, the Cascade command can create more worksheets than
can be stored in the memory of your computer. Therefore, the Open
Created Files option should not be used when you are replicating large
numbers of worksheets.
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13. In the Naming Information option group, enter BUD in the Prefix text box.

Figure 168: Destination Options Tab

Essbase Cascade Options E

Cazcade Information Destination Options | Format Dptionsl

r— Destination Directory: ———— 1~ Destination Types

hbemp & Separate Workbooks
" OneWorkbook, Separate Sheets

Elo=l | " Printer Printer... |

—File Infarmation————————  —~ Maming Infarmation
[~ Open Created Files Prefis: ELD
¥ Ovenwrite Existing Files S

Wwiorkbook: I

QK I Cancel | Help |

When you assign a prefix or suffix in the Naming Information option group,
the worksheet files that are generated as a result of executing the Cascade
command are named with the prefix or suffix that you specify. The default
is to generate worksheet names that are numbered 1 through n, where n

is the total number of worksheets created. The syntax for the file names is
PrefixnSuffix.123. If you do not specify a prefix or suffix, Essbase creates the
worksheets 1.123, 2.123, and so on. If you are creating a single workbook,
the same naming convention is used for the worksheet tab names within the
workbook.

CAUTION: Do not specify a prefix and suffix combination that leaves no
characters free for Essbase to create unique file names. If file names are
duplicated, Essbase overwrites the duplicate file name with the last
cascaded worksheet.
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14. Click the Format Options tab.

15. To copy the formatting of the source worksheet into each cascaded worksheet,
select the Copy Formatting check box.

Note: Copy formatting copies only the visual cues set using Essbase and the cell
formatting that you set using the worksheet. It does not copy formulas, column
formatting, worksheet formatting, or graphs.

In the Header and Footer text boxes, specify a header or footer name to be
used for all of the cascaded worksheets.

16. In the Sheet Formatting group, select the Suppress Missing Rows check box
so that rows containing only #Missing values are not replicated.

17. In the Table of Contents group, select the Include Table of Contents check
box to create a text file that lists all replicated worksheets, their creation dates,
and their member content.

By default, Essbase names the Table of Contents file with the extension . 1st.
Figure 169: Format Options Tab

Essbase Cascade Options E

Cascade Informationl Destination Options ~ Format Options |

— Sheet to Sheet Replication
V' Copy Formatting

Header: I

Footer: |

— Sheet Formatting
¥ Suppress Missing Rows

— Tabl

QK I Cancel Help
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18. Click OK to create the cascaded worksheets.

Essbase rapidly creates the cascaded worksheets (nine total worksheets in this
example). As each worksheet is created, it is automatically saved, closed, and
logged in the Table of Contents. Each individual file is saved in the directory
that you specified, named Bud1l.123 through Bud9.123. When the Cascade
is completed, Essbase returns you to the original worksheet view (that is, the
source file).

19. Using a text editing application, open the Table of Contents file from the
destination directory that you specified earlier. This file is named BUDO . LST
and contains a list of all cascaded worksheets.

Figure 170: Table of Contents File for Cascaded Worksheets

/***********************************************************/

/* File name: c:\temp\BUDD.1lst */

/* Creation date: Mon MNov 10 11:48:34 1997 */
/***********************************************************/

c:htempyBUD1.123 /* East, 0ld Fashioned */
c:\tempyBUDZ .123 /* East, Diet Root Beer */
c:\tempi\BUD3.123 /* East, Sasparilla */
c:htempyBUD4.123 /* East, Birch Beer */
c:htempyBUDS.123 /* West, 0ld Fashioned */
c:htemnpyBUDG.123 /* TWest, Diet Root Beer */
c:h\temph\BUDT .123 /* West, Sasparilla */
c:\tempyBUDB.123 /* 3outh, ©0ld Fashioned */
c:htempyBUDY .123 /* 3outh, Diet Root Beer */
c:\tempyBUD10.123 /* 3outh, Sasparilla */

20. Select File > Close to close the worksheet.

You do not need to save the worksheet.

Note: You can create multiple worksheet files based on the attributes of a product.
Type in the attribute names in the top row of the worksheet. Select the attribute names
and select Essbase > Cascade. Proceed as described in the above example.
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Working with Currency Conversions

Organizations with offices in different countries generally do business in the
currency of the host country (known as the local currency). Such organizations
must convert data entered in local currencies to a common currency for
consolidation and analysis.

The Essbase Currency Conversion product can be purchased separately for
Essbase. If your organization has purchased this product and has implemented a
currency conversion application, you can take advantage of the powerful
capabilities of Hyperion Essbase Currency Conversion. The Essbase Database
Administrator’s Guide describes how to design and implement a currency
conversion application.

The following sections provide a brief tutorial for working with currency
conversions:

e “Retrieving Currency Conversion Data” on page 203
e “Connecting to the Sample Currency Databases” on page 204

e “Performing Ad Hoc Currency Reporting” on page 207

Retrieving Currency Conversion Data

This section focuses on basic currency conversion concepts, including the
easy-to-use Currency Report command.

A currency conversion application consists of two databases:
e A main database that contains data in local and converted values

e A currency rates database that contains exchange rates

Apply exchange rates from the currency rates database to local values from

the main database to derive converted values. The Essbase server product
installation includes a sample currency conversion application (installation
options) that consists of two sample databases: a main database called Interntl and
a currency rates database called Xchgrate.

The Sample Interntl database consists of five dimensions: Year, Measures,
Product, Market, and Scenario. All but the Market and Scenario dimensions are
identical to the Sample Basic database. The Market dimension includes Toronto,
Vancouver, Montreal, France, Germany, Spain, and the UK. The Scenario

Essbase Spreadsheet Add-in for 1-2-3 B 203



An Advanced Essbase Tutorial

dimension handles different currency types (such as Actual and Budget) in both
local and converted currencies. In this database, all local currencies are converted
to the common currency of U.S. dollars.

The Sample Xchgrate database, which is a subset of the main database, contains
four dimensions:

e The CurTime dimension accommodates different exchange rates by month.

e The CurName dimension contains names of currencies from their respective
markets.

e The CurCategory dimension contains the names of the various currency
categories that may be applied to the categories of Measures. For example, one
rate is applied to Profit and Loss items and another rate is applied to Balance
Sheet items.

e The CurType dimension enables a currency database to contain rates for
different scenarios, such as Actual and Budget.

Connecting to the Sample Currency Databases

To complete the following exercises, the Sample Interntl and Sample Xchgrate
databases must be installed on the server. Contact the Essbase system
administrator if these application and database pairs are unavailable.

» To retrieve data from the Sample Interntl database:
1. Select Essbase > Connect.
2. Select the Sample Interntl database and click OK to complete the connection.

The Essbase installation also includes sample Lotus 1-2-3 files that illustrate
currency conversion concepts.
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The worksheet contains actual (Act) and budget (Bud) data entered in local
currencies for New York and Germany.

Figure 171: Retrieving Local Data

Total Expenses  #Missing #Missing #Missing  #Missing

Margin %% #Missing  #Missing #Missing  #Missing
Profit %2 #Missing  #Missing #Missing  #Missing

A [ B [ c© ] D [ E F
L1 Jan 100-10
2
3 | Az Fend
4 | New York Germany New York | Germany
L5 |Sales 678 210 640 190
LB |COGS 27 84 260 80
L? | Margin #Missing  #Missing #Missing  #Missing
8
|9 |Marketing 94 27 80 20
|10 |Fayrall 51 Kl 40 20
11 |Misc i 0 #dissing  #Missing
2]
3]
4]
15 ]

—
o

4. From the\Essbase\client\sample directory, open Convert.123.
Select Essbase > Retrieve.

The worksheet contains values for Actual and Budget as they display after
conversion.

Figure 172: Retrieving Converted Data Values

A [ B [ € ] D [ E [T F [T & |
1 llJan 100-10
2
3 Actusl Actuat & Bed XChe P
4 Mew York Germany Mew York | Germany  New York | Germany
5 |Sales 678 130 678 210 640 133
B |COGS 271 52 271 84 260 56
7 Margin 407 78 407 126 380 77
8
9 |Marketing 94 17 94 27 a0 14
10 |Payrall 51 19 51 31 40 14
11 |Misc 0 0 0 0 #Missing #Missing
12 | Total Expenses 145 36 145 58 120 28
13
14 Margin %% 60.03 60.00 60.03 60.00 59.38 57.89
15 Profit %2 38.64 32.38 38.64 32.38 40.63 36.84

Notice that the worksheet contains data that is converted to U.S. dollars.
Values for New York remain the same, but Germany values are converted.
Essbase converts the values by using the exchange rates from the Sample
Xchgrate database.
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From the \Essbase\client\sample directory, open Rates.123. Connect
to the Sample Xchgrate database.

Select Essbase > Retrieve.

Figure 173: Retrieving Exchange Rates from a Currency Database

A

B

[ 6 [ H T 1 [ J |

==

-
M

US$

CHE

Mark

Actxchg
Bud xchg
Actxchg
Bud xchg
Actxchg

Bud xchg

PaL
B/S
PaL
B/S
PaL
B/S
PaL
B/S
PaL
B/S
PaL

0.7

0.7

Apr May | Jun

0.7 0.7

The worksheet contains all possible combinations of exchange rate scenarios,
categories, and types by month. Because this example converts to U.S. dollars

(USS$), the sample file contains a base rate of 1 for US$. Therefore, the local and
converted figures remain the same for New York. Essbase converts the figures for
Germany, however, by using data values in the currency database, as follows:

Essbase divides data values from Actual by values in the Act xchg currency
type.

Essbase divides data values from Actual @ Bud xchg by values in the Bud
xchg currency type.

Essbase divides data values from Budget by values in the Bud xchg currency
type.

Essbase bases all figures in Convert.123 on the CurCategory of P&L and
the CurTime of Jan.

Note: A conversion can be defined as a multiplication or division operation on
exchange rates. The definition is determined by the application designer.
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Performing Ad Hoc Currency Reporting

A main database, such as Sample Interntl, usually contains values that are
converted and stored in the database. You may want to perform currency
conversions dynamically, as well. Essbase provides this capability with the
Currency Report command. This command enables you to interactively change the
currency rates and types applied to the retrieval.
» To perform an ad hoc conversion on data in the Convert . 123 file:
1. From the \Essbase\client\sample directory, open Convert.123.
The worksheet contains data that is already converted to U.S. dollars.
Select Essbase > Connect and connect to the Sample Interntl database.
Select Essbase > Retrieve.

Select Essbase > Currency Report.

Essbase displays the Essbase Currency Report dialog box.

Figure 174: Essbase Currency Report Dialog Box

Eszsbase Currency Report E
Current Setting:
[ | =
LClear |
Curkame CurType
I ENg jv Cancel |
‘rear CurCategory
|[n0ne} ﬂ |[n0ne} ﬂ Help |

The Essbase Currency Report dialog box enables you to interactively
modify the exchange rates applied to the retrieval. The box contains options
for currency settings, names, categories, and years. For more information on
these options, see the Essbase Spreadsheet Add-in online help.

Note: The dimension names CurName, CurType, and CurCategory are default
names for a currency database. The application designer can use different names
for any of these dimensions.

5. Select the currency settings that you want to apply.

For example, select CN$ from the CurName list box and Bud xchg from the
CurType list box.
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Click Apply to apply the settings.

7. Select Essbase > Retrieve to refresh the data in the worksheet with the results
of the ad hoc conversion.

Figure 175: Performing an Ad Hoc Currency Conversion

A [ B [ € ] D [ E [T F [ & |
1 IJan Cola
12|
| 3 | Actusl Actuat & Bed XChe P
| 4 | Mew York Germany Mew York | Germany  New York | Germany
| B Sales 452 61 452 69 427 62
| B |COGS 181 24 181 27 173 26
| 7 | Margin 271 36 271 a1 253 36
8
| 9 |Marketing 63 8 63 9 53 7
| 10 | Fayrall 34 9 34 10 27 7
| 11 [Misc i i i 0 #dizsing #Missing
| 12 | Tatal Expenses 97 17 97 14 i 13
13
| 14 | Margin % 60.03 60.00 60.03 60.00 59.38 57.89
L156 |  Profit®s 38.64 32.38 38.64 32.38 40.63 36.84

Essbase converts the New York and Germany figures to Canadian dollars
(CN$).

8. Click the Clear button in the Essbase Currency Report dialog box to disable
currency reporting and return to standard retrieval mode.

Note: Performing a currency report retrieval does not change values in the
database. It simply performs a temporary conversion as part of the retrieval.
Converted data values may not always balance, because the ad hoc conversion is
performed on values that were previously calculated or previously consolidated in
another currency.

If values must balance and verify, they must be converted to the target currency in
the database, calculated, and retrieved. This procedure differs from the ad hoc
currency conversion retrievals described in this section; see the Essbase system
administrator for more information.
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Essbase Integration Services is a product that works with Essbase and Essbase
Spreadsheet Add-in for Microsoft Excel and Lotus 1-2-3. Essbase Integration
Services is a suite of tools and data integration services that serves as a bridge
between relational data sources and the Essbase server. Drill-through is one of
these tools. Drill-through enables you to view and customize spreadsheet reports
that display data retrieved from relational databases. Your organization must
license Essbase Integration Services for you to use the drill-through tool.

This chapter provides the following information:
e A brief overview of the drill-through feature

e Adescription of the sample database, Lotus 1-2-3 file, and drill-through report
used for the tutorial

e A tutorial that guides you through tasks for using drill-through

What Is Drill-Through?

Despite the benefits of the multidimensional database for storing analytic data,
some data elements required for analysis are better suited to the relational structure
of a relational database. The scope of data residing in an Essbase database is
typically at a summary level, where data is summarized and calculated for
planning and analysis. Detailed, transactional data usually is not examined during
the planning and analysis of a business.

For example, say you are using Essbase to analyze retail sales for the first quarter
in the Eastern region. Detailed data, such as a list of customers who purchased a
particular product in a particular size, is not used during the normal course of

analyzing business performance. However, as you analyze sales results, you may
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want to view more detailed information. Drill-through is a tool that enables you to
drill from the summarized and calculated data stored in the Essbase server of your
organization into detailed data stored in a relational database.

The database administrator predefines a data mapping for you from Essbase to the
relational source. For example, the Essbase members East, West, South, and
Central might map to a field called Region in a relational database. As you
navigate through data in the spreadsheet, Essbase knows how the current data
maps to the relational source. For example, suppose you select cell G4 in the
following sheet:

Figure 176: Example of Drill-Through Sheet

Market drill ¥ [Market Detail\ Measures drilll \ Measures drill2 \ Measures Detail \ Praduct drill \

The dimensional attributes of the cell are as follows: Actual, Profit, New York,
Feb, and Product. The combination of one or more of these attributes becomes the
basis of a drill-through query that returns data from the relational source.

From Essbase Spreadsheet Add-in, you can access a predefined drill-through
report that is based on the dimension or member intersections of Essbase data cells
in the sheet. Using an Essbase Integration Services tool called Essbase Integration
Services Console, an administrator at your organization sets up drill-through
reports for you to access; that is, each drill-through report is already defined in
terms of what to retrieve from the relational source.
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B A [l c ol e lFlFTalHl 1 ol L M|
1 Profit  Product

2 Scenario Actual Budget
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b Florida 336 361 373 1070 336 361 373 1,070 400 450 4500 1,300
7 Connecticut 321 309 2490 9200 321 309 2490 920 380 3490 3600 1,130
] Mew Hampshire 44 74 a4 202 44 74 a4 2020 110 130 140 380
9 East 1,732 1,843 1,805 5,380 1,732 1,843 1,805 5380 2080 22300 27190 6,500
10 ‘wiest 2,339 2,394 2404 737 2339 2394 24040 137 29800 29900 2990 8,960
11 South 997 1,046 1,034 3,077 997 1,046 1,034 3077 1,330 1,440 1,410 47180
12 Central 2,956 3,063 3,090 9709 2956 3,063 3090 9709 35500 3690 3,700 10,940
13 |Market 8,024 8,346 8333 24703 8024 8346 8333 24,703 9,940 10,350 10,290 30,580



Using Drill-Through

In Essbase Spreadsheet Add-in, you can access drill-through reports from the
Linked Objects Browser dialog box. When you select a drill-through cell in the
sheet and select Essbase > Linked Objects, the Linked Objects Browser dialog box
displays an entry for drill-through that you can select and launch.

Figure 177: Linked Objects Browser Dialog Box with Drill-Through Entry

i Linked Objects Browser -- Localhost:5ample:0LAP_TBC

Iember Combination:

Linked Objects:
Object Type
Crrill-Through

i

Attach... | Edit. |£i.ew.-"Launc:h| [elete | Help | Lloze |

You can define a style for cells tagged as drill-through to identify which cells in
the spreadsheet are associated with drill-through reports. For more information,
see “Accessing Drill-Through from the Spreadsheet” on page 221.

What Is the Drill-Through Wizard?

An administrator at your organization can predefine drill-through reports for you
to view or customize. The person who develops a report determines whether the
report can be customized by drill-through users. If a report can be customized, use
the Drill-Through Wizard to customize it. The Drill-Through Wizard is a graphical
user interface that steps you through the following customization tasks:

e Selecting columns to retrieve from the relational data source
Decide which columns from the predefined report you need to see.
e Selecting the display order for columns

Change the default display order of columns across the sheet.
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e Selecting a sort order for data

Select an ascending or descending sort order for a particular column; for
example, sort a list of store managers in alphabetical order.

e Selecting data filters

Define a filter on a column so that only data meeting certain criteria is
retrieved.

Before You Start

Before starting the tutorial, you should have a working familiarity with the Essbase
product through the use of the Essbase Spreadsheet Add-in interface. Review in
this guide Chapter 2, “A Basic Essbase Tutorial” and Chapter 3, “An Advanced
Essbase Tutorial” as prerequisite reading.

A sample Essbase database is the basis for the examples in this tutorial. The
database administrator creates this sample Essbase database using the sample
metaoutline supplied with Essbase Integration Services. For more information, see
the Essbase Integration Services OLAP Metaoutline User’s Guide. A sample
Lotus 1-2-3 file, Essdt . 123, contains a sheet with the appropriate member
intersections for the sample drill-through report. For more information on the
sample database, Lotus 1-2-3 file, and drill-through report, see “About the
Samples Used in This Tutorial” on page 220.

If you plan to follow the examples in a live working session, check with the person
at your organization who installs the Essbase Integration Services product family
for information on the sample database you need for drill-through, and to which
Essbase server you should connect.

Note: The Essdt. 123 file also contains sample results of the drill-through reports
when you run them without customizing the reports. The results are provided in
separate sheets in the workbook so that you can see the sample report results without
working through the tutorial For more information about the sample reports, see “About
the Samples Used in This Tutorial” on page 220.
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Before starting the tutorial, make sure you meet the following requirements:
e You must install the following components on your client PC:

— A 32-bit version of Lotus 1-2-3

— Essbase Spreadsheet Add-in for Lotus 1-2-3

—  Drill-through

The drill-through module is installed automatically when you install
Essbase Spreadsheet Add-in. This module is transparent until you invoke
it from the Linked Objects Browser. For more information on installation,
contact the Essbase system administrator.

e The Essbase system administrator must install the Essbase server.

e You must have access to Essbase Integration Services and to the Essbase
server. For more information, contact the Essbase system administrator or the
person who administers Essbase Integration Services at your organization.

e You must have access to the underlying relational database (typically using a
user name and password that are different from those you use for Essbase). For
more information, contact the Essbase system administrator or the person who
administers Essbase Integration Services at your organization.

e Make sure that the sample Lotus 1-2-3 file, Essdt . 123, is available in the
\Essbase\client\sample directory.

e In order to use the sample drill-through report, Essdt . 123, you need to login
to a machine that has both the Essbase server and Essbase Integration Services
installed. You must run member and data load and calculate the data for the
sample Essbase Integration Services database that you will access from
Essbase Spreadsheet Add-in.

e The sample database that contains the drill-through report must be set up and
running. The sample drill-through reports used in this tutorial (called “Market
Detail,” “Measures Detail,” and “Product Detail”’) are available with the
sample database. Contact the person at your organization who installs Essbase
Integration Services to find out the name of the sample database needed for
drill-through.

Note: For more information on Essbase Integration Services installations, see the
Essbase Integration Services Installation Guide. For more information on Essbase
installations, see the Essbase Installation Guide.
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Keep in mind the following guidelines during the tutorial:

Each tutorial task builds upon the previous one, and tasks must be followed in
succession.

Tasks that should not be performed as part of the tutorial are displayed in gray
boxes. These tasks are included for your reference. You can find more
information on these tasks in the Drill-Through online help.

The examples used in this tutorial are based on the sample database that is
included with the Essbase Integration Services installation. Contact the person
at your organization who installs Essbase Integration Services for information
about accessing the sample database.

Set the options in the Essbase Options dialog box as described in the following
section, “Setting Essbase Options” on page 214. If the option settings are
different, the illustrations presented in this chapter may not match the
spreadsheet view.

If you make a mistake during the tutorial, select Essbase > FlashBack to return
to the previous spreadsheet view.

Setting Essbase Options

Before you begin the tutorial, make sure that the spreadsheet options are set to the
initial settings, as illustrated in Figure 178 through Figure 182. If your option
settings are different, the illustrations presented in this chapter may not match the
spreadsheet view.

214 1

Note: For information about each option in the Essbase Options dialog box, click Help
to see the Essbase Spreadsheet Add-in online help.

» To set Essbase options:

1.
2.

From the spreadsheet menu, select Essbase > Options.

In the Essbase Options dialog box, select the Display tab.
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3. Select the appropriate check boxes and option buttons so that your display
matches the following illustration:

Figure 178: Initial Settings for Display Options

Essbase Options

|Zoom | Mode | St | Glbal]
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Select the Zoom tab.

Select the appropriate check boxes and option buttons so that your display
matches the following illustration:

Figure 179: Initial Settings for Zoom Options

Essbase Options
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Select the Mode tab.

Select the appropriate check boxes and option buttons so that your display
matches the following illustration:

Figure 180: Initial Settings for Mode Options

Essbase Options
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Select the Style tab.

Select the appropriate check boxes and option buttons so that your display
matches the following illustration:

Figure 181: Initial Settings for Style Options

Essbase Options E
Display I Zoom I Mode  Style | Global I
— Member
Aftribute: - Sample
i
[ Chid
Shared -
L —I Farmat.. |
— Dimenszion
Dimenszion: - Sample
i
[ Measures
I Product LI
™| Gl Barder
Background Color: I Mone j M
— Drata Cell
Attribute: — Sample
I Integration Server Drill-Through
[~ Read Only LI Farmat.. |
Connection Information:
’7 Aszpen:Sample:Basic ‘

QK I Cancel | Help |
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10. Select the Global tab.

11. Select the appropriate check boxes and option buttons so that your display
matches the following illustration:

Figure 182: Initial Settings for Global Options

Essbase Options

12. Click OK to save the settings for this session and close the Essbase Options
dialog box.
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About the Samples Used in This Tutorial

220 m

The sample database used for this tutorial contains the following dimensions:
Scenario, Product, Market, Measures, and Year. The sample Lotus 1-2-3 file
shown in Figure 183 provides a particular view from this database:

Figure 183: View from Sample Database

Market drill ¥ [Market Detail\ Measures drilll \ Measures drill2 \ Measures Detail \ Praduct drill \

For this spreadsheet view, detail-level data exists in a relational data source—data
that is not available from Essbase. For example, the relational source contains
columns of data for market detail, measures detail, and product detail. This tutorial
walks you through a sample drill-through session, where you will drill down from
the data shown in Figure 183 into the detail data from the relational source.

This tutorial uses two sample drill-through reports, “Measures Detail” and
“Market Detail.” As with all drill-through reports, these reports have been
predefined to retrieve specific columns from the relational source. You will use the
Drill-Through Wizard to customize the report, “Measures Detail.”

Note: The sample file also contains two more sample reports called “Product Detail”
and “Two reports” that you can use for drill-through practice. In “Two reports,” select the
drill-through cell B3 to select from two drill-through reports, “Product Detail” and Market
Detail, select cell B6 to view “Market Detail,” and cell G3 to view “Product Detail.”

In addition to the sample drill-through reports, Essdt . 123 provides sample
results of the drill-through reports. The following list describes the drill-through
results that are provided:

e The Market Detail drill tab displays the results for Market Detail when you run
a drill-through report on cell G4 without customizing the report.

e The Measures Detail drilll tab displays the results for Measures Detail when
you run a drill-through report on cell C4 without customizing the report.
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B A [l c ol e lFlFTalHl 1 ol L M|
1 Profit  Product

2 Scenario Actual Budget

3 Jan  Feb har G Jan  Feb har G Jan  Feb hlar Gt

4 ey ork 512 601 543 1,656 512@ 543 1656 G20 710 670 2,000
5 Massachusetts | 519 495 515 1532 519 495 515 1,532 570 550 5700 1,690
b Florida 336 361 373 1070 336 361 373 1,070 400 450 4500 1,300
7 Connecticut 321 309 2490 9200 321 309 2490 920 380 3490 3600 1,130
] Mew Hampshire 44 74 a4 202 44 74 a4 2020 110 130 140 380
9 East 1,732 1,843 1,805 5,380 1,732 1,843 1,805 5380 2080 22300 27190 6,500
10 ‘wiest 2,339 2,394 2404 737 2339 2394 24040 137 29800 29900 2990 8,960
11 South 997 1,046 1,034 3,077 997 1,046 1,034 3077 1,330 1,440 1,410 47180
12 Central 2,956 3,063 3,090 9709 2956 3,063 3090 9709 35500 3690 3,700 10,940
13 |Market 8,024 8,346 8333 24703 8024 8346 8333 24,703 9,940 10,350 10,290 30,580
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o The Measures Detail drill2 tab displays the results for Measures Detail when
you run a drill-through report on cell G6 without customizing the report.

e The Product Detail drill tab displays the results for Product Detail when you
run a drill-through report on cell D5.

Using Drill-Through
Drill-through consists of the following tasks:
e Accessing Drill-Through from Essbase Spreadsheet Add-in
e Selecting Drill-Through Reports to View or Customize
e Selecting and Ordering Columns
e Sorting Data

e Filtering Data

The following sections describe each of these tasks and step you through a live
working drill-through session.

Accessing Drill-Through from the Spreadsheet

From Essbase Spreadsheet Add-in, you can access detail-level drill-through
reports that are based on the member intersections of Essbase data cells in the
sheet. Each drill-through report has been predefined by an administrator at your
organization; that is, each drill-through report is already set up to retrieve specific
columns from the relational source, to sort data in these columns in specific ways,
and so forth. Using the Drill-Through Wizard, you can customize these predefined
drill-through reports to retrieve only the data you want, displayed in a specific
way.

To access the predefined drill-through report, double-click a drill-through cell in
the spreadsheet (or select a range of cells and select Essbase > Linked Objects).
You can set styles for cells tagged as drill-through to help identify which cells in
the sheet are associated with drill-through reports. When you double-click a
drill-through cell, Essbase displays the Linked Objects Browser dialog box, which
displays an drill-through report entry. A single cell can have multiple reports
associated with it. The Linked Objects Browser dialog box also displays entries for
linked partitions and other linked object types, such as cell notes, URLs, and
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application files. After you view or customize the drill-through report, Essbase
Integration Services retrieves data from the relational source and displays the
results in a new spreadsheet.

Before starting the drill-through tutorial, perform the following tasks:

1. Open a sample Lotus 1-2-3 file that contains the appropriate member
intersections from the sample database for the drill-through report. This file,
Essdt. 123, is provided as part of the default Essbase installation.

2. Set a style for data cells that are associated with drill-through reports.

» To access the sample file and sample database:
1. Start Lotus 1-2-3.

2. Select File > Open and open the Essdt . 123 file from the
Essbase\client\sample directory.

The sample file should look like the following screen. Note that the Market
Detail tab is selected in this example. The default tab that is selected when you
first open the file may be different.

Figure 184: Sample Lotus 1-2-3 File for Drill-Through

Market drill ¥ [Market Detail\ Measures drilll \ Measures drill2 \ Measures Detail \ Praduct drill \

B A [l c ol e lFlFTalHl 1 ol L M|
1 Profit  Product

2 Scenario Actual Budget

3 Jan  Feb har G Jan  Feb har G Jan  Feb hlar Gt

4 ey ork 512 601 543 1,656 512@ 543 1656 G20 710 670 2,000
5 Massachusetts | 519 495 515 1532 519 495 515 1,532 570 550 5700 1,690
b Florida 336 361 373 1070 336 361 373 1,070 400 450 4500 1,300
7 Connecticut 321 309 2490 9200 321 309 2490 920 380 3490 3600 1,130
] Mew Hampshire 44 74 a4 202 44 74 a4 2020 110 130 140 380
9 East 1,732 1,843 1,805 5,380 1,732 1,843 1,805 5380 2080 22300 27190 6,500
10 ‘wiest 2,339 2,394 2404 737 2339 2394 24040 137 29800 29900 2990 8,960
11 South 997 1,046 1,034 3,077 997 1,046 1,034 3077 1,330 1,440 1,410 47180
12 Central 2,956 3,063 3,090 9709 2956 3,063 3090 9709 35500 3690 3,700 10,940
13 |Market 8,024 8,346 8333 24703 8024 8346 8333 24,703 9,940 10,350 10,290 30,580

The sample file shows data for specific members of an Essbase database. This
sample file contains the following three predefined drill-through reports,
indicated by the tabs of the spreadsheet: “Market Detail,” “Measures Detail,”
and “Product Detail.” Using drill-through, you can access these reports and
customize them so that Essbase Integration Services retrieves only the data
you need and displays it in the desired format.
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Select the Market Detail tab on the spreadsheet.

Select Essbase > Connect and connect to the appropriate sample database.

Note: A specific sample database for drill-through is not automatically provided
with Essbase Integration Services. For information on the sample database,
contact the person at your organization who installs Essbase Integration Services
to set up a database for you.

Select Essbase > Options and select the Style tab.

6. Inthe Data Cells option group, select the Integration Server Drill-Through
check box and click Format.

Essbase displays the Font dialog box.
7. Select Bold Italic from the Font style list box.

Select Blue from the Color drop-down list, and click OK to return to the
Essbase Options dialog box.

Figure 185: Font Dialog Box Selection

Font 21=]
FEont: Font style: Size:
[MS Sans Seii Eold ltalic] 10 [ ok ]
M5 5 erif Regular af g .
MS Seri Italc B IlIl—I Corcel |
T News Gothic Bold 12
H News Gothic Condens Bold [talic 14
% Mimrod it 18
Orys 24
B Perpetua LI LI LI
— Effect: — Sample
[ Stikeout
™ Underline AL
Lolor:
I- Blue vl Script:
IWestern VI

Note: In the Essbase Options dialog box, Essbase displays an example of the
selected style in the Sample box.
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The following screen shows how the Essbase Options Style tab looks with
the style for drill-through cells defined:

Figure 186: Sample Style for Drill-Through Data Cells

Essbase Options E

Displayl Zoom I Mode  Style |GIObaI|

— Member
— Sample
v
v Child Parent
I Shared LI
Farmat... |
— Dimenszion
— Sample
=
[ Measures
I Product LI
™| Gl Barder
Background Color: I Mone j Earmat... |
— Drata Cell
— Sample
I Linked Objects = Sl
Imllirtegration Server Drill-Through fategration Sen
™ Read Only LI
Farmat... |
Connection Information:
’7 lzgal 7:EIS:Main ‘
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In the Essbase Options dialog box, select the Display tab, and then select the
Use Styles check box.

Figure 187: Setting the Use Styles Option

Essbase Options

[ ]
Display |Zoom I tode I Style I Globall
~ Indentation — Replacement
" None HMigzing Label: IU—
& Subitems
 Totals

#Mo Access Label: I

=
liaze:

— Suppre

™ #Missing Fows V' Use Aliases
™ Zemo Rows

™ Use Both Member Names and Aliases
far Row Dimensions

Alias:
rCels————

™ Underscore Characters

IDefauIt j
V' Adiust Columng
= Auto Sort Fows Query Designer
¥ Bepeat Member Labels ’7|_ Use Sheet Options with Query Designer
— Dynamic Time Serie:

I Latest Time Period IJan

=

()3 I Cancel |

Help |

10. Click OK to close the Essbase Options dialog box.
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11.

Select Essbase > Retrieve to display the new style in the spreadsheet.

In Figure 188, the sample drill-through report is associated with the data cells
for Actual, Profit, and Product at the month and Eastern state levels, so that
these data cells are displayed in blue, bold, italic font.

Figure 188: Sample Lotus 1-2-3 File with Drill-Through Style Applied

A [ B [ € [ b [ E [ F & [ w® T 1 [ 4 g

|1 Profit | Product
| 2 | Scenaria Actual J
| 3 | Jan Feh tlar Oitrl Jan Feh ar Oitrl Jan
L4 | Mews ' ork Y24 a37 A47 1656 5)’2' #i7 _l A47 1656 [
| 5 | Massachusetts EYES 98 &7 1532 EYES 98 &7 1532 a8
| 6 | Flarida JIE JET Z77 1070 JIE JET Z77 1070 07
| 7| Connecticut 277 Ji7 B 920 277 Ji7 B 920 FE7
= MNew Hampshire L&l ~ #4 202 L&l ~ #4 202 7z
|9 | East 1,732 1843 1805 5380 1732 1843 1805 5330 2,080
|10 ‘est 2,339 2394 2404 FO37 0 2339 2384 2404 37 2980
|11 South 997 1046 0 1034 3077 997 | 1046 1034 3077 17330
| 12| Central 2,556 3poe3 | 30900 9109 2856 3063 3080 9109 3550
| 13 | Market g,024 8346 8,333 24703 8024 8346 8333 24705 9940

14 -
14 [ 4 [» [#i,_Market drill_3Market Detail { Measures drill_#{ Measuresdrilz_ 1|4 | Il

» To access the sample drill-through report from Essbase Spreadsheet Add-in:
1. Select any drill-through cell; for example, cell G4.
Figure 189: Selecting a Drill-Through Cell
A [ B [ € [ b [ E [ F & [ w® T 1 [ 4 g
|1 Profit | Product
| 2 | Scenaria Actual J
| 3 | Jan Feh tlar Oitrl Jan Feh tlar Oitrl Jan
| 4 | Mew Yark 577 507 547 1F56 572 #07| 547 1556 520
|5 | Massachusetts 578 798 575 1532 578 498 575 1532 5707
| B | Flarida F3F FE7 377 1070 33 FFF 377 1070 007
|7 | Connecticut zz7 J08  Zg7 920 F77| 308 2d8 30 780
ER Mew Hampshire P B #4202 P B #4202 F77
|9 | East 1732 1843 1805 5380 1732 1843 1805 5380 2080
|10  west 2,339 2394 | 2404 | 7137 | 2339 2394 2404 7137 | 2880
|11 South 997 1046 1034 3077 997 | 1046 1034 3077 | 1330
12| Central 2 956 3063 3090 9109 255 3063 3090 9103 | 3550
| 13 Market 8,024 8346 | 8333 | 24703| B8024| 8346| 8333 24703 | 9940
14 =
14 [ 4 [» [#i,_Market drill_3Market Detail { Measures drill_#{ Measuresdrilz_ 1|4 | Il
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Note: You can also select a continuous range of cells in the sheet to display all
drill-through reports associated with cells you select. In this example, we have only
one drill-through report attached to the range of cells.
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2. Seclect Essbase > Linked Objects to open the Linked Objects Browser
dialog box.

Alternatively, select the Enable Linked Object Browsing check box in the
Essbase Options dialog box (Global tab), which enables you to double-click
a linked object cell to open the Linked Objects Browser dialog box. This
option works only with single-cell selection. If you select a range of cells, use
the Essbase > Linked Objects menu command.

Figure 190: Linked Objects Browser Dialog Box with Drill-Through
Entry Selected

i Linked Objects Browser -- Localhost:5ample:0LAP_TBC

Iember Combination:

Linked Objects:

Object Type Object Description Linked Object and Object Created By (L.

Diill Through ~ Essbase Integration Server  E Integration Server

« 2

Attach... | Edit. |£i.ew.-"Launc:h| [elete | Help | Lloze |

3. Select the drill-through report entry and click View/Launch.
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In the Select Drill-Through Report dialog box, select Market detail and click
Execute.

The results of the drill-through report are displayed in a spreadsheet.The
results of the Market Detail report shows that the regional director for the East
region is John West and that the population for New York is between
18,000,001-21,000,000.

Figure 191: Results of Market Detail Drill-Through Report

A | B [ c© ] D [ E ]
1 |[REGIONIDIRECTOR STATE | POPULATION_ALIAS

| 2 |East John West |Mew York 18,000,001--21,000,000

3

1

Note: If there is only one report available for the cells you select in the
spreadsheet, and if that report is not designed to be customized, drill-through
generates the report and immediately displays the results in the spreadsheet. The
person at your organization who develops drill-through reports specifies whether
you can customize a report and whether you need to log in to drill-through and the
relational data source.

Follow the steps in the next section, “Selecting Drill-Through Reports to View
or Customize” on page 228 to select a report to customize.

Selecting Drill-Through Reports to View or Customize

228 1

After you launch drill-through from the Linked Objects Browser dialog box,
Essbase Integration Services displays the Select Drill-Through Report dialog box
under the following conditions:

More than one drill-through report exists for the cell or cell range that you
select in the spreadsheet, or

Only one report exists, but you have the option of customizing it using the
Drill-Through Wizard.

The Select Drill-Through Report dialog box displays the list of drill-through
reports available for the cells you select in the spreadsheet. Depending on how a
report is defined in Essbase Integration Services Console, you may have access
only to view, not customize, the report.
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Note: Tasks that you should not perform as part of the tutorial are shown in light
colored boxes.

The sample report used for this tutorial is the Measures Detail report. You will use
the Drill-Through Wizard to customize this sample report.

» To execute a predefined drill-through report without customizing it, perform
these tasks:

1. Select the report that you want to view from the Available Reports
list box.
1. Click Execute.

Essbase Integration Services retrieves the data from the relational source and
displays the results in a new spreadsheet. The new sheet is added before the
current sheet.

» To customize the sample drill-through report:

1. In Essdt.123, select the Measures Detail tab.
Figure 192: Initial Drill-Through Report for Measures Detail
Market drill \ Market Detail \ Measures drilll \ Measures drilz_ Y} [Measures Detail\ Praduc
E

E A el ¢ [D [ F [ 6 |
1

2 Mew vork

3 Cola DietColz__]Caffeine Free Cola Colas  Cola

4 Sales fear 8,940 D 1} 8,940 6,518
5 Cost of Goods Sold ‘fear 3,573 0 1] 3673 783
B Margin ‘fear 5367 0 o 5,367 5,735
7 Total Expenses ‘fear 1,869 0 o 1.869 630
g |Profit fear 3498 0 1] 3498 5,105

2. Select Essbase > Connect and connect to the appropriate sample database.

Note: A specific sample database for drill-through is not automatically provided
with Essbase Integration Services. For information on the sample database,
contact the person at your organization who installs Essbase Integration Services
to set up a database for you.
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3. Select Essbase > Options and select the Style tab to define styles for this
sheet.

4. Inthe Data Cells option group, select the Integration Server Drill-Through
check box and click Format.

Essbase displays the Font dialog box.

Note: The style for drill-through cells may already be set as blue, bold, italic font
because you set the style in the previous exercise. If this is the case, then go to
Step 7.

Select Bold Italic from the Font style list box.

Select Blue from the Color drop-down list, and click OK to return to the
Essbase Options dialog box.

Figure 193: Font Dialog Box Selection

Font 21=]
FEont: Font style: Size:
[MS Sans Serit S old It 10 [ ok ]
5 efrif Regular af g .
MS Seri Italc B IlIl—I Corcel |
T News Gothic Bold 12
H News Gothic Condens Bold [talic 14
% Mimrod it 18
Onyx 24
B Perpetua LI LI LI
— Effect: — Sample
[ Stikeout
™ Underline AL
Lolor:
I- Blue vl Script:
IWestern VI

Note: In the Essbase Options dialog box, Essbase displays an example of the
selected style in the Sample box.
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Figure 194: Sample Style for Drill-Through Data Cells

Essbasze Options E
Dizplay I Zoom I Mode Style | Global I
— Member
— Sample
v
v Child Parent
I Shared LI
Farmat... |
— Dimension:
™ — Sample
I Measures
I Product LI
™| Cell Border:
Background Colar: I Mone j Earmat... |
—Diata Cell
— Sample
I Linked Objects = Sl
Imllirtegration Server Diill-Through fntegration Serv
™ Read Only LI
Farmat... |
Connection Infarmation:
’7 lzgal 7:EIS:Main ‘

QK I Cancel | Help |
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7. In the Essbase Options dialog box, select the Display tab and select the Use

Styles check box.

Figure 195: Setting the Use Styles Option

Essbase Options

[ ]
Display |Zoom I Mode I Style I Globall
~ Indentation — Replacement
" Nane HMissing Labsl: |0
& Subjterns
 Totaks #Mo Access Label: l—
— Suppre — Aliaze:
™ #Missing Fows IV Use Aliases
™ Zemo Rows ™ Use Both Member Names and Aliases
™ Underscore Characters far Raw Dimensions
Alias:
cele I Default j
V' Adiust Columng
= Auto Sort Fows Query Designer
V¥ Bepeat Member Labels ’7|_ Use Sheet Options with Query Designer
— Dynamic Time Serie
™ Latest Time Period IJan j
QK I Cancel | Help |

8. Click OK to close the Essbase Options dialog box.
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9. Select Essbase > Retrieve to display the new style in the spreadsheet.

In this example, the sample drill-through report is associated with every
member intersection at the state level in the East region, so that all data cells

associated with an Eastern state and children of Cola are now displayed in
blue, bold, italic font.

Figure 196: Sample File with Drill-Through Style Applied

A [ B[ ¢© [T © ] E [ F [ 6 | H |
1

| 2 | Mews ok Mazsachusetts
=N Cala Diet Cala | Caffeine Free Cala | Calas | Cola Diet Cala

| 4 | Sales ear g348 7 & G940 518 7

| 5 | Cost of Goods Sold | Year L8777 7 3573 FEF 7

| B | Margin “rear HIE7 7 7 5,367 E

| # | Tatal Expenses “rear Faeg 7 7 1,869 L%/ A

| & | Profit “rear Z498 7 & 3498 BN

» To access the sample drill-through report from the Essbase Spreadsheet Add-in:

1. Select any drill-through cell; for example, cell G6.
Figure 197: Selecting the Dirill-Through Cell for the Measures Detail Report
A [ B[ ¢© [T © ] E [ F [ 6 _ ] H [
1
Z Mews ok Mazsachusetts
=N Cala Diet Cala | Caffeine Free Cala | Calas | Cola Diet Cala
| 4 | Sales ‘Year a940 7 7 8,940 E578 &7
| 5 | Cost of Goods Sald | vear 2577 & 7 3573 A3 7
| 6| Hargin rear L3857 & 7 5,367 L]
| # | Tatal Expenses rear 1857 7 7 1,869 53 7
L8 | Profit ‘Year 2498 7 7 3,498 si0s 7

Essbase Spreadsheet Add-in for 1-2-3

Note: If Essbase Integration Services is not running, drill-through does not launch
properly. For more information, contact the Essbase system administrator.

Note: If you are prompted with the Drill-Through Login dialog box to connect to
Essbase Integration Services and the relational data source, enter the appropriate
connection information. The person at your organization who administers Essbase

Integration Services and develops drill-through reports should provide you with this
information.
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2. Seclect Essbase > Linked Objects to open the Linked Objects Browser
dialog box.

Alternatively, select the Enable Linked Object Browsing check box in the
Essbase Options dialog box (Global tab), which enables you to double-click
a linked object cell to open the Linked Objects Browser dialog box. This
option works only with single-cell selection. If you select a range of cells, use
the Essbase > Linked Objects menu command.

Figure 198: Linked Objects Browser Dialog Box with Drill-Through
Entry Selected

i Linked Objects Browser -- Localhost:5ample:0LAP_TBC

Iember Combination:
Linked Objects:
Object Type Object Description Linked Object and Object Created By (L.

Ciill Through ~ E Integration Server  Es Integration Server

« 2

Attach... | Edit. |£i.ew.-"Launc:h| [elete | Help | Lloze |

3. Select the drill-through report entry and click View/Launch.

The Select Drill Through Report dialog box is displayed.
Note: In the Select Drill Through Report dialog box, if the Customize button is
selectable, then you can customize the report. If more than one drill-through report

is displayed, then you can select from the different drill-through reports. In this
tutorial, only one report, “Measures detail,” is displayed and customizable.
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4. Select the Measures detail report from the Available Reports list box.
Figure 199: Selecting the Sample Drill-Through Report

Select Drill-Through Report (=[] =]

Available Reports Execute

Customize ...

Lancel

Help

i

5. Click Customize.

Note: The Customize button may be selectable or not selectable for any given
report, depending on how the report was defined in Essbase Integration Services
Console.

Essbase Integration Services displays the first screen of the Drill-Through
Wizard.

Figure 200: Drill-Through Wizard Dialog Box, Introductory Screen

Follow these steps to customize the transactional report
related to the OLAP intersections you have selected:

1. Select the columns to retrieve and define their
dizplay order.

2. Define a sort arder for colurmns.

3. Define filkers for columns.

Click the finizh button at any point to generate the report,

< Back Mest » Cancel Help
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6. Click Next to display the Select Columns and Display Order dialog box.
Figure 201: Select Columns and Display Order Dialog Box

Select Columns and Display Order E

Fepart Mame

IMeasures detail

Selected Columnz

: 5 MEASLIRES.CHILD
o MARKET MARKET STATE
.. PRODUCT FRODUCT.SKEU
- SCENARID
- Time

- SALES

SCEMARIO.SCENARID
Time. TRANSDATE
SALES AMOUNT

ove llp

i
< =
«

< Back | Mest » | Finizh I Cancel | Help |

7. Follow the steps in the next section, “Selecting and Ordering Columns” on
page 236, to select and order rows for the customized report.

Selecting and Ordering Columns

236 1

Using the Drill-Through Wizard, you can customize predefined drill-through
reports. The first task in the Drill-Through Wizard is selecting and ordering
columns to retrieve from the relational database. These columns contain detailed
information that is not available in the Essbase database.

In the Select Columns and Display Order dialog box, you can select which
columns you want Essbase Integration Services to retrieve from the relational data
source. From this dialog box, you can also specify how the columns are displayed
in the resulting report.

The Available Columns list box displays a list of columns available from the
relational data source for this report (as defined in Essbase Integration Services
Console). The Selected Columns list box displays the columns from the Available
Columns list box in expanded form. You can remove columns from the Selected
Columns list box to exclude them from the drill-through report.

Essbase Spreadsheet Add-in for 1-2-3



Using Drill-Through

In this example, the columns from the Available Columns list box are selected for
inclusion in the sample Measures detail report. These columns are displayed in
expanded form in the Selected Columns list box.

» To remove one of the selected columns from the drill-through report:

1. In the Selected Columns list box, select the MARKET.STATE column.
Note: To select multiple columns in the list that are not adjacent to each other, hold
down the Ctrl key and select each column. To select a range of columns, hold down

the Shift key and click the first and last columns in the list, which also selects all
columns in between them.

Figure 202: Selecting Columns to Remove From the Drill-Through Report

Select Columns and Display Order E

Fepart Mame

IMeasures detail

Available Columns Selected Columnz
(- MEASURES
+- MARKET
PRODUCT
SCENARIO
Time

PRODUCT.SKU
SCEMARIO.SCENARIO
Time. TRANSDATE
SALES.AMOUNT

Move Up

Move Down

Bl =[]
i 2

< Back | Mest » | Finizh I Cancel | Help |

2. Click to move the selected column from the Selected Columns list box
back to the Available Columns list box.

Note: To move a column from one list box to another, click or . To move
all columns from one list box to another, click or .
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3. Click Next to display the Select Data Sort Order dialog box, and follow the
steps in the following section, “Ordering Data” on page 238 to further
customize the report.

Note: When you finish customizing the report, click Finish at any time to generate
the report and view the results in a new sheet. The new sheet is placed before the
current sheet.

Ordering Data

In the Select Data Sort Order dialog box, you can select an ascending or
descending sort order for the data in a column. Sort order determines the order in
which rows will be displayed in the drill-through report. For example, you can sort
the contents of the Time. TRANSDATE column, which represents the transaction
dates, in ascending order in the drill-through report.

» To define the sort order of rows in the drill-through report:

1. In the Available Columns list box, select the Time. TRANSDATE column.

The columns in the Available Columns list box are those that you selected in
“Selecting and Ordering Columns” on page 236. The columns in the Column
list box are those for which a sort order has already been defined in Essbase
Integration Services Console.

If a data sort order was selected when the report was created in Essbase
Integration Services Console, the Order By list box displays that selection.
Otherwise, the default sort order is Ascending.
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2. Click to move the Time. TRANSDATE column to the Column list box so
that you can define a sort order for the column.

Note: To move a column from one list box to another, click or . To move
all columns from one list box to another, click or .
Figure 203: Moving a Column to the Column List Box for Sorting

Select Data Sort Order E

Fepart Mame

IMeasures detail

Available Columng I Colurnn | Order By |
ME&SURES.CHILD Time. TRANSDATE  Ascending

PRODUCT.SKU
SCENARIO.SCENARIO

ove llp

[mve Mo

[Hrden B

ElEIE
FELE

< Back Mest » Finizh Cancel Help
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3. In the Column list box, double-click the Time. TRANSDATE column to
change the data sort order from Ascending to Descending so that transaction
date values are displayed in reverse chronological order in the drill-through
report.

Figure 204: Selecting the Data Sort Order

Select Data Sort Order E

Fepart Mame

IMeasures detail

Available Columns I
ME&SURES.CHILD
PRODUCT.SKU
SCEMARIO.SCENARIO
SALES.AMOUNT

ove llp

> [mve Mo

<4 Order By...

L

< Back Mest » | Finizh I Cancel Help
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4. Click Next to display the Select Data Filters dialog box, and follow the steps
in the following section, “Filtering Data” on page 241 to further customize the
report.

Note: Tasks that you should not perform as part of the tutorial are shown in
light-shaded boxes.

» To change the data sort order for multiple columns at one time, perform these
tasks:

1. Hold down the Ctrl key and select the desired columns from the Column
list box.

2. Click Order By.
Essbase Integration Services displays the Order By dialog box.

Figure 205: Order By Dialog Box

DK |
Cancel |
Help |

3. Select Ascending or Descending and click OK to return to the Selecting
Data Sort Order dialog box.

Filtering Data

You can apply filters to determine what Essbase Integration Services retrieves for
the drill-through report. For any given column, you may want to retrieve only data
that meets certain conditions. For example, the MEASURES.CHILD column in
the sample database contains all children of the Measures dimension. In the sample
drill-through report, if you did not apply a filter to this list of measures, Essbase
Integration Services would retrieve all children from the relational source, because
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Using Drill-Through

the sample drill-through report applies to all children of Measures. In this section,
you will apply a filter to the MEASURES.CHILD column so that all children of
Measures, except Misc, are included in the report.

Note: When you apply a filter on a non-level 0 member using Essbase Integration
Services, the filter may return more members than expected. To work around this
problem, use the Drill-Through Wizard.

» To define a filter:
1. Select the MEASURES.CHILD column from the Column list box.

The columns in the Column list box are those that you selected in “Selecting
and Ordering Columns” on page 236.

Figure 206: Select Data Filters Dialog Box

Select Data Filters E

[ Condtion | add. |

PRODUCT.SKU ﬂl
SCENARID.SCENARID
Tirme. TRANSDATE Clear Al |
SALES.AMOUNT

Condition

< Back | dEwt | Finizh I Cancel | Help |

Note: If there is a filter already attached to the column, it is displayed in the
Condition list box. The full string of the filter is displayed in the lower Condition
text box.
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2. With the MEASURES.CHILD column selected, clic

The Set Filter on Column dialog box is displayed.

Figure 207: Set Filter on Column Dialog Box

Using Drill-Through

k Add.

Set Filter On Column : CHILD E
Filters |
Colurnm: Operator: Condition:
Era—— 5 -
dd | Add Type
 And
@ 0r
Filters:
1 _>l_I
QK I Cancel | Help |

Select CHILD from the Column drop-down list box.

The column displayed in the Column drop-down list box is the one that you

selected in “Filtering Data” on page 241.

Select the <> operator, which represents not equal to
drop-down list box.

, from the Operator

Note: You can select multiple values at one time only if you have selected In or Not
In as the filter operator. For more information on filter operators, see the

Drill-Through online help.
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Using Drill-Through

5. Click the Browse E' button to open the Select Filter Values from the List
dialog box, which lists all possible values for that column.

The Select Filter Values from the List dialog box is displayed.

Note: Essbase Integration Services retrieves these values directly from the
relational data source. If the relational data source contains many values, Essbase
Integration Services confirms if you want to view them all before it retrieves them

from the data source.

6. In the Select Filter Values from the List dialog box, select Misc and click
OK. The Set Filter On Column dialog box is displayed.

Figure 208: Selecting Filter Values from the List

Select Filter ¥alues from the List

Walue

Additions

COGS

Ending Inventory
Inventory

M argin

Margin %

M arketing

Opening lrventory
Pagrall

Prafit

Prafit %

Profit per Ounce

R atios

Sales

Total Expenzes

Lancel

Help |

| o |
_Goneel |
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Using Drill-Through

7. Click Add to add the condition to the Filters list box.

Note: For information on using multiple filter conditions, see the Intergration
Server Drill-Through online help.

The Set Filter on Column dialog box should now look like Figure 209:

Figure 209: Defining a Filter for a Column

Set Filter On Column : CHILD E

Filters |

Colurnm: Operator: Condition:

[crico = o = [

Sl Add Type

 And
@ 0r

Filters:

ME&SURES.CHILD <> Misc’ ;I

¥
4 ¥

QK | Cancel | Help |

The filter defined above causes all children of Measures, except Misc data, to
show in the drill-through report.

Note: The Add button becomes unselectable after creating the first filter, but
becomes selectable when you create another filter. In this tutorial, you are creating
only one filter. The And and Or options are used when combining multiple filters.
The default value is Or, which means that Essbase Integration Services applies the
filter if any of the conditions you specify are met. If you select And, Essbase
Integration Services applies the filter only if all the conditions are met.
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Using Drill-Through

8. Click OK to return to the Select Data Filters dialog box. Notice that the filter
defined in the Set Filter on Column dialog box is displayed in the Condition
list box and text box of the Select Data Filters dialog box.

Figure 210: Result of Defining a Filter for a Column

Select Data Filters

Calumn

| Condition |

MEASURES.CHILD
MARKET STATE
PRODUCT.SKU

Time. TRANSDATE
SALES AMOUNT

Condition

SCEMARIO.SCENARIOD

MEASURES.CHILD <> Misc’

LClear |
Clear Al |

ME&SURES.CHILD <> Misc' ;l
I
< Back | dEwt | Finizh | Cancel | Help |

Note: You can also create a filter by typing the filter conditions directly into the
Filters list box of the Set Filter on Column dialog box. For more information, see
the Drill-Through online help.

To delete a filter, select the filter and click Clear. To delete all filters, click Clear All.
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Using Drill-Through

9. Click Finish.

Essbase Integration Services generates the customized drill-through report
and displays the results in a new spreadsheet. The new spreadsheet is added to
the workbook before the current spreadsheet.

Figure 211: Customized Drill-Through Report

A [ B ]| [ [ D [ E ]
1 [CHILD ISkl SCENARIO TRANSDATE AMOUNT

| 2 |Additions 100-10 | Actual 2000-12-09 00:00:00.000 | 12397
| 3 coGs 100-10 | Actual 2000-12-0900:00:00.000 5153
| 4 |Marketing 100-10 | Actual 2000-12-09 00:00:00.000 16.94
| & |Payral 100-10 | Actual 2000-12-0900:00:00.000 | 2387
| B |Sales 100-10 | Actual 2000-12-0900:00:00.000 | 3927
| 7 |Additions 100-10 | Actual 2000-12-04 00:00:00.000 | 37.03
| 8 [coGs 100-10 | Actual 2000-12-04 00:00:00.000 15.41
| 9 |Marketing 100-10 | Actual 2000-12-04 00:00:00.000 5.06
| 18 |Payrol 100-10 | Actual 2000-12-04 00:00:00.000 713
| 11 |Sales 100-10 | Actual 2000-12-04 00:00:00.000 117.3
| 12 |Additions 100-10 | Actual 2000-11-28 00:00:00.000 | 5382
|13|coGs 100-10 | Actual 2000-11-28 00:00:00.000 195
| 14 |Marketing 100-10 | Actual 2000-11-28 00:00:00.000 624
| 15 |Payrall 100-10 | Actual 2000-11-28 00:00:00.000 B.0R
| 16 |Sales 100-10 | Actual 2000-11-28 00:00:00.000 | 11804
| 17 | Additions 100-10 | Actual 2000-11-19 00:00:00.000 | 15318
|18 |coGs 100-10 | Actual 2000-11-19 00:00:00.000 555
| 19 |Marketing 100-10 | Actual 2000-11-19 00:00:00.000 17 76
| 20 |Payral 100-10 | Actual 2000-11-1900:00:00.000 2294
| 21 |Sales 100-10 | Actual 2000-11-1900:00:00.000 33596
| 22 | Additions 100-10 | Actual 2000-10-16 00:00:00.000 191
|23 |coGs 100-10 | Actual 2000-10-16 00:00:00.000 72

In this sample, the customized drill-through report reflects the specifications that
you set using the Drill-Through Wizard:

e The Time. TRANSDATE column is sorted in descending order, displaying the
transaction dates in reverse chronological order.

e All children of Measures, Additions, COGS, Marketing, Payroll, Sales, and
Opening Inventory, except Misc, are displayed as you specified in the filtering
part of the Drill-Through Wizard.
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Using Drill-Through

Disconnecting from Essbase

When you finish using drill-through, disconnect from the Essbase server to free up
a port on the server for other Essbase Spreadsheet Add-in users.

» To disconnect from the server:
1. Select Essbase > Disconnect.

Essbase displays the Essbase Disconnect dialog box, where you can
disconnect any spreadsheet that is connected to a database.

Figure 212: Essbase Disconnect Dialog Box

Essbase Disconnect E

Sheet ServerApplication-> D atabase

[ <DAEIS D

Note: Essbase may return an error message when you attempt to disconnect after
using drill-through. If an error message is returned, select Essbase > Retrieve from
the sheet and then disconnect.

2. Select a sheet name from the list and click Disconnect.
Repeat Step 2 until you have disconnected from all active sheets.

Click Close to close the Essbase Disconnect dialog box.

Note: You can also disconnect from the server by closing Lotus 1-2-3. An
abnormal termination of a Lotus 1-2-3 session, such as a power loss or system
failure, does not disconnect your server connection.
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Symbols

#Missing strings, suppressing, 70
#NoAccess strings, suppressing, 71
* wildcard character, 109

? wildcard character, 109

A

access
to databases, 45, 120
to Essbase data, 45, 120
to linked partitions, 190
to linked reporting objects, 181
to multiple databases, 189
to online help, 35
using Essbase commands, 43
with drill-through, 221
Acrobat Reader. See Adobe Acrobat Reader
ad hoc reports, 19, 48, 143, 207
Add button, 243
Add-in Manager, 32
adding members. See members, adding
adjusting columns. See columns, adjusting width
administrators, 20
Adobe Acrobat Reader, ix
advanced interpretation engine, 163
Advanced Interpretation mode, 163, 170
aliases
definition of, 82
displaying
process of, 83
with member names, 84
with Query Designer results, 105
in tables, 82

Essbase Spreadsheet Add-in for 1-2-3

alternate dimensions. See dimensions, alternate
alternate names. See aliases
ancestors, definition of, 28
AND operators, 106
APIL, 23
application designer, 20
application partitions. See linked partitions
application programming interface, 23
applications/databases

Sample Basic, 32, 44, 47, 121

sample for drill-through, 220

Sample Interntl, 203

Sample Xchgrate, 203
ascending sort order

with drill-through, 238

with Query Designer, 134
asymmetric reports

definition of, 137

pivoting, 139

retrieving data into, 137
Attach Linked Object dialog box, 174, 177, 179
attaching reporting objects to cells. See linking
attaching to databases. See connecting
attributes, drill down, 53
auditing updates, 195
auto logouts, 116
Auto Sort Rows option, 166

blank

columns, 139

rows, 139
blocks, locking data, 193
Boolean operators, 106, 110
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C linking notes to, 177

linking URLs to, 178
retrieving a range, 149
retrieving single values, 152

Calculation command, 195
Calculation dialog box, 196

calculations selecting nonadjacent, 65
database status, 196 with nondatabase values, 139

databas.es, 156, 195 Change Password dialog box, 48
dynarplc, 156 o changing
reducing calculation time, 156 passwords, 48

scrip ts,.196 . . row and column orientation, 59
specifying latest time period, 159 spreadsheet format, 73
substitution variables, 161 ’

: varia - styles, 73

Wlt.h Dynamic Tlme Series, 159 children (defined), 28
canceling data retrievals, 50 Clear All button, 246
Cascade command, 197 Clear button, 246

Cascade Information page, 198

. : Clear command, 50
Cascade Options dialog box, 198

clearing styles, 82

cascading sheets click (defined), 36
creating table of contents, 201

ting client

destination, 199 components, 21

format, 201 . software, 31

level of detail, 198 upgrading with server, xv

names, 200 client-server environment, 21

output type, 199 collapsing data views. See drill
cell notes o colors, setting, 73

accessing linked, 183 columns

linking to cells, 177 adjusting width, 44, 142
cell ranges blank, 139

keeping, 63

: displaying as rows, 59
removing, 66

ovi displaying selected, 63
retrieving, 149 . filtering by, 128
selecting nonadjacent, 65 keeping selected, 63
with drill-through, 226 nested, 52 ’

cells L . pivoting, 59
accessing linked partitions, 190 removing selected, 66
applying styles, 73, 80 retrieving into, 52
attaching reports. See linking columns, drill-through
attaching URLs. See linking choo;ing 36

EssCell function in, 152 selecting display order, 236

formatting, 73, 80, 176 selecting for retrieval from relational source, 236
in data cells, 80 sorting, 238

of dimension members, 77

commands
of Dynamic Calculation members, 157 Calculation, 195
of parent members, 74 Cascade, 197
formulas in, 139, 142, 145, 152 Clear, 50
linked reporting objects, 173, 178 Connect, 45, 120, 189

linking files to, 173
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Currency Report, 203, 207

Disconnect, 115

FlashBack, 50

Keep Only, 63

Linked Objects, 173, 178

Lock, 193

Member Selection, 107

Navigate Without Data, 66, 69

Pivot, 59

Remove Only, 66

Retrieve, 49

Retrieve & Lock, 193

Send, 193

Undo, 50

Unlock, 194

Zoom In, 51

Zoom Out, 55
comparison operators, 106, 129
computing environment, vii
concurrent

database access, 47, 189

updates to server, 193
conditional retrievals, 126
Connect command, 45, 120, 189
connecting

to a database, 45, 120

to a relational data source, 209, 221, 233

to Essbase, 46, 120

to Essbase Integration Server, 221, 233

to multiple databases, 189

viewing current connections, 190
connecting. See also disconnecting
Connection Information text box, 190, 196
consolidations (defined), 29
conversions, currency, 203
creating queries, 90
creating reports. See reports, creating
Currency Conversion product, 23
currency conversions

modifying exchange rates, 207

reporting, 207

sample databases, 204

settings, 207
Currency Report command, 203, 207
Currency Report dialog box, 207
current time period. See Dynamic Time Series
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cursors (Essbase), 49

custom applications, 23 to 24
Customize button, 235

customizing drill-through reports, 229

D

data
calculating, 195
changing orientation, 59
comparison operators, 129
displaying, 25, 49
dynamically calculating, 156
filtering, 126
filtering, with drill-through, 246
formatting, 73
locking, 193
missing, 71
modifying, 193
navigating, 29, 66
pivoting, 59
relational, with drill-through, 209
removing subsets, 66
retaining subsets, 63
retrieving. See retrieving
sorting, 126
unlocking, 194
updating, 193, 195
data sort order, with drill-through, 238
data source, relational, 233
databases
calculating. See calculations
connecting. See connecting
consolidations, 29
defined, 24
dimensions, 27
disconnecting from, 115
linked. See linked partitions
loading, 47, 122
locking, 193
members, 27
organization, 26
outlines, 29
queries. See queries, 88
restoring previous views, 50
rules, 26
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sample, 44, 203, 220

selecting. See connecting

switching, 189

viewing connections, 190
deleting

filters, drill-through, 246

selected members, 66

styles, 82
descendants (defined), 28
descending sort order

with drill-through, 238

with Query Designer, 134
Destination Options page, 199
destinations

cascaded sheets, 199

Query Designer queries, 99
detaching. See disconnecting, 115
dialog boxes, Help buttons, 35
dimensions

alternate, 24

applying styles, 77

currency conversion and, 203

described, 24, 27

drilling down on, 51 to 52

drilling up on, 55

naming elements, 27

pivoting, 59
disabling data retrieval. See navigating without data
Disconnect

command, 115

dialog box, 116
disconnecting

forced logouts, 116

from Essbase, 115

from Essbase Integration Server, 248
discontinuous rows and columns, 65
disk space, effect on Dynamic Calculation, 156
display

options, 73

order of columns, drill-through, 236
Display page (Essbase Options dialog box), 38, 214
Display Unknown Member option, 142, 144
displaying data, 25, 49
distributed sheets. See cascading sheets
double-clicking

defined, 36

252 |

enabling
for drilling, 36
for linked object browsing, 181, 191, 227, 234
downloading Acrobat Reader, ix
drag, defined, 36
drag-and-drop operations, 59
drill
by double-clicking, 36
down on attributes, 53 to 54
down on consolidations, 29
Formula Fill, 145
retain formulas during, 145
to less detail, 55
drill-through
accessing, 211, 221
cells, defining styles for, 221
described, 209
installing, 213
multiple reports, 210
requirements, 213
sample
database, 220
drill-through report, 220
file, 222
styles for cells, 211
tutorial guidelines, 214
Drill-Through Wizard
dialog box, 235
introductory screen, 235
duplicating sheets. See cascading sheets, 197
Dynamic Calculation members, applying styles to,

157
Dynamic Time Series
defined, 159

specifying latest time period, 160 to 161

E

Edit Cell Note dialog box, 184
Edit menu, 50
Edit URL dialog box, 187
editing

cell notes, 183

linked files, 182

URLs, 185, 187
editing in cells, 36
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Enable Hybrid Analysis option in Zoom page
(Essbase Options dialog box), 40
enabling
FlashBack setting, 51
mouse actions, 36, 181, 191
Navigate Without Data, 67
environment (computing), vii
Essbase
API, 23
architecture, 21
Cascade Options dialog box, 198
computing environment, vii
connecting to. See connecting
Disconnect dialog box, 116
disconnecting from. See disconnecting
Member Selection dialog box, 107, 113
Member Selection dialog box, from Query
Designer, 92
menu, 34
migration information, xv
Options dialog box, 38, 122, 214
starting a session, 34
System Login dialog box, 45, 120
upgrades, xv
Essbase Integration Server, 23, 209
Essbase Integration Server drill-through. See
drill-through
EssCell function, 152
error messages, 155
syntax, 153
exchange rates, 203
Execute button, 235
executing drill-through reports, 228 to 229
expanding data views. See drill down
expanding formulas when drilling, 146
external files, 173

F

files
accessing linked, 181
destinations
cascaded sheets, 199
linking to data cells, 173
sample for tutorial, ix, 119
filtering data, 126
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filters
operators, 243
with drill-through, 246
Find Member dialog box, 109
finding members, 106, 109
FlashBack command, 50
font
formats, 75
style list, 76
Font dialog box, 76
forced logouts, 116
formatted sheets
pivoting in, 143
retrieving data into, 139
formatting
data cells
linked objects, 176, 191
read/write, 80
read-only, 80
dimension members, 77
displaying aliases, 82
displaying aliases and names, 84
Dynamic Calculation members, 157
enabling styles, 76
linked object cells, 176, 191
options for cascaded sheets, 201
parent members, 74
repeating member labels, 85
spreadsheets, 73
text and cell styles, 80
Formula Fill option, 146, 148
Formula Preservation mode
Formula Fill, 145
pivoting in, 143
restrictions with, 143, 146
Retain on Keep and Remove Only, 145
Retain on Retrieval, 142, 145
formulas
EssCell, 152
expanding when drilling, 146
in cells, 139, 146
preservation
effects on other operations, 146
enabling, 142, 145
restrictions with, 143
free-form reporting
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entering generation and level names in, 170
in Advanced Interpretation mode, 163
in Free-Form mode, 166
retrieving data, 163
Free-Form retrieval mode, 166
guidelines, 166
functions. See macro functions

G

generations

defined, 28

entering names in spreadsheet, 170
Global page (Essbase Options dialog box), 36

H

Help buttons, 35

Help, accessing, 35

Hybrid Analysis, xvi
Enabling in the Zoom page (Essbase Options

dialog box), 40

Hyperion Essbase
intended audience, 20
products of, 22

Hyperion Essbase Spreadsheet Add-in
accessing drill-through from, 221
logging data updates, 195
retrieval cursors, 49
starting, 34
users, described, 20

in-cell editing, 36

installation, drill-through, 213

Integration Server drill-through. See drill-through
Internet, linking cells to URLs, 178

Interntl sample database, 204

K

Keep Only command
described, 63
in Formula Preservation mode, 145

254 H

L

labels
applying styles, 77
displaying with aliases, 84
entering in spreadsheet, 163, 166
member names. See member names
repeating, 85
LAN. See networks
Latest Time Period option, 160
latest time period, specifying, 159
levels
cascading by, 198
defined, 28
drilling down, 56
drilling in, 56
entering names, 170
linked objects
partitions. See linked partitions
reporting objects. See linked reporting objects
Linked Objects Browser dialog box, 188, 191, 227,
234
LROs, 173
Linked Objects command, 174, 177, 179
linked partitions
access privileges, 192
accessing from spreadsheet, 190
cells, applying styles, 191
Linked Reporting Objects
accessing from spreadsheet, 181
applying styles, 176
cell notes, 177
creating, 173
external files, 173
URLs, 178
linking
cell notes, 177
external files, 173
partitions, 190
URLs to data cells, 178
list, cascaded sheets, 201
local area network. See networks
Lock command, 193
locking data blocks, with multiple users, 193
logging
off of Essbase. See disconnecting
on to a relational data source, 233
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on to Essbase Integration Server, 233

on to Essbase. See connecting, 45
logging data updates from spreadsheet, 195
logical operators, 110
logouts, forced or auto, 116
Lotus 1-2-3

clearing formats, 82

mouse actions, 36

sample tutorial files, 119

status bar, 34

macro functions

EssCell, 152

Spreadsheet Toolkit, ix, 22, 35
main menu (Essbase), 34
manual calculation mode, 155
Member Information dialog box, 108
member names

aliases for, 82

alternate. See aliases, 82

applying styles, 74

displaying with aliases, 84

entering in spreadsheet, 163, 166

formatted sheets, 139

indenting, 29

repeating, 85

with EssCell function, 153
Member Preview dialog box, 112 to 113
Member Retention option, 57
Member Selection command, 107
Member Selection dialog box, 107
Member Selection Preview dialog box, 97
Member Selection, with Query Designer, 92
members

adding, 92

aliases for, 82

ancestors, 28

applying styles, 74, 77

children, 28

collapsing, 55

defined, 27

deleting, 66

descendants, 28

deselecting, 114
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drilling down on, 52
drilling up on, 55
Dynamic Calculation, 156
Dynamic Time Series, 159
finding, 106, 109
generations, 28
levels, 28
names. See member names
parents, 27
retaining, 63
selecting, 93, 106
siblings, 28
menu, Essbase, 34
messages (Essbase)
database calculation status, 196
display options, 144
EssCell, 155
unknown member, 142
migrating to release 6, xv
missing values
suppressing, 70
suppressing disabled, 146
missing values, suppressing
in cascaded sheets, 201
unavailable, 146

Index

Mode page (Essbase Options dialog box), 41, 124,

146
money. See currency conversions
mouse actions, enabling, 35
moving
rows and columns. See pivot
through worksheets, 66
multidimensional databases. See databases

multiple filter conditions, with drill-through, 245

N

Named Pipes protocol, 22
names
alternate. See aliases
applying styles, 74
displaying with aliases, 84
entering generation, 170
entering level, 170
repeating, 85
Navigate Without Data command, 66, 69

B 255



Index

nested columns or rows, 52
networks, 22

Next Level option, 56, 198
nonadjacent cells, 65

notes, linking to data cells, 177
null values, 153

numeric values, preserving, 140

o)

Objects product, 24
ODBC clients, 23
OLAP
defined, 19
server. See server
online analytical processing, 19
online help
displaying for spreadsheet, 35
opening
Essbase, 34
operating systems, 22
operators, comparison, 106, 129
options
Cascade, 198
Display, 38, 122,214
Global, 36, 42, 125,219
Mode, 41, 124, 146, 217
settings for advanced tutorial, 122
settings for basic tutorial, 38
settings for drill-through tutorial, 214
Style, 75
Zoom, 40, 56, 123, 216
Options dialog box, 38, 214
OR operators, 106
Order By dialog box, 241
ordering
columns, drill-through, 236
rows, drill-through, 238
outlines
consolidations, 29
described, 26
dimensions, 27
Dynamic Calculation members, 156
Dynamic Time Series members, 159
members, 27
output, cascaded sheets, 198
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overlapping styles, 81

P

parent members
applying styles to, 74
defined, 27
Partitioning product. See linked partitions
partitions. See linked partitions
passwords
changing, 48
entering, 121
pattern matching, 110
pivot
asymmetric reports and, 139
by dragging, 60
described, 36, 59
effect on text, 141
formatted sheets and, 143
formula preservation and, 143
rows or columns, 59, 139
unavailable, 141
without retrieving data, 68
Pivot command, 59
power loss, 116
preferences. See options, 36
preserving formulas, 142, 149
primary mouse button, 35
printer destination, cascaded sheets, 199
programming interface, 23

Q

queries
applying styles, 101
creating, 90
defining, 88
deleting, 101
retrieving, 88
saving, 99

Query Designer
applying option settings, 105
connecting to multiple databases, 104
creating queries, 91
data filtering panel, 128
data sorting panel, 134
filtering data, 126
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hint panel, 88

layout panel, 91

messages, 137

messages and confirmations, 101
navigation panel, 88

properties panel, 88

save as query dialog box, 99
sorting data, 134

R

read/write cells, 80
read-only cells, 80
relational data source, 233
relational databases, accessing with drill-through,
209

remote databases. See linked partitions, 190
Remove Only command

described, 66

in Formula Preservation mode, 145
Remove Unselected Groups option, 146
removing. See deleting, 66
Repeat Member Labels option, 85
report script commands, 166, 168
reports

ad hoc, 48, 143

ad hoc currency, 207

asymmetric, 137

creating multiple, 197

formatted, 139

free-form, 163

methods of generating, vii

saving, 115
reports, creating

ad hoc, 207

Cascade, 197

Member Selection, 106

methods, vii

Query Designer, 88
reports, drill-through

accessing, 221

customizing, 211, 229

disconnecting from, 248

executing, 228

selecting to view or customize, 228
restoring database views, 50
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restrictions, with Formula Preservation, 146
Retain on Keep and Remove Only option, 146
Retain on Retrieval option
disabled, 146
enabled, 142, 146
Retain on Zooms option, 146, 148
retaining
data subsets, 63
formulas, 139, 141
when drilling, 145
when retaining data, 145
when retrieving, 142, 145
selected members, 63
Retrieve & Lock command, 193
Retrieve command, 49
retrieving
Advanced Interpretation mode and, 163
canceling, 50
conditional, 126
currency conversion, 203
cursors, 49
data, 44
Dynamic Calculation members, 156
formula preservation and, 145
Free-Form mode and, 166
functions, 152
increasing speed, 82, 137, 149, 156
into asymmetric reports, 137
into columns, 52
into formatted sheets, 139
rules for, 140
into rows, 52
less detail, 55
modes, 163
more detail, 51
performance impact, 82, 137, 156
range of cells, 149
retaining formulas and, 142, 145
selected cells, 149
starting process and, 48
suppressing data and, 66
reverting to previous database view, 50
rows
blank, 139
deleting during pivot, 139
displaying as columns, 59
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displaying selected, 63
filtering by, 128

keeping discontinuous, 65
nested, 52

pivoting, 59

removing selected, 66
retrieving into, 52

sorting within, 134
suppressing values in, 70, 201

S

sample
databases
connecting to, 47, 204
described, ix, 44, 203
databases, in drill-through, 220
files for tutorial, location, 119
Sample Basic
connecting to, 47
described, 44
Sample directory, 119
Save As command, 115
Save command, 115
saving
queries, 99
worksheets, 115
secondary mouse button, 35
select (defined), 36
Select Calc Script option, 196
Select Columns and Display Order dialog box,
236 to 237
Select Data Filters dialog box, 242
Select Data Sort Order dialog box, 238
Select Drill-Through Report dialog box, 228, 235
Select Filter Values from the List dialog box, 244
selecting
cells to keep, 63
cells to remove, 66
latest time period, 159
members, 106
nonadjacent cells, 65
range of cells for retrieval, 149
Send command, 193
sending
data to server, 193
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log file, 195
server, 21
changing password, 48
client-server environment, 21
connecting to, 46, 120
described, 21
disconnecting from, 115
Essbase Integration Server, 23, 209
Essbase OLAP, described, 21
logging updates to, 193
migrating to release 5, with client, xv
name, 46, 120
on network, 22
sending data to, 193
Set Filter on Column dialog box, 243
shared members, applying styles to, 75
sheet destination, Cascade option, 199
sheets. See worksheets
shortcuts, mouse actions, 36
siblings (defined), 28
sort order
with drill-through, 238
with Query Designer, 134
sorting criteria, 126
Spreadsheet Toolkit product, 22
spreadsheets
applying styles, 73
cascading, 197
creating multiple, 197
data update log file, 195
described, 24
displaying aliases, 83 to 84
displaying member names, 84
distributing, 197
drilling options, 56
global options, 36, 51, 144
mode options, 145, 163
preserving formulas, 145
repeating member labels, 85
retrieving data, 44
saving, 115
setting options, 38
style options, 73
suppressing missing and zero values, 70
zoom options, 56
SQL Interface, 23
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data retrieval, 49
drill-through, 221
Hyperion Essbase, 34

Hyperion Essbase Spreadsheet Add-in, 34

status bar, enabling and disabling, 34
status of database connections, 190
Style page (Essbase Options dialog box), 75
styles
applying
to data cells, 80
to dimension members, 77
to dimensions, 77
to drill-through cells, 221
to linked partition cells, 191
to linked reporting object cells, 176
to members, 74
to parent members, 74
to Query Designer results, 105
to shared members, 75
clearing, 82
defining, 74 to 75
hierarchy of, 81
overlapping, 81
removing, 82
selecting members, 75
stored in ESSBASE.INI, 79
turning off, 82
turning on, 76
Subset dialog box, 110, 112
subsets
defining members, 110
removing, 66
retaining, 63
substitution variables, 161 to 162
suppressing
data retrieval, 66
disabled, 146
missing and zero values, 70
underscore characters, 70
symmetric reports, 137
system administrator, 20
system failure, 116
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Index

T

table of contents, with Cascade, 201
TCP/IP protocol, 22
terminating database connections. See disconnecting
termination, abnormal, 116
text

entering free-form, 163

formatting, 76

hierarchy of styles, 81

pivoting. See pivot

preserving formatted, 140
time periods, 159
title members, with drill-down, 52
to-date calculations, specifying, 159
tracking data updates, 195
transaction-level data, accessing with drill-through,

209

transparent partitions. See linked partitions
transport protocol, 22
tutorial

basic tasks, 31

guidelines, 43

preparing for, 38

U

UDA. See user-defined attributes, 110
underscore characters, suppressing, 72
Undo command. See FlashBack command
undoing actions, 50
Unlock command, 194
unlocking data blocks, 194
Update Mode, 193
updating
data, 193
log file, 195
upgrading, xv
up-to-date calculations, 159

URLs
accessing linked, 185
editing, 187

length limits, 180

linking to data cells, 178
Use Aliases option, 83
Use Both Member Names and Aliases option, 85
Use Sheet Options with Query Designer option, 105
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Use Styles option, 76
User-Defined Attributes, 110
username, entering, 121
users, 20

\')

V2.x mode, 166

VBA functions, ix

viewing
active connections, 190
aliases, 82
aliases and names, 84
data in spreadsheet, 48
Dynamic Calculation members, 157
Essbase menu, 34
fewer members. See drill
linked partitions, 190
linked reporting objects, 181
more members. See drill
multidimensional data, 25
online help, 35
repeated member labels, 85
spreadsheet without data, 66
styles, 76

views, restoring, 50

Visual Basic for Applications. See VBA functions

visual cues. See styles

w

Web resources, linking to data cells, 178
wildcard characters, 109
Within Selected Group option, 58, 137
worksheets

formatting, 73

navigating without data in, 66
World Wide Web, linking to data cells, 178

X

Xchgrate sample database, 204

V4

zero values
suppressing, 70, 72
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suppressing disabled, 146
Zoom commands, customizing, 56
Zoom In command
drilling down options, 51
selecting levels, 56
Zoom Out command, drilling up options, 55
Zoom page (Essbase Options dialog box), 40, 56
Enable Hybrid Analysis option, 40
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